Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034018
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 03. Procurement managementmajoralways2016-09-19 15:402016-09-20 02:11
ReporterlorenzofidalgoView Statuspublic 
Assigned Tomarkmm82 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q4
StatusclosedFix in branchFixed in SCM revision9388451efb97
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toaferraz
Web browserGoogle Chrome, Mozilla Firefox
ModulesCore
Regression levelPackaging and release
Regression date2016-09-16
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/df9155c88ab2 [^]
Triggers an Emergency PackNo
Summary

0034018: Posting a Purchase Invoice is not possible with "F&B España, S.A. - Finanace - F&B International Group" role. NPE is thrown

DescriptionTrying to post a Purchase Invoice an error message is thrown with the following message: "java.lang.NullPointerException".
I have been able to reproduce this issue in pi but not in main.
Steps To Reproduce0-Login POS as Openbravo and using F&B España, S.A. - Finanace - F&B International Group role, go to "Purchase Invoice" window.
1-Click "Create a new record in form" button and choose "Bebidas Alegres, S.L." as "Business Partner".
2-Go to "Lines" tab and create a new record. Select "Cerveza Ale 0,5L" in "Product" field.
3-Save and Complete that record.
4-Now, try to Post that record. DEFECT: An error message with the following message will appear: "java.lang.NullPointerException".(check attached image).
TagsNo tags attached.
Attached Filespng file icon NPEPostingAPurchaseInvoice.png [^] (125,289 bytes) 2016-09-19 15:40

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00340193.0PR16Q3.2 closedmarkmm82 Posting a Purchase Invoice is not possible with "F&B España, S.A. - Finanace - F&B International Group" role. NPE is thrown 
depends on backport 00340203.0PR16Q2.3 closedmarkmm82 Posting a Purchase Invoice is not possible with "F&B España, S.A. - Finanace - F&B International Group" role. NPE is thrown 
caused by design defect 0024191 closeddmiguelez Accounting background process has bad performance 

-  Notes
(0090082)
hgbot (developer)
2016-09-19 21:20

Repository: erp/devel/pi
Changeset: 9388451efb9743b62a9df24513fb5ae91dbed888
Author: Mark <markmm82 <at> gmail.com>
Date: Mon Sep 19 11:33:17 2016 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/9388451efb9743b62a9df24513fb5ae91dbed888 [^]

Fixes issue 34018: Is possible posting a Purchase Invoice with Finance role

Modified the OrganizationStructureProvider.getPeriodControlAllowedOrganization() method to execute in Admin mode.

---
M src/org/openbravo/dal/security/OrganizationStructureProvider.java
---
(0090084)
aferraz (developer)
2016-09-19 21:27

Code review + Testing OK
(0090097)
hudsonbot (developer)
2016-09-20 02:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/3f07553793a6 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-09-19 15:40 lorenzofidalgo New Issue
2016-09-19 15:40 lorenzofidalgo Assigned To => Triage Finance
2016-09-19 15:40 lorenzofidalgo File Added: NPEPostingAPurchaseInvoice.png
2016-09-19 15:40 lorenzofidalgo Web browser => Google Chrome, Mozilla Firefox
2016-09-19 15:40 lorenzofidalgo Modules => Core
2016-09-19 15:40 lorenzofidalgo Regression level => Pre packaging ( pi )
2016-09-19 15:40 lorenzofidalgo Regression introduced in release => pi
2016-09-19 15:40 lorenzofidalgo Triggers an Emergency Pack => No
2016-09-19 15:41 lorenzofidalgo Web browser Google Chrome, Mozilla Firefox => Google Chrome, Mozilla Firefox
2016-09-19 15:41 lorenzofidalgo Summary Posting a Purchase Invoice is not possible. NPE is thrown => Posting a Purchase Invoice is not possible with "F&B España, S.A. - Finanace - F&B International Group" role. NPE is thrown
2016-09-19 16:00 aferraz Relationship added caused by 0024191
2016-09-19 16:00 aferraz Assigned To Triage Finance => markmm82
2016-09-19 16:00 aferraz Status new => scheduled
2016-09-19 16:05 aferraz Web browser Google Chrome, Mozilla Firefox => Google Chrome, Mozilla Firefox
2016-09-19 16:05 aferraz Regression level Pre packaging ( pi ) => Packaging and release
2016-09-19 16:05 aferraz Regression date => 2016-09-16
2016-09-19 16:05 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/df9155c88ab2 [^]
2016-09-19 21:20 hgbot Checkin
2016-09-19 21:20 hgbot Note Added: 0090082
2016-09-19 21:20 hgbot Status scheduled => resolved
2016-09-19 21:20 hgbot Resolution open => fixed
2016-09-19 21:20 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9388451efb9743b62a9df24513fb5ae91dbed888 [^]
2016-09-19 21:27 aferraz Review Assigned To => aferraz
2016-09-19 21:27 aferraz Note Added: 0090084
2016-09-19 21:27 aferraz Status resolved => closed
2016-09-19 21:27 aferraz Fixed in Version => 3.0PR16Q4
2016-09-20 02:11 hudsonbot Checkin
2016-09-20 02:11 hudsonbot Note Added: 0090097


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker