Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034003
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 02. Master data managementmajoralways2016-09-15 14:042016-09-20 02:11
ReporterpsanjuanView Statuspublic 
Assigned Tomarkmm82 
PriorityurgentResolutionfixedFixed in Version3.0PR16Q4
StatusclosedFix in branchFixed in SCM revision176aeafb9b58
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0034003: Set New Currency process warning needs to be modified

DescriptionSet New Currency process warning needs to be modified
Steps To ReproduceIn livebuild (pi).

Go to payment in window and create a new one for F&B España, Alimentos y Supermercados business Partner.

Press Add Details

Enter 1500.00 in the field Actual Payment.
Do not select anything.

Go down and select "Leave the credit to be used later" in the field Overpayment Action.

Press Done.

Go to Business partner window and select Alimentos y Supermercados. Run Set New Currency process.

Check that a new window is opened including a Warning, becuase business partner does have credit.

That warning needs to be enhaced.




Proposed SolutionCorrect Warning message needs to be:

Detected available credit for this business partner.
Changing the Business Partner's currency will not allow you to use available credit in the old currency. If you want to convert the available credit in the old currency into credit in the new currency automatically, select a G/L Item.

Therefore last sentece needs to be removed. See image attached.
TagsNo tags attached.
Attached Filespng file icon Issue_34003.png [^] (42,129 bytes) 2016-09-15 14:06

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0033977 closedmarkmm82 "Set new currency" process is not converting credit properly when more than one credit payment exists for this business partner 

-  Notes
(0090041)
markmm82 (developer)
2016-09-16 18:47

In livebuild (pi).

Go to payment in window and create a new one for F&B España, Alimentos y Supermercados business Partner.

Press Add Details

Enter 1500.00 in the field Actual Payment.
Do not select anything.

Go down and select "Leave the credit to be used later" in the field Overpayment Action.

Press Done.

Go to Business partner window and select Alimentos y Supermercados. Run Set New Currency process.

Check that a new window is opened including a Warning, because business partner does have credit, and it is:
"Detected available credit for this business partner.
Changing the Business Partner's currency will not allow you to use available credit in the old currency. If you want to convert the available credit in the old currency into credit in the new currency automatically, select a G/L Item. "
(0090064)
hgbot (developer)
2016-09-19 13:43

Repository: erp/devel/pi
Changeset: 176aeafb9b58a37aa870adc5ff5352031c429762
Author: Mark <markmm82 <at> gmail.com>
Date: Fri Sep 16 12:42:07 2016 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/176aeafb9b58a37aa870adc5ff5352031c429762 [^]

Fixes issue 34003: Set New Currency process warning needs to be modified

Warning message changed to:

Detected available credit for this business partner.
Changing the Business Partner's currency will not allow you to use available credit in the old currency. If you want to convert the available credit in the old currency into credit in the new currency automatically, select a G/L Item.

Therefore last sentece has beee removed.

---
M src-db/database/sourcedata/AD_MESSAGE.xml
---
(0090065)
aferraz (developer)
2016-09-19 13:45

Code review + Testing OK
(0090096)
hudsonbot (developer)
2016-09-20 02:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/3f07553793a6 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-09-15 14:04 psanjuan New Issue
2016-09-15 14:04 psanjuan Assigned To => Triage Finance
2016-09-15 14:04 psanjuan Modules => Core
2016-09-15 14:04 psanjuan Triggers an Emergency Pack => No
2016-09-15 14:06 psanjuan Relationship added related to 0033977
2016-09-15 14:06 psanjuan File Added: Issue_34003.png
2016-09-15 14:08 aferraz Assigned To Triage Finance => markmm82
2016-09-15 16:44 markmm82 Status new => scheduled
2016-09-16 18:47 markmm82 Note Added: 0090041
2016-09-19 13:43 hgbot Checkin
2016-09-19 13:43 hgbot Note Added: 0090064
2016-09-19 13:43 hgbot Status scheduled => resolved
2016-09-19 13:43 hgbot Resolution open => fixed
2016-09-19 13:43 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/176aeafb9b58a37aa870adc5ff5352031c429762 [^]
2016-09-19 13:45 aferraz Review Assigned To => aferraz
2016-09-19 13:45 aferraz Note Added: 0090065
2016-09-19 13:45 aferraz Status resolved => closed
2016-09-19 13:45 aferraz Fixed in Version => 3.0PR16Q4
2016-09-20 02:11 hudsonbot Checkin
2016-09-20 02:11 hudsonbot Note Added: 0090096


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker