Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033820
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] Z. Othersmajoralways2016-08-26 08:532016-09-01 17:58
ReporterngarciaView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q2.3
StatusclosedFix in branchFixed in SCM revisionaacd8ffa3d67
ProjectionnoneETAnoneTarget Version3.0PR16Q2.3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0033820: No error message shown when voiding an invoice and the period is closed for AP Payment and AR Receipt

DescriptionNo error message shown when voiding an invoice and the period is closed for AP Payment and AR Receipt
Steps To ReproduceAs group admin role:
   Close the current period for AP Payment and AR Receipt documents
   Check it is opened for AR Invoice and AP Invoice
   Create a sales invoice with today's date
   Complete it
   Try to void it and check the status is still Completed and no error message is shown
   The log shows:
      ERROR org.openbravo.base.exception.OBException - The Period does not exist or it is not opened
org.openbravo.base.exception.OBException: The Period does not exist or it is not opened
    at org.openbravo.advpaymentmngt.process.FIN_PaymentProcess.processPayment(FIN_PaymentProcess.java:1141)
    at org.openbravo.advpaymentmngt.process.FIN_PaymentProcess.execute(FIN_PaymentProcess.java:99)
    at org.openbravo.advpaymentmngt.process.FIN_AddPayment.processPayment(FIN_AddPayment.java:1584)
    at org.openbravo.advpaymentmngt.process.FIN_AddPayment.processPayment(FIN_AddPayment.java:1529)
    at org.openbravo.advpaymentmngt.ad_actionbutton.ProcessInvoice.doPost(ProcessInvoice.java:343)
   The problem is also reproduced with Purchase Invoices
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0033817 closedAtulOpenbravo No error message shown when voiding an invoice and the period is closed for AP Payment and AR Receipt 

-  Notes
(0089560)
AtulOpenbravo (developer)
2016-08-30 20:12

Test Plan
- Login as group admin role:
- Close the current period for AP Payment and AR Receipt documents
- Check it is opened for AR Invoice and AP Invoice
- Create a sales invoice with today's date, Payment Term = Immediate.
- Complete it.
- Try to void it and check that error message is shown."An error occurred when processing the payment:
The Period does not exist or it is not opened".

- Go to Open and Close Period Control. For current period, open AR Receipt document.
- Try to void previous Sales Invoice.
- Check that void action is successfully performed.
(0089675)
hgbot (developer)
2016-09-01 17:57

Repository: erp/backports/3.0PR16Q2.3
Changeset: aacd8ffa3d6701292d57a13d476db3543659f4e8
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Tue Aug 30 23:25:40 2016 +0530
URL: http://code.openbravo.com/erp/backports/3.0PR16Q2.3/rev/aacd8ffa3d6701292d57a13d476db3543659f4e8 [^]

Fixes issue 33820: No error shown when voiding an invoice and period is closed

Error message shown in this case "An error occurred when processing the payment: The Period does not exist or it is not opened"

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/ad_actionbutton/ProcessInvoice.java
---
(0089677)
aferraz (developer)
2016-09-01 17:58

Code review OK

- Issue History
Date Modified Username Field Change
2016-08-26 10:37 aferraz Type defect => backport
2016-08-26 10:37 aferraz Target Version => 3.0PR16Q2.3
2016-08-30 20:12 AtulOpenbravo Note Added: 0089560
2016-09-01 17:57 hgbot Checkin
2016-09-01 17:57 hgbot Note Added: 0089675
2016-09-01 17:57 hgbot Status scheduled => resolved
2016-09-01 17:57 hgbot Resolution open => fixed
2016-09-01 17:57 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR16Q2.3/rev/aacd8ffa3d6701292d57a13d476db3543659f4e8 [^]
2016-09-01 17:58 aferraz Review Assigned To => aferraz
2016-09-01 17:58 aferraz Note Added: 0089677
2016-09-01 17:58 aferraz Status resolved => closed
2016-09-01 17:58 aferraz Fixed in Version => 3.0PR16Q2.3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker