Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033553
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 05. Production managementmajoralways2016-07-28 10:562016-08-11 18:40
ReporterngarciaView Statuspublic 
Assigned Tomarkmm82 
PriorityurgentResolutionfixedFixed in Version3.0PR16Q4
StatusclosedFix in branchFixed in SCM revisione49203fbb0c9
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0033553: Division by zero error in Standard Costs Report if Decrease or Rejected fields are 0 for produced products in the Process Plan

DescriptionDivision by zero error in Standard Costs Report if Decrease or Rejected fields are 0 for produced products in the Process Plan. The report is shown empty
Steps To ReproduceAs group admin role:
   Create a Process Plan, Version and Operation
   Add a record in the I/O Products tab:
      Production Type: Product Production (P+)
      Decrease: 0
      Rejected: 0
   Launch the Standard Costs Report and select the previously created plan and version
   Check the report is shown empty and the log shows:
      ERROR net.sf.jasperreports.engine.fill.JRFillSubreport - Fill 1: exception
net.sf.jasperreports.engine.JRException: Error executing SQL statement for : ReportStandardCostsJR_subreport0
    at net.sf.jasperreports.engine.query.JRJdbcQueryExecuter.createDatasource(JRJdbcQueryExecuter.java:240)
    ...
Caused by: org.postgresql.util.PSQLException: ERROR: division by zero
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0088713)
markmm82 (developer)
2016-08-01 21:41

Test Plan
As group admin role:
   Create a Process Plan, Version and Operation
   Add a record in the I/O Products tab:
      Production Type: Product Production (P+)
      Decrease: 0
      Rejected: 0
   Launch the Standard Costs Report and select the previously created plan and version
   Check the report is shown and log shows any error.
(0088893)
hgbot (developer)
2016-08-08 14:29

Repository: erp/devel/pi
Changeset: e49203fbb0c9ae2d52c48db4fab1dd521e3edfb6
Author: Mark <markmm82 <at> gmail.com>
Date: Mon Aug 01 02:13:20 2016 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/e49203fbb0c9ae2d52c48db4fab1dd521e3edfb6 [^]

Fixes issue 33553: Avoid division by zero error in Standard Costs Report

A Division by zero error in Standard Costs Report was happening if Decrease or Rejected fields are 0 for produced products in the Process Plan. To avoid it, a validation was included to the report.

---
M src/org/openbravo/erpCommon/ad_reports/ReportStandardCostsJR_subreport0.jrxml
---
(0088894)
aferraz (developer)
2016-08-08 14:30

Code review + Testing OK
(0089047)
hudsonbot (developer)
2016-08-11 18:40

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/edaa05b1fb18 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-07-28 10:56 ngarcia New Issue
2016-07-28 10:56 ngarcia Assigned To => Triage Finance
2016-07-28 10:56 ngarcia Modules => Core
2016-07-28 10:56 ngarcia Triggers an Emergency Pack => No
2016-07-28 11:03 ngarcia Issue Monitored: networkb
2016-07-28 12:09 aferraz Assigned To Triage Finance => markmm82
2016-07-28 18:08 markmm82 Status new => acknowledged
2016-07-29 15:25 markmm82 Status acknowledged => scheduled
2016-08-01 21:41 markmm82 Note Added: 0088713
2016-08-08 14:29 hgbot Checkin
2016-08-08 14:29 hgbot Note Added: 0088893
2016-08-08 14:29 hgbot Status scheduled => resolved
2016-08-08 14:29 hgbot Resolution open => fixed
2016-08-08 14:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e49203fbb0c9ae2d52c48db4fab1dd521e3edfb6 [^]
2016-08-08 14:30 aferraz Review Assigned To => aferraz
2016-08-08 14:30 aferraz Note Added: 0088894
2016-08-08 14:30 aferraz Status resolved => closed
2016-08-08 14:30 aferraz Fixed in Version => 3.0PR16Q4
2016-08-11 18:40 hudsonbot Checkin
2016-08-11 18:40 hudsonbot Note Added: 0089047


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker