Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033549
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Retail Modules] Web POSminoralways2016-07-21 11:272016-08-23 13:49
ReporterlorenzofidalgoView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in VersionRR16Q2.2
StatusclosedFix in branchFixed in SCM revisionce2f13bc3a6b
ProjectionnoneETAnoneTarget VersionRR16Q2.2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0033549: [RR16Q3][ProductServices] Clicking several times in a product to add it to a receipt prevents Product Services to appear

DescriptionIt is supposed that, after clicking a product, if it is configured to do that, a service must appear to be able to be selected by the POS user. If the product is clicked quickly several times, it does not appear after clicking the product. It can appear after some clicks or when the POS user has finished to click in that product, "randomly".
Steps To Reproduce0-Having Product Services configured, login POS as vallblanca.
1-Go to BROWSE || Best sellers.
2-Now click quickly several times "Avalanche transceiver" (20 times for example). DEFECT: Realise that, depending on the speed of those clicks, the Product Service can appear in different moments. (You can try step 2 clicking faster or slower to check it).
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0033520 closedranjith_qualiantech_com [RR16Q3][ProductServices] Clicking several times in a product to add it to a receipt prevents Product Services to appear 

-  Notes
(0089130)
hgbot (developer)
2016-08-16 11:35

Repository: retail/backports/3.0RR16Q2.2/org.openbravo.retail.posterminal
Changeset: f552d7b048f0d4274699e5406d2f5c9552e04455
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Aug 16 15:04:50 2016 +0530
URL: http://code.openbravo.com/retail/backports/3.0RR16Q2.2/org.openbravo.retail.posterminal/rev/f552d7b048f0d4274699e5406d2f5c9552e04455 [^]

Fixes issue 33549 : Restrict for adding new product if last added product has services

- Added callback for addProductToorder inorder to find the process completion
- Removed "subscribeToCalculateGross" function, since product service should shown after adding product
(subscribeToCalculateGross take some time to callback, due to "saveCurrent" event listener)

---
M web/org.openbravo.retail.posterminal/js/model/order.js
M web/org.openbravo.retail.posterminal/js/pointofsale/view/pointofsale.js
---
(0089276)
jorge-garcia (developer)
2016-08-22 13:47

This fix breaks the integration of 3.016Q2.2 release.
FAILED:
        https://ci.openbravo.com//job/try-ret-test-pgsql-suite1/4152/ [^]
        https://ci.openbravo.com//job/try-ret-test-pgsql-suite3/4138/ [^]
        https://ci.openbravo.com//job/try-ret-test-oracle-suite1/4135/ [^]
        https://ci.openbravo.com//job/try-ret-test-oracle-suite2/4131/ [^]
        https://ci.openbravo.com//job/try-ret-test-oracle-suite3/4132/ [^]
Probably it's needed to backport something else to this release
(0089280)
hgbot (developer)
2016-08-22 14:18

Repository: retail/backports/3.0RR16Q2.2/org.openbravo.retail.posterminal
Changeset: ce2f13bc3a6b2b4bdb2a56405f07a4cd32d626f7
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Aug 22 17:47:19 2016 +0530
URL: http://code.openbravo.com/retail/backports/3.0RR16Q2.2/org.openbravo.retail.posterminal/rev/ce2f13bc3a6b2b4bdb2a56405f07a4cd32d626f7 [^]

Fixes issue 33549 : Removing Duplicate code inorder to prevent the unappropriate product addition

---
M web/org.openbravo.retail.posterminal/js/model/order.js
---

- Issue History
Date Modified Username Field Change
2016-07-27 13:16 marvintm Type defect => backport
2016-07-27 13:16 marvintm Target Version => RR16Q2.2
2016-08-16 11:35 hgbot Checkin
2016-08-16 11:35 hgbot Note Added: 0089130
2016-08-16 11:35 hgbot Status scheduled => resolved
2016-08-16 11:35 hgbot Resolution open => fixed
2016-08-16 11:35 hgbot Fixed in SCM revision => http://code.openbravo.com/retail/backports/3.0RR16Q2.2/org.openbravo.retail.posterminal/rev/f552d7b048f0d4274699e5406d2f5c9552e04455 [^]
2016-08-18 12:25 guilleaer Review Assigned To => guilleaer
2016-08-18 12:25 guilleaer Status resolved => closed
2016-08-18 12:25 guilleaer Fixed in Version => RR16Q2.2
2016-08-22 13:47 jorge-garcia Note Added: 0089276
2016-08-22 13:47 jorge-garcia Status closed => new
2016-08-22 13:47 jorge-garcia Resolution fixed => open
2016-08-22 13:47 jorge-garcia Fixed in Version RR16Q2.2 =>
2016-08-22 13:50 ranjith_qualiantech_com Status new => scheduled
2016-08-22 14:18 hgbot Checkin
2016-08-22 14:18 hgbot Note Added: 0089280
2016-08-22 14:18 hgbot Status scheduled => resolved
2016-08-22 14:18 hgbot Resolution open => fixed
2016-08-22 14:18 hgbot Fixed in SCM revision http://code.openbravo.com/retail/backports/3.0RR16Q2.2/org.openbravo.retail.posterminal/rev/f552d7b048f0d4274699e5406d2f5c9552e04455 [^] => http://code.openbravo.com/retail/backports/3.0RR16Q2.2/org.openbravo.retail.posterminal/rev/ce2f13bc3a6b2b4bdb2a56405f07a4cd32d626f7 [^]
2016-08-23 13:49 guilleaer Status resolved => closed
2016-08-23 13:49 guilleaer Fixed in Version => RR16Q2.2
2016-10-25 15:57 ranjith_qualiantech_com Relationship added causes 0034271
2016-10-25 16:08 ranjith_qualiantech_com Relationship deleted causes 0034271


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker