Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033531
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 09. Financial managementmajoralways2016-07-20 12:522016-08-02 09:10
ReporterngarciaView Statuspublic 
Assigned Tomarkmm82 
PriorityurgentResolutionfixedFixed in Version3.0PR16Q3
StatusclosedFix in branchFixed in SCM revision5489c10e9115
ProjectionnoneETAnoneTarget Version3.0PR16Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0033531: Cannot post a Cash VAT payment that pays more than one invoice, Process failed during execution error is shown

DescriptionCannot post a Cash VAT payment that pays more than one invoice, Process failed during execution error is shown
Steps To ReproduceAs system admin role:
   Install the Cash VAT Management module

As group admin role:
   Create a tax rate. Configure its accounting for Cash VAT:
      Tax Due Transitory
      Tax Credit Transitory
   Set it as Cash VAT
   Create three purchase orders, set them as Cash VAT and select the previously created tax rate
   Create three purchase invoices from them
   Create a Payment Out and pay the three invoices
   Try to post the payment out and check the following error message is shown:
      Process failed during execution
   The log shows:
      org.hibernate.LazyInitializationException: could not initialize proxy - no Session
    at org.hibernate.proxy.AbstractLazyInitializer.initialize(AbstractLazyInitializer.java:167)
    at org.hibernate.proxy.AbstractLazyInitializer.getImplementation(AbstractLazyInitializer.java:215)
    at org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer.invoke(JavassistLazyInitializer.java:190)
    at org.openbravo.model.common.invoice.InvoiceTax_$$_javassist_194.getTax(InvoiceTax_$$_javassist_194.java)
    at org.openbravo.erpCommon.utility.CashVATUtil.createFactCashVAT(CashVATUtil.java:496)
    at org.openbravo.erpCommon.ad_forms.DocFINPayment.createFact(DocFINPayment.java:396)
    at org.openbravo.erpCommon.ad_forms.AcctServer.postLogic(AcctServer.java:1111)
    at org.openbravo.erpCommon.ad_forms.AcctServer.post(AcctServer.java:804)
    at org.openbravo.erpCommon.ad_forms.AcctServer.post(AcctServer.java:720)
    at org.openbravo.erpCommon.ad_actionButton.Posted.processButton(Posted.java:273)
    at org.openbravo.erpCommon.ad_actionButton.Posted.doPost(Posted.java:104)
...
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0033508 closedmarkmm82 Cannot post a Cash VAT payment that pays more than one invoice, Process failed during execution error is shown 

-  Notes
(0088718)
hgbot (developer)
2016-08-02 08:57

Repository: erp/backports/3.0PR16Q3
Changeset: 5489c10e911577cb1133c600d5a36b6bfdfaeb3a
Author: Mark <markmm82 <at> gmail.com>
Date: Tue Jul 26 14:43:28 2016 -0400
URL: http://code.openbravo.com/erp/backports/3.0PR16Q3/rev/5489c10e911577cb1133c600d5a36b6bfdfaeb3a [^]

Fixes issue 33531: Error posting Cash VAT payment if pays more than one invoice

When trying to post a Cash VAT payment that pays more than one invoice, process was failing and an error was shown. It was caused by a clearing of the session when iterating on the cash vat invoices list. To avoid it, list of cash vat ids are retrieved instead a list of InvoiceTaxCashVAT_V.

---
M src/org/openbravo/erpCommon/ad_forms/DocLineCashVATReady_PaymentTransactionReconciliation.java
M src/org/openbravo/erpCommon/utility/CashVATUtil.java
---
(0088719)
hgbot (developer)
2016-08-02 08:57

Repository: erp/backports/3.0PR16Q3
Changeset: 3928a857fcb800c9bf78494f39c7babcce5f9d65
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Aug 01 13:21:44 2016 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR16Q3/rev/3928a857fcb800c9bf78494f39c7babcce5f9d65 [^]

Related to issue 33531: Code review improvements

Set invoiceTaxCashVAT_V variable as private.
Keep getInvoiceTaxCashVAT_V and setInvoiceTaxCashVAT_V methods as deprecated to avoid API change.
Add distinct to setInvoiceTaxCashVAT_V query to avoid retrieve duplicated ids.

---
M src/org/openbravo/erpCommon/ad_forms/DocLineCashVATReady_PaymentTransactionReconciliation.java
M src/org/openbravo/erpCommon/utility/CashVATUtil.java
---
(0088722)
aferraz (developer)
2016-08-02 09:10

Code review + Testing OK

- Issue History
Date Modified Username Field Change
2016-07-22 14:25 aferraz Type defect => backport
2016-07-22 14:25 aferraz Target Version => 3.0PR16Q3
2016-08-02 08:57 hgbot Checkin
2016-08-02 08:57 hgbot Note Added: 0088718
2016-08-02 08:57 hgbot Status scheduled => resolved
2016-08-02 08:57 hgbot Resolution open => fixed
2016-08-02 08:57 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR16Q3/rev/5489c10e911577cb1133c600d5a36b6bfdfaeb3a [^]
2016-08-02 08:57 hgbot Checkin
2016-08-02 08:57 hgbot Note Added: 0088719
2016-08-02 09:10 aferraz Review Assigned To => aferraz
2016-08-02 09:10 aferraz Note Added: 0088722
2016-08-02 09:10 aferraz Status resolved => closed
2016-08-02 09:10 aferraz Fixed in Version => 3.0PR16Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker