Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033429
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Modules] Payment Aging Balance Reportmajorsometimes2016-07-05 12:392016-07-06 13:36
ReporterdmiguelezView Statuspublic 
Assigned Toaferraz 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisioneae2aeebcc7e
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Regression date
Regression introduced by commit
Regression level
Review Assigned Tovmromanos
Regression introduced in release
Summary

0033429: Problems in Aging Balance Report with Oracle due to date formats

DescriptionThere is a problem in the Aging Balance Report with Oracle.
Sometimes it throws the error ora-01843 not a valid month.
But this behavior is not always consistent.

This is happening since we started to use a new ConnectionProvider for launching the query: new DalConnectionProvider(false)

This might be related to some problem while creating a new connection, it might be that the date preferences are not correctly set in the database connection we are using.
Steps To ReproduceInstall the latest version of the aging balance module: https://code.openbravo.com/erp/mods/org.openbravo.agingbalance [^]

Go to Receivables Aging Balance.
Launch the report with the parameters:
*Organization: F&B España
*General Ledger: F&B España
*As of date: 27-06-2016
*Show Details: Checked
The rest of the parameters can be set with the default values

It should throw an error:
55585 [http-8081-2] ERROR org.openbravo.base.exception.OBException - Error
javax.servlet.ServletException: @CODE=1843@ORA-01843: not a valid month

    at org.openbravo.agingbalance.ad_reports.AgingDaoData.selectDetail(AgingDaoData.java:492)
    at org.openbravo.agingbalance.ad_reports.AgingDao.getOpenReceivablesAgingScheduleDetails(AgingDao.java:217)
    at org.openbravo.agingbalance.ad_reports.AgingProcess.printPageDetails(AgingProcess.java:391)
    at org.openbravo.agingbalance.ad_reports.AgingProcess.doPost(AgingProcess.java:156)
    at org.openbravo.base.HttpBaseServlet.doGet(HttpBaseServlet.java:294)

This behavior is not always consistent.
Proposed SolutionThere is a patch attached with a functional solution for it, in case any client needs it.

But this issue is reported to be investigated just in case there is a bigger problem hidden.
TagsNo tags attached.
Attached Filesdiff file icon fix.diff [^] (8,137 bytes) 2016-07-05 12:39 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0033438 closedalostale Openbravo ERP DalConnectionProvider.getTransactionConnection does not obtain connection from common pool 

-  Notes
(0088230)
alostale (developer)
2016-07-06 10:18

The root cause of the problem is due to issue 0033438 Aging report is using xsql files with "scrollable" type which internally create a transactional connection, which if created from a DalConnectionProvider, does not get properly set session configuration.

Proposal: fix this issue within attached functional changeset, not to be blocked by 0033438
(0088235)
vmromanos (manager)
2016-07-06 13:02

Test plan:

Launch the report in both Oracle and PG.
Verify you get data
(0088239)
hgbot (developer)
2016-07-06 13:35

Repository: erp/mods/org.openbravo.agingbalance
Changeset: eae2aeebcc7e0ed2974264cf62c7e1f891d3c0fc
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Wed Jul 06 12:48:00 2016 +0200
URL: http://code.openbravo.com/erp/mods/org.openbravo.agingbalance/rev/eae2aeebcc7e0ed2974264cf62c7e1f891d3c0fc [^]

Fixed bug 33429: Problems in Aging Balance Report with Oracle due to date formats

This is a workaround for issue 33438. We pass the connection provider from the servlet to avoid this random problems on Oracle only

---
M src/org/openbravo/agingbalance/ad_reports/AgingDao.java
M src/org/openbravo/agingbalance/ad_reports/AgingProcess.java
---
(0088240)
hgbot (developer)
2016-07-06 13:35

Repository: erp/mods/org.openbravo.agingbalance
Changeset: b3d79d3969658d078630092633bc4cc27bb35893
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Wed Jul 06 13:00:14 2016 +0200
URL: http://code.openbravo.com/erp/mods/org.openbravo.agingbalance/rev/b3d79d3969658d078630092633bc4cc27bb35893 [^]

Related to issue 33429: increase module version

Actually this is an API change, but we are not increasing the major version to avoid problems in retail integration

---
M src-db/database/sourcedata/AD_MODULE.xml
---
(0088241)
vmromanos (manager)
2016-07-06 13:36

Code review + testing OK

Fixed in module version 3.1.1700 (or higher)

- Issue History
Date Modified Username Field Change
2016-07-05 12:39 dmiguelez New Issue
2016-07-05 12:39 dmiguelez Assigned To => platform
2016-07-05 12:39 dmiguelez File Added: fix.diff
2016-07-05 12:39 dmiguelez Modules => Core
2016-07-05 12:39 dmiguelez Triggers an Emergency Pack => No
2016-07-05 15:35 alostale Steps to Reproduce Updated View Revisions
2016-07-05 16:40 alostale Relationship added related to 0027878
2016-07-06 10:06 alostale Issue cloned 0033438
2016-07-06 10:06 alostale Relationship added related to 0033438
2016-07-06 10:14 alostale Relationship deleted related to 0027878
2016-07-06 10:18 alostale Note Added: 0088230
2016-07-06 10:18 alostale Assigned To platform => Triage Finance
2016-07-06 12:50 vmromanos Status new => scheduled
2016-07-06 12:50 vmromanos Assigned To Triage Finance => aferraz
2016-07-06 12:50 vmromanos Project Openbravo ERP => Modules
2016-07-06 12:52 vmromanos Category A. Platform => Payment Aging Balance Report
2016-07-06 13:02 vmromanos Note Added: 0088235
2016-07-06 13:05 vmromanos Severity critical => major
2016-07-06 13:35 hgbot Checkin
2016-07-06 13:35 hgbot Note Added: 0088239
2016-07-06 13:35 hgbot Status scheduled => resolved
2016-07-06 13:35 hgbot Resolution open => fixed
2016-07-06 13:35 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/mods/org.openbravo.agingbalance/rev/eae2aeebcc7e0ed2974264cf62c7e1f891d3c0fc [^]
2016-07-06 13:35 hgbot Checkin
2016-07-06 13:35 hgbot Note Added: 0088240
2016-07-06 13:36 vmromanos Review Assigned To => vmromanos
2016-07-06 13:36 vmromanos Note Added: 0088241
2016-07-06 13:36 vmromanos Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker