Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033412
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2016-07-01 14:312016-08-23 15:57
ReporterJONHMView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR16Q4
StatusclosedFix in branchFixed in SCM revision1fd172f8c1c8
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0033412: error in tree sub tab when creating record in its header

DescriptionThe console shows an error by having some window with a tab defined in tree grid view. In some cases this error causes wrong data visualization in form view.
Steps To Reproduce1) Open window "account tree"
2) Select some record
3) Then select an element value and put it in tree grid view (press button toogle tree grid visibility)
4) Create a new record into header tab

The chrome console shows an error:
ISC_Combined.js:1410 Uncaught TypeError: Cannot read property 'id' of undefined

Proposed SolutionInto file:
https://code.openbravo.com/erp/devel/pi/file/cfff3c184b53/modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-tree-view-grid.js#l210 [^]

- getParentTabRecordId: function () {
- if (!this.view.parentView) {
- return null;
- }
- return this.view.parentView.viewGrid.getSelectedRecord().id;
- },


+ getParentTabRecordId: function () {
+ if (!this.view.parentView) {
+ return null;
+ }
+ if (this.view.parentView.viewGrid.getSelectedRecord())
+ return this.view.parentView.viewGrid.getSelectedRecord().id;
+ else
+ return null;
+ },
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00318563.0PR16Q2 closedcaristu It is not supported to have more than one "Tree and node image" record defined for same client 

-  Notes
(0088476)
hgbot (developer)
2016-07-14 12:17

Repository: erp/devel/pi
Changeset: 05fe133ffcf71819bec9dc63844d8b512a6b1425
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Jul 14 12:15:48 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/05fe133ffcf71819bec9dc63844d8b512a6b1425 [^]

fixed bug 33412: error in tree sub tab when creating record in its header

  A JS error was thrown beacause tree subtab incorrectly assumed there was a
  record selected in its parent tab.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-tree-view-grid.js
---
(0088605)
caristu (developer)
2016-07-20 16:32
edited on: 2016-07-20 16:32

Following steps to reproduce, the following error is raised in the backend:

org.openbravo.service.datasource.TreeDatasourceService - Error on tree datasource
java.lang.NullPointerException
    at org.openbravo.service.datasource.AccountTreeDatasourceService.getDatasourceSpecificParams(AccountTreeDatasourceService.java:54)

The problem is that the accountTreeId arrives with value "null" (String) at the datasource.

Proposed solution:

In AccountTreeDatasourceService add the following to the existing check:

  if (accountTreeId == null || "null".equals(accountTreeId)) {
      return datasourceParams;
  }

(0089012)
hudsonbot (developer)
2016-08-11 18:40

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/edaa05b1fb18 [^]
Maturity status: Test
(0089279)
hgbot (developer)
2016-08-22 14:01

Repository: erp/devel/pi
Changeset: 1fd172f8c1c8cf31c8164bc5c65e7a6939922b8b
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Aug 22 14:00:14 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/1fd172f8c1c8cf31c8164bc5c65e7a6939922b8b [^]

related to issue 33412: prevent NPE

When refreshing a subtab in tree view, having a new record selected in the header, a NullPointerException was being thrown in the tree datasource because it was not possible to retrieve the tree information as no account id is provided in that case

---
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/ADTreeDatasourceService.java
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/AccountTreeDatasourceService.java
---
(0089299)
hudsonbot (developer)
2016-08-23 14:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/49d28e45a11a [^]
Maturity status: Test
(0089310)
AugustoMauch (developer)
2016-08-23 15:57

Code reviewed and verified in pi@9bebb4948779

- Issue History
Date Modified Username Field Change
2016-07-01 14:31 JONHM New Issue
2016-07-01 14:31 JONHM Assigned To => platform
2016-07-01 14:31 JONHM Modules => Core
2016-07-01 14:31 JONHM Triggers an Emergency Pack => No
2016-07-14 12:13 alostale Summary Error caused by having some window with a tab defined in tree grid view => error in tree sub tab when creating record in its header
2016-07-14 12:13 alostale Assigned To platform => alostale
2016-07-14 12:13 alostale Review Assigned To => caristu
2016-07-14 12:17 hgbot Checkin
2016-07-14 12:17 hgbot Note Added: 0088476
2016-07-14 12:17 hgbot Status new => resolved
2016-07-14 12:17 hgbot Resolution open => fixed
2016-07-14 12:17 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/05fe133ffcf71819bec9dc63844d8b512a6b1425 [^]
2016-07-20 16:32 caristu Note Added: 0088605
2016-07-20 16:32 caristu Status resolved => new
2016-07-20 16:32 caristu Resolution fixed => open
2016-07-20 16:32 caristu Note Edited: 0088605 View Revisions
2016-08-11 18:40 hudsonbot Checkin
2016-08-11 18:40 hudsonbot Note Added: 0089012
2016-08-22 11:46 caristu Assigned To alostale => caristu
2016-08-22 14:00 caristu Status new => scheduled
2016-08-22 14:01 hgbot Checkin
2016-08-22 14:01 hgbot Note Added: 0089279
2016-08-22 14:02 caristu Status scheduled => resolved
2016-08-22 14:02 caristu Resolution open => fixed
2016-08-22 14:03 caristu Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/05fe133ffcf71819bec9dc63844d8b512a6b1425 [^] => http://code.openbravo.com/erp/devel/pi/rev/1fd172f8c1c8cf31c8164bc5c65e7a6939922b8b [^]
2016-08-22 14:03 caristu Review Assigned To caristu => AugustoMauch
2016-08-22 14:03 caristu Issue Monitored: AugustoMauch
2016-08-22 14:05 caristu Relationship added related to 0031856
2016-08-23 14:26 hudsonbot Checkin
2016-08-23 14:26 hudsonbot Note Added: 0089299
2016-08-23 15:57 AugustoMauch Note Added: 0089310
2016-08-23 15:57 AugustoMauch Status resolved => closed
2016-08-23 15:57 AugustoMauch Fixed in Version => 3.0PR16Q4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker