Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033402
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 07. Sales managementmajorsometimes2016-06-29 22:062016-07-01 09:35
ReporterrbianchiniView Statuspublic 
Assigned ToSanjota 
PriorityhighResolutionfixedFixed in Version3.0PR16Q3
StatusclosedFix in branchFixed in SCM revision3f6e4a7da362
ProjectionnoneETAnoneTarget Version3.0PR16Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0PR16Q1.3SCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2015-10-28
Regression introduced in release3.0PR16Q1.3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/e1c26dc9a819 [^]
Triggers an Emergency PackNo
Summary

0033402: Wrong Storage Bin in Goods Receipt Lines

DescriptionIn some cases, when you create a goods receipt line the storage bin's defaul value don't belongs to the warehouse defined in the header.
It works fine in 15Q4.6 but don't in 16Q1.3 or 16Q2
Steps To Reproduce1 - Log in ERP as Openbravo with the following configuration:
Role: The White Valley Group Admin
Client: The White Valley Group
Organization: Vall Blanca Store
Warehouse: Vall Blanca Store Warehouse

2 - Open the Goods Receipt window and create a new header (in form view) as follows:
Organization: Vall Blanca Store
Document Type: Spain MM Receipt
Warehouse: White Valley Spain Distribution Center
BP: Mountains and Snow S.L

3 - Save the header and create a new line in form view
4A - In 15Q4.6 The storage bin loaded as default is WVS/001 0-0-0 --> OK
4B - In 16Q1.3 and 16Q2 The storage bin loaded as default is CMS/001 0-0-0. The storage bin is wrong since it don't belongs to the White Valley Spain Distribution Center warehouse defined in the header


Steps to Reproduce with F & B Internation Group Admin Role:
1 - Log in ERP as Openbravo with the following configuration:
Role: F & B International group Admin
Client: F & B International group

2. - Open Warehouse and Storage bin:
--Create New Warehouse :
Organization : "F&B España, S.A"
Name : "Test"
Search Key : "Test"
Save
--Create Storage bin Under newly created warehouse "Test"
Search Key : "NewTestBin"

3 - Open the Goods Receipt window and create a new header (in form view) as follows:
Organization: "F&B España - Región Norte"
Warehouse: "Test"

4 - Save the header and create a new line in form view
Check that in Storage Bin field there is no default value means it's blank.

Note: It should show newly created "NewTestBin" in Storage Bin field.
Proposed SolutionReview why the default value OnHandLocatorDefault is not executing, since if you execute the OnHandLocatorDefault's query, it returns the correct value
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0033382 closedSanjota Wrong Storage Bin in Goods Receipt Lines 

-  Notes
(0088126)
hgbot (developer)
2016-07-01 09:23

Repository: erp/backports/3.0PR16Q3
Changeset: 3f6e4a7da3623e394812e323bca9418193aa36a3
Author: Sanjota <sanjota.nelagi <at> promantia.com>
Date: Thu Jun 30 18:04:33 2016 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR16Q3/rev/3f6e4a7da3623e394812e323bca9418193aa36a3 [^]

Fixes issue 33402: Wrong Storage Bin in Goods Receipt Lines

In some cases, when you create a goods receipt line the storage bin's defaul value don't belongs to the warehouse defined in the header.

---
M src-db/database/sourcedata/AD_AUXILIARINPUT.xml
---
(0088131)
aferraz (developer)
2016-07-01 09:35

Code review + Testing OK

- Issue History
Date Modified Username Field Change
2016-07-01 08:53 aferraz Type defect => backport
2016-07-01 08:53 aferraz Target Version => 3.0PR16Q3
2016-07-01 09:23 hgbot Checkin
2016-07-01 09:23 hgbot Note Added: 0088126
2016-07-01 09:23 hgbot Status scheduled => resolved
2016-07-01 09:23 hgbot Resolution open => fixed
2016-07-01 09:23 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR16Q3/rev/3f6e4a7da3623e394812e323bca9418193aa36a3 [^]
2016-07-01 09:35 aferraz Review Assigned To => aferraz
2016-07-01 09:35 aferraz Note Added: 0088131
2016-07-01 09:35 aferraz Status resolved => closed
2016-07-01 09:35 aferraz Fixed in Version => 3.0PR16Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker