Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033375
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 01. General setuptrivialalways2016-06-29 10:032016-06-30 19:13
ReporterngarciaView Statuspublic 
Assigned ToSanjota 
PriorityhighResolutionfixedFixed in Version3.0PR16Q3
StatusclosedFix in branchFixed in SCM revisioned42f9732da4
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2015-05-14
Regression introduced in release3.0PR15Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/135a4a43d546 [^]
Triggers an Emergency PackNo
Summary

0033375: Error! tag shown instead of Organization in Initial Organization Setup success message

DescriptionError! tag shown instead of Organization in Initial Organization Setup success message
Steps To ReproduceAs group admin role:
   Launch Initial Org Setup Process:
      Organization: B1
      Organization Username: B1 Admin
      Organization type: Generic
      Parent organization: *
      Location/Address: Spain
      Include Accounting File or Accounting Reference Data: N
   Check in the success message Error!=B1 appears instead of Organization=B1 (attached an image)
TagsNo tags attached.
Attached Filespng file icon InitialOrgSetup.png [^] (44,553 bytes) 2016-06-29 10:03

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00333803.0PR16Q2.1 closedSanjota Error! tag shown instead of Organization in Initial Organization Setup success message 
depends on backport 00333813.0PR16Q1.4 closedSanjota Error! tag shown instead of Organization in Initial Organization Setup success message 
caused by feature request 0029201 closednaiaramartinez Modify 'generate invoices' process to add the posibility to include SO with different orgs in one or more SI with a parent org 

-  Notes
(0088097)
Sanjota (developer)
2016-06-30 12:48
edited on: 2016-06-30 12:49

Test Plan:
As group admin role:
   Launch Initial Org Setup Process:
      Organization: B2
      Organization Username: B2 Admin
      Organization type: Generic
      Parent organization: *
      Location/Address: Spain
      Include Accounting File or Accounting Reference Data: N
   Check in the success message "Organization = B2"
  Also check that if there is any error, the message will be "Error! = B2"

(0088100)
hgbot (developer)
2016-06-30 14:24

Repository: erp/devel/pi
Changeset: ed42f9732da4e579d3ecfb1989c94d6dd2115faa
Author: Sanjota <sanjota.nelagi <at> promantia.com>
Date: Thu Jun 30 12:35:54 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ed42f9732da4e579d3ecfb1989c94d6dd2115faa [^]

Fixes issue 33375: Error! tag shown instead of Organization

Error! tag shown instead of Organization in Initial Organization Setup success message.

---
M src/org/openbravo/erpCommon/businessUtility/InitialOrgSetup.java
M src/org/openbravo/erpCommon/businessUtility/InitialSetupUtility.java
---
(0088101)
hgbot (developer)
2016-06-30 14:24

Repository: erp/devel/pi
Changeset: b7e087925687e0debc32f27ab8fdb15268ed66ed
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu Jun 30 13:17:45 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b7e087925687e0debc32f27ab8fdb15268ed66ed [^]

Related to issue 33375: Code review improvements

---
M src/org/openbravo/erpCommon/businessUtility/InitialOrgSetup.java
M src/org/openbravo/erpCommon/businessUtility/InitialSetupUtility.java
---
(0088106)
aferraz (developer)
2016-06-30 14:28

Code review + Testing OK
(0088121)
hudsonbot (developer)
2016-06-30 19:13

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/afefea138cd1 [^]
Maturity status: Test
(0088122)
hudsonbot (developer)
2016-06-30 19:13

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/afefea138cd1 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-06-29 10:03 ngarcia New Issue
2016-06-29 10:03 ngarcia Assigned To => Triage Finance
2016-06-29 10:03 ngarcia File Added: InitialOrgSetup.png
2016-06-29 10:03 ngarcia Modules => Core
2016-06-29 10:03 ngarcia Triggers an Emergency Pack => No
2016-06-29 10:04 ngarcia Issue Monitored: networkb
2016-06-29 16:56 aferraz Severity minor => trivial
2016-06-29 18:28 aferraz Relationship added caused by 0029201
2016-06-29 18:34 aferraz Regression level => Production - Confirmed Stable
2016-06-29 18:34 aferraz Regression date => 2015-05-14
2016-06-29 18:34 aferraz Regression introduced in release => 3.0PR15Q3
2016-06-29 18:34 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/135a4a43d546 [^]
2016-06-29 19:00 aferraz Status new => scheduled
2016-06-29 19:00 aferraz Assigned To Triage Finance => Sanjota
2016-06-30 12:48 Sanjota Note Added: 0088097
2016-06-30 12:49 Sanjota Note Edited: 0088097 View Revisions
2016-06-30 12:49 Sanjota Note Edited: 0088097 View Revisions
2016-06-30 14:24 hgbot Checkin
2016-06-30 14:24 hgbot Note Added: 0088100
2016-06-30 14:24 hgbot Status scheduled => resolved
2016-06-30 14:24 hgbot Resolution open => fixed
2016-06-30 14:24 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ed42f9732da4e579d3ecfb1989c94d6dd2115faa [^]
2016-06-30 14:24 hgbot Checkin
2016-06-30 14:24 hgbot Note Added: 0088101
2016-06-30 14:28 aferraz Review Assigned To => aferraz
2016-06-30 14:28 aferraz Note Added: 0088106
2016-06-30 14:28 aferraz Status resolved => closed
2016-06-30 14:28 aferraz Fixed in Version => 3.0PR16Q3
2016-06-30 19:13 hudsonbot Checkin
2016-06-30 19:13 hudsonbot Note Added: 0088121
2016-06-30 19:13 hudsonbot Checkin
2016-06-30 19:13 hudsonbot Note Added: 0088122


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker