Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033361
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 09. Financial managementmajoralways2016-06-24 13:122016-06-28 10:08
ReporterpsanjuanView Statuspublic 
Assigned Tovmromanos 
PriorityurgentResolutionfixedFixed in Version3.0PR16Q2.1
StatusclosedFix in branchFixed in SCM revisionffbd8049bda8
ProjectionnoneETAnoneTarget Version3.0PR16Q2.1
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-08-26
Regression introduced in release3.0PR14Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/35648d50070b5bde2cbd8ff287e098d98ed0044d#l1.42 [^]
Triggers an Emergency PackNo
Summary

0033361: No correct Cash VAT posting for the payment in case of more than one General Ledger assigned to the Organization.

DescriptionNo correct Cash VAT posting for the payment in case of more than one General Ledger assigned to the Organization.
Steps To ReproduceIn an environment with F&B International Group demo data, install "Cash VAT Management" module.

Once installed apply its dataset at * organization.

Go to Account Tree window and create below accounts:

For F&B España, create the accounts:
Search Key: 47200T
Name: HP IVA soportado Transitorio
Account Type: Asset

Search Key: 47700T
Name: HP IVA repercutido Transitorio
Account Type: Liability

For F&B International Group, create the accounts:
Search Key: 2260T
Name: Sales Tax Payable Transitory
Account Type: Liability

Search Key: 7410T
Name: Tax Expense Transitory
Account Type: Expense

Go to General ledger Configuration window and enter above created accounts for each General Ledger Configuration, Defaults tab:

F&B España:
Tax Due Transitory: 47700T
Tax Credit Transitory: 47200T

F&B International:
Tax Due Transitory: 2260T
Tax Credit Transitory: 7410T

Go to Tax rate window and create below two one tax rates:
(1) For F&B España:
Name = Adquisiciones IVA 21% IVA de Caja
Valid from date = 01-01-2016
Rate = 21
Purchase Tax
Cash VAT = YES
Country= Destination country = Spain.

(1) For F&B US:
Name = Purchase Tax Cash VAT
Valid from date = 01-01-2016
Rate = 21
Purchase Tax
Cash VAT = YES
Country= Destination country = United States

Go to purchase invoice and create a new one for F&B España. Bebidas Alegres BP. Set it as Cash VAT = Yes.
Enter any line. Make sure that the tax "Adquisiciones IVA 21% IVA de Caja" is shown in there.
Complete and post the invoice.

Verify postings refers a transitory VAT account:

F&B España Euro:

204.00 (6000) Compras Mercaderias - DEBIT
42.84 (47200T) HP IVA soportado Transitorio - DEBIT
264.84 (4000) Proveedores - CREDIT

F&B International Dollar:

22.36 (5360) Product Expense - DEBIT
42.84 (7410T) Tax Expense Transitory - DEBIT
269.06 (2110) Accounts Receivable - CREDIT

Add a payment for the invoice. Go to the payment and post it.

F&B España Euro:
246.84 (40000) Proveedores - DEBIT
246.84 (57200) Bancos - CREDIT

(*) this posting is not correct as it does not move Cash VAT transitory account balance to a Final Cash VAT account

F&B International Group:

269.06 (2110) Account payables - DEBIT
46.70 (7410) Tax expense - DEBIT
269.06 (1140) Bank - CREDIT
46.70 (7410T) Tax Expense Transitory - CREDIT

(*) this posting is correct.

Moreover, create a purchase invoice for F&B US, Be Soft Drinker Inc BP. Make sure it is set as Cash VAT = Yes.

Add any line. Make sure that the tax rate "Purchase Tax Cash VAT" is used.

Complete and post.

Add a payment and verify below posting for the only general ledger related to F&B US:

F&B International Group /Dollar

366.03 (2110) Account payables - DEBIT
65.53 (7410) Tax expense - DEBIT
366.03(1140) Bank - CREDIT
63.53 (7410T) Tax Expense Transitory - CREDIT

Proposed SolutionTransitory Cash VAT should take place, therefore correct payment posting looks like:
246.84 (40000) Proveedores - DEBIT
42.84 (47200) HP IVA soportado - DEBIT
246.84 (57200) Bancos - CREDIT
42.84 (47200t) HP IVA soportado transitorio - CREDIT
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0033354 closedvmromanos No correct Cash VAT posting for the payment in case of more than one General Ledger assigned to the Organization. 

-  Notes
(0088010)
hgbot (developer)
2016-06-28 10:06

Repository: erp/backports/3.0PR16Q2.1
Changeset: ffbd8049bda82d1d8e62d3f2beb6d287cfbd2943
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Mon Jun 27 11:57:06 2016 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR16Q2.1/rev/ffbd8049bda82d1d8e62d3f2beb6d287cfbd2943 [^]

Fixed issue 33361: Cash VAT accounting with several ledgers

Comparing objects was wrongly done using equals instead of comparing by the ID.
The iteration for the first accounting schema worked fine, but the next ones were identified as other objects (although the record ID was the same).
Now the comparation is done using the ID.

---
M src/org/openbravo/erpCommon/utility/CashVATUtil.java
---
(0088011)
hgbot (developer)
2016-06-28 10:06

Repository: erp/backports/3.0PR16Q2.1
Changeset: 93ccc3beaedd234ca99b6ec9ab32791b4f0ab6b2
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Tue Jun 28 10:05:28 2016 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR16Q2.1/rev/93ccc3beaedd234ca99b6ec9ab32791b4f0ab6b2 [^]

Related to issue 33361: Update copyright

---
M src/org/openbravo/erpCommon/utility/CashVATUtil.java
---
(0088014)
aferraz (developer)
2016-06-28 10:08

Code review OK

- Issue History
Date Modified Username Field Change
2016-06-27 11:51 aferraz Type defect => backport
2016-06-27 11:51 aferraz Target Version => 3.0PR16Q2.1
2016-06-28 10:02 aferraz Assigned To Triage Finance => vmromanos
2016-06-28 10:06 hgbot Checkin
2016-06-28 10:06 hgbot Note Added: 0088010
2016-06-28 10:06 hgbot Status scheduled => resolved
2016-06-28 10:06 hgbot Resolution open => fixed
2016-06-28 10:06 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR16Q2.1/rev/ffbd8049bda82d1d8e62d3f2beb6d287cfbd2943 [^]
2016-06-28 10:06 hgbot Checkin
2016-06-28 10:06 hgbot Note Added: 0088011
2016-06-28 10:08 aferraz Review Assigned To => aferraz
2016-06-28 10:08 aferraz Note Added: 0088014
2016-06-28 10:08 aferraz Status resolved => closed
2016-06-28 10:08 aferraz Fixed in Version => 3.0PR16Q2.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker