Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033339
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersminoralways2016-06-23 12:092016-06-28 16:06
ReportermaiteView Statuspublic 
Assigned Tomarkmm82 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q3
StatusclosedFix in branchFixed in SCM revision180c0d96c61f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesAdvanced Payables and Receivables Mngmt
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0033339: Error when trying to Void a NOT PAID invoice, logged with * organization

DescriptionFollowing error is raised: org.hibernate.StaleStateException: Batch update returned unexpected row count from update [0]; actual row count: 0; expected: 1
Steps To Reproduce1. Log into the system and set * as default organization in login
2. Create new Sales Invoice for Alimentos y Supermercados business partner. Add any line and Complete
3. Void invoice and following error will be raised:
org.hibernate.StaleStateException: Batch update returned unexpected row count from update [0]; actual row count: 0; expected: 1

NOTE: if you change default organization to another one then invoice is properly voided
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00333493.0PR16Q2.1 closedmarkmm82 Error when trying to Void a NOT PAID invoice, logged with * organization 
depends on backport 00333503.0PR16Q1.4 closedmarkmm82 Error when trying to Void a NOT PAID invoice, logged with * organization 
caused by defect 00309713.0PR16Q1 closedaferraz When voiding an unpaid invoice, payment schedule details should be canceled instead of deleted 

-  Notes
(0087911)
markmm82 (developer)
2016-06-24 16:57

Test Plan
1. Log into the system and set * as default organization in login
2. Create new Sales Invoice for Alimentos y Supermercados business partner. Add any line and Complete
3. Void invoice and any error is shown. Process is completed successfully.
(0087948)
hgbot (developer)
2016-06-27 10:21

Repository: erp/devel/pi
Changeset: 180c0d96c61f9daf2c2ee01205c218368f8e20fe
Author: Mark <markmm82 <at> gmail.com>
Date: Fri Jun 24 09:39:53 2016 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/180c0d96c61f9daf2c2ee01205c218368f8e20fe [^]

Fixes issue 33339: Allow to Void a NOT PAID invoice, logged as * organization

Was avoid the Error when trying to Void a NOT PAID invoice, logged with * organization. The payment detail takes the organization from the payment schedule details organization.

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/ad_actionbutton/ProcessInvoice.java
---
(0087949)
aferraz (developer)
2016-06-27 10:22

Code review + Testing OK
(0088052)
hudsonbot (developer)
2016-06-28 16:06

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/865878a5d292 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-06-23 12:09 maite New Issue
2016-06-23 12:09 maite Assigned To => Triage Finance
2016-06-23 12:09 maite Modules => Advanced Payables and Receivables Mngmt
2016-06-23 12:09 maite Triggers an Emergency Pack => No
2016-06-23 12:09 maite Relationship added caused by 0030971
2016-06-23 12:09 maite Issue Monitored: networkb
2016-06-23 12:27 aferraz Assigned To Triage Finance => markmm82
2016-06-23 17:47 markmm82 Status new => acknowledged
2016-06-24 10:32 aferraz Status acknowledged => scheduled
2016-06-24 16:57 markmm82 Note Added: 0087911
2016-06-27 10:21 hgbot Checkin
2016-06-27 10:21 hgbot Note Added: 0087948
2016-06-27 10:21 hgbot Status scheduled => resolved
2016-06-27 10:21 hgbot Resolution open => fixed
2016-06-27 10:21 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/180c0d96c61f9daf2c2ee01205c218368f8e20fe [^]
2016-06-27 10:22 aferraz Review Assigned To => aferraz
2016-06-27 10:22 aferraz Note Added: 0087949
2016-06-27 10:22 aferraz Status resolved => closed
2016-06-27 10:22 aferraz Fixed in Version => 3.0PR16Q3
2016-06-28 16:06 hudsonbot Checkin
2016-06-28 16:06 hudsonbot Note Added: 0088052


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker