Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033064
TypeCategorySeverityReproducibilityDate SubmittedLast Update
design defect[Openbravo ERP] A. Platformminorhave not tried2016-05-26 17:082016-06-17 19:38
ReporteralostaleView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR16Q3
StatusclosedFix in branchFixed in SCM revision3ea47b48a028
ProjectionnoneETAnoneTarget Version3.0PR16Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0033064: form widgets can be added to workspace

DescriptionWidgets can be designed to be included within a form. In these cases it might not be desirable to allow the widget to be displayed in workspace.

Currently, all widgets regardless what they are designed for, can be added to workspace.
Steps To Reproduce1. Create a widget to be included in a form [1]
2. Check it is possible to add it to workspace


[1] http://wiki.openbravo.com/wiki/How_to_embed_a_Widget_into_a_Window_Tab [^]
Proposed SolutionAdd a flag to widgets (defaulted to true) that defines whether it should be possible to add the widget to workspace.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0033144 closedinigosanchez API change because some java methods have been removed in MyOpenbravoComponent class. 

-  Notes
(0086968)
inigosanchez (developer)
2016-06-03 00:05

Added test cases in TestLink. Go to Platform > [WAW] Widget Available in Workspace.
(0086969)
hgbot (developer)
2016-06-03 00:06

Repository: erp/devel/pi
Changeset: 4c3b627a612c96a7d3acca4f5fa7a8b8ff38f000
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Jun 02 17:11:55 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/4c3b627a612c96a7d3acca4f5fa7a8b8ff38f000 [^]

Related with issue 33064: form widgets cant be added to workspace

It has implemented a new flag (Available_in_workspace) in the widget
definition that determines when a widget is available to be shown in
the workspace. We have also added the default values to the widgets
that already exist. By default yes.

---
M modules/org.openbravo.client.myob/src-db/database/model/tables/OBKMO_WIDGET_CLASS.xml
M modules/org.openbravo.client.myob/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.client.myob/src-db/database/sourcedata/AD_ELEMENT.xml
M modules/org.openbravo.client.myob/src-db/database/sourcedata/AD_FIELD.xml
M modules/org.openbravo.client.myob/src-db/database/sourcedata/OBKMO_WIDGET_CLASS.xml
M modules/org.openbravo.client.widgets/src-db/database/sourcedata/OBKMO_WIDGET_CLASS.xml
M src-db/database/sourcedata/OBKMO_WIDGET_CLASS.xml
---
(0086970)
hgbot (developer)
2016-06-03 00:06

Repository: erp/devel/pi
Changeset: 3ea47b48a0282754f31a4a068a2ca1e02486ecee
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Jun 02 17:14:50 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3ea47b48a0282754f31a4a068a2ca1e02486ecee [^]

Fixed issue 33064: form widgets cant be added to workspace

The problem was related with widgets that can be embedded
into a form. In some cases, these widgets should not be
placed into the workspace.

To resolve this problem in a generic way, it has been
implemented a flag (Available_in_workspace) in the widget
definition that determines when a widget is available to
be shown in the workspace.

Now, any widget that does not have selected the new flag,
will not appear in the list of widgets to place into the
workspace.

---
M modules/org.openbravo.client.myob/src/org/openbravo/client/myob/MyOpenbravoActionHandler.java
M modules/org.openbravo.client.myob/src/org/openbravo/client/myob/MyOpenbravoComponent.java
---
(0086971)
hgbot (developer)
2016-06-03 00:06

Repository: erp/devel/pi
Changeset: 4cb4e19893164c3e7b148172f198ba7729467670
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Jun 02 19:27:18 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/4cb4e19893164c3e7b148172f198ba7729467670 [^]

Related with issue 33064: Added default values in widgets.

---
M modules/org.openbravo.client.htmlwidget/src-db/database/sourcedata/OBKMO_WIDGET_CLASS.xml
M modules/org.openbravo.client.querylist/src-db/database/sourcedata/OBKMO_WIDGET_CLASS.xml
---
(0086973)
alostale (developer)
2016-06-03 09:03

Reopening due to code review: https://docs.google.com/a/openbravo.com/spreadsheets/d/1EWn_rz6r0x-cQPizxEyYNtBXVQdLP6baEUcyB2F_TuQ/edit?usp=sharing [^]
(0087047)
hgbot (developer)
2016-06-07 09:59

Repository: erp/devel/api-checks
Changeset: 20a70577d29ff7e34452e6556f9fbb7766c0837e
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Mon Jun 06 17:45:34 2016 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/20a70577d29ff7e34452e6556f9fbb7766c0837e [^]

Fixes issue 33144: API change for issue 33064.

---
M java/reference/java.japi.gz
---
(0087049)
hgbot (developer)
2016-06-07 10:00

Repository: erp/devel/pi
Changeset: e9720f1ccc77c20d5fcafef93411e246b1736360
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Mon Jun 06 16:44:06 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/e9720f1ccc77c20d5fcafef93411e246b1736360 [^]

Related with issue 33064: Code review improvements.

It have been added help and description values.
Besides it have been removed some unused methods:
getAvailableWidgetClasses. There is an API changes.

It has been removed unused test in myob module.

---
M modules/org.openbravo.client.myob/src-db/database/model/tables/OBKMO_WIDGET_CLASS.xml
M modules/org.openbravo.client.myob/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.client.myob/src-db/database/sourcedata/AD_ELEMENT.xml
M modules/org.openbravo.client.myob/src-db/database/sourcedata/AD_FIELD.xml
M modules/org.openbravo.client.myob/src/org/openbravo/client/myob/MyOpenbravoActionHandler.java
M modules/org.openbravo.client.myob/src/org/openbravo/client/myob/MyOpenbravoComponent.java
R modules/org.openbravo.client.myob/src-test/org/openbravo/client/myob/test/MyOpenbravoTest.java
---
(0087052)
hgbot (developer)
2016-06-07 10:58

Repository: erp/devel/api-checks
Changeset: 06637790bbcff215589b83d223c78c6e1b70d048
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Tue Jun 07 10:56:30 2016 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/06637790bbcff215589b83d223c78c6e1b70d048 [^]

Related issue 33144: Fixed API change for issue 33064

---
M java/reference/java.japi.gz
---
(0087054)
hgbot (developer)
2016-06-07 11:25

Repository: erp/devel/api-checks
Changeset: 55e301a659ee2a0d8a681f1e3ea3cbdcac2716ca
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Tue Jun 07 11:24:11 2016 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/55e301a659ee2a0d8a681f1e3ea3cbdcac2716ca [^]

Related issue 33144: Last API change for issue 33064

These API changes are the good ones. It had made mistakes
in the previous commits.

---
M java/reference/java.japi.gz
---
(0087146)
hgbot (developer)
2016-06-10 08:50

Repository: erp/devel/pi
Changeset: 0323d44c7e7ca04776b8906ceeaa7a8d5ed3b9e9
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Jun 10 08:49:34 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/0323d44c7e7ca04776b8906ceeaa7a8d5ed3b9e9 [^]

related to issue 33064: changes in help/description

---
M modules/org.openbravo.client.myob/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.client.myob/src-db/database/sourcedata/AD_ELEMENT.xml
M modules/org.openbravo.client.myob/src-db/database/sourcedata/AD_FIELD.xml
---
(0087265)
hgbot (developer)
2016-06-14 19:08

Repository: erp/pmods/org.openbravo.client.analytics
Changeset: c63cc0c2d192e3ee232d1703d9a353346832b4ff
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Tue Jun 14 18:15:47 2016 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.client.analytics/rev/c63cc0c2d192e3ee232d1703d9a353346832b4ff [^]

Related with issue 33050:Fix db consistency of analytics module.

DB Consistency related to issue 33064: form widgets can be added
to workspace. Added default value in widgets that already exist
in analytics module.

---
M src-db/database/sourcedata/OBKMO_WIDGET_CLASS.xml
---
(0087270)
hgbot (developer)
2016-06-14 19:10

Repository: erp/pmods/org.openbravo.retail.analytics
Changeset: cf27a5380dbd0c808852c1ea53f08cf2c4af8485
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Tue Jun 14 18:30:29 2016 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.analytics/rev/cf27a5380dbd0c808852c1ea53f08cf2c4af8485 [^]

Related with issue 33050:Fix db consistency of retail.analytics module.

DB Consistency related to issue 33064: form widgets can be added to
workspace. Added default value in widgets that already exist in
retail.analytics module.

---
M src-db/database/sourcedata/OBKMO_WIDGET_CLASS.xml
---
(0087587)
hudsonbot (developer)
2016-06-17 19:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0dc7be081b1c [^]
Maturity status: Test
(0087588)
hudsonbot (developer)
2016-06-17 19:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0dc7be081b1c [^]
Maturity status: Test
(0087589)
hudsonbot (developer)
2016-06-17 19:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0dc7be081b1c [^]
Maturity status: Test
(0087595)
hudsonbot (developer)
2016-06-17 19:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0dc7be081b1c [^]
Maturity status: Test
(0087600)
hudsonbot (developer)
2016-06-17 19:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0dc7be081b1c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-05-26 17:08 alostale New Issue
2016-05-26 17:08 alostale Assigned To => platform
2016-05-26 17:08 alostale Modules => Core
2016-05-26 17:08 alostale Triggers an Emergency Pack => No
2016-05-26 17:08 alostale Target Version => 3.0PR16Q4
2016-05-26 17:08 alostale Status new => acknowledged
2016-06-01 15:00 inigosanchez Status acknowledged => scheduled
2016-06-01 15:00 inigosanchez Assigned To platform => inigosanchez
2016-06-03 00:04 inigosanchez Review Assigned To => alostale
2016-06-03 00:05 inigosanchez Note Added: 0086968
2016-06-03 00:06 hgbot Checkin
2016-06-03 00:06 hgbot Note Added: 0086969
2016-06-03 00:06 hgbot Checkin
2016-06-03 00:06 hgbot Note Added: 0086970
2016-06-03 00:06 hgbot Status scheduled => resolved
2016-06-03 00:06 hgbot Resolution open => fixed
2016-06-03 00:06 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3ea47b48a0282754f31a4a068a2ca1e02486ecee [^]
2016-06-03 00:06 hgbot Checkin
2016-06-03 00:06 hgbot Note Added: 0086971
2016-06-03 09:03 alostale Note Added: 0086973
2016-06-03 09:03 alostale Status resolved => new
2016-06-03 09:03 alostale Resolution fixed => open
2016-06-06 10:02 inigosanchez Relationship added related to 0033144
2016-06-07 09:55 inigosanchez Status new => scheduled
2016-06-07 09:59 hgbot Checkin
2016-06-07 09:59 hgbot Note Added: 0087047
2016-06-07 10:00 hgbot Checkin
2016-06-07 10:00 hgbot Note Added: 0087049
2016-06-07 10:58 hgbot Checkin
2016-06-07 10:58 hgbot Note Added: 0087052
2016-06-07 11:25 hgbot Checkin
2016-06-07 11:25 hgbot Note Added: 0087054
2016-06-07 11:42 inigosanchez Status scheduled => resolved
2016-06-07 11:42 inigosanchez Resolution open => fixed
2016-06-10 08:50 hgbot Checkin
2016-06-10 08:50 hgbot Note Added: 0087146
2016-06-10 08:53 alostale Status resolved => closed
2016-06-10 08:53 alostale Fixed in Version => 3.0PR16Q3
2016-06-14 19:08 hgbot Checkin
2016-06-14 19:08 hgbot Note Added: 0087265
2016-06-14 19:10 hgbot Checkin
2016-06-14 19:10 hgbot Note Added: 0087270
2016-06-17 19:38 hudsonbot Checkin
2016-06-17 19:38 hudsonbot Note Added: 0087587
2016-06-17 19:38 hudsonbot Checkin
2016-06-17 19:38 hudsonbot Note Added: 0087588
2016-06-17 19:38 hudsonbot Checkin
2016-06-17 19:38 hudsonbot Note Added: 0087589
2016-06-17 19:38 hudsonbot Checkin
2016-06-17 19:38 hudsonbot Note Added: 0087595
2016-06-17 19:38 hudsonbot Checkin
2016-06-17 19:38 hudsonbot Note Added: 0087600


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker