Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032970
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Modules] Multi-Dimensional Profit And Lossmajoralways2016-05-17 11:192016-05-20 08:48
ReporterngarciaView Statuspublic 
Assigned Tocaristu 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionb3c7a6bd32cc
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Regression date
Regression introduced by commit
Regression level
Review Assigned Toalostale
Regression introduced in release
Summary

0032970: Cannot launch Multi-Dimensional Profit And Loss if the Account is included as Member and Children

DescriptionCannot launch Multi-Dimensional Profit And Loss if the Account is included as Member and Children
Steps To ReproduceAs system admin role:
   Install the Multi-Dimensional Profit And Loss module
   Create the cubes from the templates
   Launch the Update Time Reference... background process
As group admin role:
   Configure the 'PYG - Pérdidas y ganancias' account in the Cube Definition window for 'DPL - P&L - F&B España, S.A. US_A_Euro' cube and 'PL - Profit & Loss' for 'DPL - P&L - F&B International Group US_A_US Dollar' cube
   Set both as Show = Member and Children (Cube Report Dimension Element tab)
   Launch the Generate Profit And Loss Fact Acct background process
   Go to Multi-dimensional Profit and Loss window and launch the report
   A pop-up appears with Error loading query message
   The log shows:
ERROR org.saiku.web.rest.resources.Query2Resource - Error creating new query
org.saiku.olap.util.exception.SaikuIncompatibleException: Cannot convert member selection using operator: CHILDREN
      
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0037100 acknowledgedplatform Multi-Dimensional Profit and Loss shows information collapsed 

-  Notes
(0086502)
caristu (developer)
2016-05-17 15:59

The problem seems to be on Saiku's QueryConverter class. It can not convert query models with Selections having type = "member" and an operator different from MEMBER (like CHILDREN in this case).
(0086508)
hgbot (developer)
2016-05-17 19:38

Repository: erp/pmods/org.openbravo.financial.dimensionalreports
Changeset: b3c7a6bd32cccb849466e698e044518ba5284320
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue May 17 19:37:06 2016 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.financial.dimensionalreports/rev/b3c7a6bd32cccb849466e698e044518ba5284320 [^]

fixes issue 32970: Error if the Account is included as Member and Children
Saiku's QueryConverter does not allow to have Selections defined with type='member' and operator='CHILDREN'. To avoid this problem, when using the 'CHILDREN' operator the member type is set as 'level'.

---
M src/org/openbravo/financial/dimensionalreports/DimensionalReportsUtils.java
---
(0086590)
alostale (developer)
2016-05-20 08:48

code reviewed + tested

- Issue History
Date Modified Username Field Change
2016-05-17 11:19 ngarcia New Issue
2016-05-17 11:19 ngarcia Assigned To => Triage Finance
2016-05-17 11:19 ngarcia Assigned To Triage Finance => caristu
2016-05-17 11:19 ngarcia Issue Monitored: networkb
2016-05-17 15:55 caristu Status new => scheduled
2016-05-17 15:59 caristu Note Added: 0086502
2016-05-17 19:38 hgbot Checkin
2016-05-17 19:38 hgbot Note Added: 0086508
2016-05-17 19:38 hgbot Status scheduled => resolved
2016-05-17 19:38 hgbot Resolution open => fixed
2016-05-17 19:38 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.financial.dimensionalreports/rev/b3c7a6bd32cccb849466e698e044518ba5284320 [^]
2016-05-17 19:38 caristu Review Assigned To => alostale
2016-05-20 08:48 alostale Note Added: 0086590
2016-05-20 08:48 alostale Status resolved => closed
2017-10-18 11:23 maite Relationship added related to 0037100


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker