Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032707
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] K. Packagingminoralways2016-04-19 12:142016-06-17 19:37
ReporteryogaskarnikView Statuspublic 
Assigned ToNaroaIriarte 
PrioritynormalResolutionfixedFixed in Version3.0PR16Q3
StatusclosedFix in branchFixed in SCM revision31f0af79e203
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseOracleJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2015-08-19
Regression introduced in release3.0PR15Q4
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/243b29f38be260b5dec6743eebe89e5adbbafb24 [^]
Triggers an Emergency PackNo
Summary

0032707: java.sql.SQLSyntaxErrorException: ORA-00918 while packaging module

DescriptionUsing an Oracle database, when a module with at least one table is being packaged the following error is shown:

java.sql.SQLSyntaxErrorException: ORA-00918: column ambiguously defined.
Steps To Reproduce1- Create a module with at least one table.
2- Try to package it executing the following command:
    
     ant package.module -Dmodule=<module name>

3- Realize that the "ORA-00918: column ambiguously defined." error message is shown.
Proposed SolutionIn Oracle it is not possible to do the validation, but the module can be exported.

This is the workaround:

ant package.module -Dmodule=<module name> -Dobx.export.validate=false
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00327353.0PR16Q2 closedNaroaIriarte java.sql.SQLSyntaxErrorException: ORA-00918 while packaging module 
depends on backport 00327363.0PR16Q1.2 closedNaroaIriarte java.sql.SQLSyntaxErrorException: ORA-00918 while packaging module 
depends on backport 00327373.0PR15Q4.6 closedNaroaIriarte java.sql.SQLSyntaxErrorException: ORA-00918 while packaging module 
caused by feature request 00301793.0PR15Q4 closedAugustoMauch DBSourceManager support indexes with functions 

-  Notes
(0085900)
hgbot (developer)
2016-04-22 15:04

Repository: erp/devel/dbsm-main
Changeset: 87275e76980ecc9f5877b74426faa9f5a96eddc3
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Wed Apr 20 15:02:08 2016 +0200
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/87275e76980ecc9f5877b74426faa9f5a96eddc3 [^]

Fixed issue 32707: ORA-00918 error was get while packaging module

When a module was being packed in oracle, that error was shown.
This means that a column in ambiguously created.

The problem was in a query.
It was trying to execute a query where there were two tables with
a column with the same name. TABLE_NAME was being exectued insetad of
U.TABLE_NAME (with the alias of the table), and as that column exists in the two
tables, that error was raised.

---
M src/org/apache/ddlutils/platform/oracle/OracleModelLoader.java
---
(0085901)
hgbot (developer)
2016-04-22 15:04

Repository: erp/devel/pi
Changeset: 31f0af79e203487fc562dd4993e6aa9598a578bb
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Wed Apr 20 15:20:32 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/31f0af79e203487fc562dd4993e6aa9598a578bb [^]

Fixed issue 32707: ORA-00918 error was got while packaging module

When a module was being packed in oracle, that error was shown.
This means that a column in ambiguously created.

The problem was in a query.
It was trying to execute a query where there were two tables with
a column with the same name. TABLE_NAME was being exectued insetad of
U.TABLE_NAME (with the alias of the table), and as that column exists in the two
tables, that error was raised.

---
M src-db/database/lib/dbsourcemanager.jar
---
(0086083)
alostale (developer)
2016-04-29 14:12

code reviewed + tested
(0087486)
hudsonbot (developer)
2016-06-17 19:37

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0dc7be081b1c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-04-19 12:14 yogaskarnik New Issue
2016-04-19 12:14 yogaskarnik Assigned To => shuehner
2016-04-19 12:14 yogaskarnik Modules => Core
2016-04-19 12:14 yogaskarnik Triggers an Emergency Pack => No
2016-04-19 13:36 shuehner Assigned To shuehner => platform
2016-04-19 16:24 NaroaIriarte Assigned To platform => NaroaIriarte
2016-04-19 16:24 NaroaIriarte Status new => acknowledged
2016-04-19 16:24 NaroaIriarte Status acknowledged => scheduled
2016-04-20 15:38 NaroaIriarte Relationship added caused by 0030179
2016-04-20 15:43 NaroaIriarte Regression level => Production - Confirmed Stable
2016-04-20 15:43 NaroaIriarte Regression date => 2015-08-19
2016-04-20 15:43 NaroaIriarte Regression introduced in release => 3.0PR15Q4
2016-04-20 15:43 NaroaIriarte Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/243b29f38be260b5dec6743eebe89e5adbbafb24 [^]
2016-04-20 15:56 NaroaIriarte Status scheduled => feedback
2016-04-20 15:57 NaroaIriarte Status feedback => new
2016-04-20 16:00 NaroaIriarte Severity major => minor
2016-04-20 16:00 NaroaIriarte Proposed Solution updated
2016-04-20 16:01 NaroaIriarte Status new => scheduled
2016-04-22 14:57 NaroaIriarte Description Updated View Revisions
2016-04-22 14:57 NaroaIriarte Steps to Reproduce Updated View Revisions
2016-04-22 15:04 hgbot Checkin
2016-04-22 15:04 hgbot Note Added: 0085900
2016-04-22 15:04 hgbot Status scheduled => resolved
2016-04-22 15:04 hgbot Resolution open => fixed
2016-04-22 15:04 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/dbsm-main/rev/87275e76980ecc9f5877b74426faa9f5a96eddc3 [^]
2016-04-22 15:04 hgbot Checkin
2016-04-22 15:04 hgbot Note Added: 0085901
2016-04-22 15:04 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/dbsm-main/rev/87275e76980ecc9f5877b74426faa9f5a96eddc3 [^] => http://code.openbravo.com/erp/devel/pi/rev/31f0af79e203487fc562dd4993e6aa9598a578bb [^]
2016-04-29 14:12 alostale Review Assigned To => alostale
2016-04-29 14:12 alostale Note Added: 0086083
2016-04-29 14:12 alostale Status resolved => closed
2016-04-29 14:12 alostale Fixed in Version => 3.0PR16Q3
2016-06-17 19:37 hudsonbot Checkin
2016-06-17 19:37 hudsonbot Note Added: 0087486


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker