Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032560
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2016-03-31 02:492016-08-11 18:40
ReporterrbianchiniView Statuspublic 
Assigned ToAtulOpenbravo 
PrioritynormalResolutionfixedFixed in Version3.0PR16Q4
StatusclosedFix in branchFixed in SCM revision3abacd38deed
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0PR16Q1SCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032560: Allow to invoice an already invoiced goods receipt

DescriptionTested on 15Q3.5, 15Q4.5, 16Q1

If you create a purchase order and complete it, then create a purchase invoice using the copy lines from button in the purchase invoice window, then create the goods receipt using the pending good receipts window, the application allows you to invoice that goods receipt, but it is already invoiced, so you have 2 purchase invoice with the same goods.

Note: if the goods receipt is created using the create lines from button on goods receipt window, instead of using the pending goods receipt window, and you try to invoice the goods receipt, the application detects that is already invoiced.
Steps To Reproduce1 - Create a purchase order and complete it
2 - Create a purchase invoice header
3 - Click on copy lines from button and copy the lines from the purchase order created in step 1
4 - Complete the purchase invoice
5 - Go to Pending Goods Receipts window and create the goods receipt from the purchase order created in step 1
6 - Open the goods receipt generated in step 5
7 - Click on generate invoice from receipt button
8 - Realize you have 2 purchase invoices for the same purchase order
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0033042 newTriage Finance Partially shipped Goods Shipment Line is linked to completely invoiced Sales Invoice Line 

-  Notes
(0088246)
vmromanos (developer)
2016-07-06 16:58

In the steps to reproduce "copy lines from" means "Create lines from".

Problem seems to be in Pending Goods receipt process, that should detect a previous invoice has been created for this order, and update the goods receipt line field at invoice line level just after creating the goods receipt
(0088281)
AtulOpenbravo (developer)
2016-07-07 11:56

Test Plan
- Create a purchase order and complete it.
- Create a purchase invoice header.
- Click on "create lines from" button and copy the lines from the purchase order created in step 1.
- Complete the purchase invoice.
- Go to Pending Goods Receipts window and create the goods receipt from the purchase order created in step 1.
- Open the goods receipt generated in step 5.
- Click on generate invoice from receipt button.
- Check that error is shown regarding receipt is already invoiced.
(0088326)
vmromanos (developer)
2016-07-08 10:21

The resolution time is wrong: it was reported as OBPS in 2016-07-06 and the resolution time is set to 2016-06-27
(0088328)
hgbot (developer)
2016-07-08 11:15

Repository: erp/devel/pi
Changeset: 3abacd38deed78abcd36f022fa54d2bde448b092
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Thu Jul 07 18:32:05 2016 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/3abacd38deed78abcd36f022fa54d2bde448b092 [^]

Fixes Issue 32560:Allow to invoice an already invoiced goods receipt

when creating goods receipt using "Pending Goods Receipt", associated
purchase invoice line with related purchase order line is updated with
the goods receipt line reference.

---
M src/org/openbravo/erpCommon/ad_forms/MaterialReceiptPending.java
M src/org/openbravo/erpCommon/ad_forms/MaterialReceiptPendingLines_data.xsql
---
(0088329)
vmromanos (developer)
2016-07-08 11:16

Code review + testing OK
(0089001)
hudsonbot (developer)
2016-08-11 18:40

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/edaa05b1fb18 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-03-31 02:49 rbianchini New Issue
2016-03-31 02:49 rbianchini Assigned To => Triage Finance
2016-03-31 02:49 rbianchini Modules => Core
2016-03-31 02:49 rbianchini Triggers an Emergency Pack => No
2016-07-06 16:58 vmromanos Note Added: 0088246
2016-07-06 16:58 vmromanos Assigned To Triage Finance => AtulOpenbravo
2016-07-07 11:56 AtulOpenbravo Status new => scheduled
2016-07-07 11:56 AtulOpenbravo Note Added: 0088281
2016-07-08 10:21 vmromanos Note Added: 0088326
2016-07-08 11:12 vmromanos Relationship added related to 0033042
2016-07-08 11:15 hgbot Checkin
2016-07-08 11:15 hgbot Note Added: 0088328
2016-07-08 11:15 hgbot Status scheduled => resolved
2016-07-08 11:15 hgbot Resolution open => fixed
2016-07-08 11:15 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3abacd38deed78abcd36f022fa54d2bde448b092 [^]
2016-07-08 11:16 vmromanos Review Assigned To => vmromanos
2016-07-08 11:16 vmromanos Note Added: 0088329
2016-07-08 11:16 vmromanos Status resolved => closed
2016-07-08 11:16 vmromanos Fixed in Version => 3.0PR16Q4
2016-08-11 18:40 hudsonbot Checkin
2016-08-11 18:40 hudsonbot Note Added: 0089001


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker