Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032472
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Modules] Procurement Contractsmajoralways2016-03-14 19:022016-04-01 15:03
ReporterngarciaView Statuspublic 
Assigned Tomarkmm82 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision1fbaf864028f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Regression date
Regression introduced by commit
Regression level
Review Assigned Todmiguelez
Regression introduced in release
Summary

0032472: Purchase Invoices with Total Gross Amount of 0 created from Procurement Contract Billing Process

DescriptionPurchase Invoices with Total Gross Amount of 0 created from Procurement Contract Billing Process
Steps To ReproduceAs group admin role:
   Apply module's dataset
   Create a new Contract Type:
      Service Contract: Y
      Sales Contract: N
   Create a Contract Invoice Schedule
   Create a Procurement Contract
   Fill all the fields in the header (Duration: 12 month, for instance)
   Add a line to it and fill all the fields
   Process it by selecting the option of Generate Invoice Plan
   Launch the Procurement Contract Billing Process for the Contract organization. Select a date range in order to create at least one invoice proposal
   Launch the Create Invoices process and check the created Purchase Invoice has a Total Gross Amount of 0
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0032428 closedmarkmm82 Openbravo ERP Wrong Tax Amount and Total Gross Amount in orders created by the Copy Record process if price list includes taxes 
related to defect 0032514 closedmarkmm82 Modules No Tax line created after running "Create Invoice" process in the Procurement Contract Invoice Proposal" window 
related to defect 0032555 newTriage Finance Modules Error shown when trying to complete a Procurement Contract - Mandatory fields can not be left empty, regardless it is not empty. 
caused by feature request 0028366 closedadrianromero Openbravo ERP Add new functionality to calculate taxes per product BOM 
related to defect 0032844 closedmarkmm82 Modules Wrong total net and gross amounts when generating an invoice with the Mass Invoicing process 

-  Notes
(0085009)
psanjuan (manager)
2016-03-16 15:36

Issue verified.

Check also that there is no info in the Tax tab, therefore regardless invoice can be posted, posting is Not OK.
(0085227)
markmm82 (developer)
2016-03-18 18:53
edited on: 2016-03-21 12:11

Test Plan
As group admin role:
   Apply module's dataset
   Create a new Contract Type:
      Service Contract: Y
      Sales Contract: N
   Create a Contract Invoice Schedule with this Contract Type with an Invoice Frequency = Annual
   Create a Procurement Contract
   Fill all the fields in the header (Duration: 2 years, for instance)
   Add a line to it and fill all the fields, mainly contract invoice schedule.
   Process it by selecting the option of Generate Invoice Plan
   Launch the Procurement Contract Billing Process for the Contract organization. Select a date range in order to create at least one invoice proposal (for instance 30 days) and select the BP. Press Done.
   Launch the Create Invoices process from the window "Procurement Contract Invoice Proposal" and check the created Purchase Invoice has a Total Gross Amount and Total Net Amount updated!

(0085239)
psanjuan (manager)
2016-03-21 12:12
edited on: 2016-03-21 13:48

As group admin role:
Apply module's dataset
Create a new Contract Type:
Service Contract: Y
Sales Contract: N
Create a Contract Invoice Schedule with this Contract Type with an Invoice Frequency = Annual

Test Plan 1

Go to Business Partner window and check that "La Fruta es la Vida" supplier has a purchase price list "Tarifa La Fruta es la Vida" do not set as "Price Including Taxes".
Check that "Zumo de Naranja Bio 0.33L" product is in that list with a purchase unit price = 0.89

Create a Procurement Contract by selecting contract type created.

Fill in all the fields in the header, as described below:
BP = La Fruta es la Vida
Starting date = 21-03-2016
Duration 3
Duration Unit = Year
Price List = Tarifa la Fruta es la vida

Go to Lines:

Add a line to it by selecting the contract invoice schedule created, Product = Zumo de Naranja 0.33L
Price = 0.89
Quantity = 100
Press Complete.

Process it by selecting the option of Generate Invoice Plan.

Launch the Procurement Contract Billing Process for the organization F&B España

Select a date range in order to create at least one invoice proposal (for instance from 01-01-2016 to 31-12-2016.
Select BP = La Fruta es la Vida.
Press Done.

Check that a new window is opened. Window "Procurement Contract Invoice Proposal".

Select one proposal and run "Create Invoices" process.

Check that a new purchase invoice has been created. For instance 10000887.

Go to that invoice and verify below data:

Invoiced quantity = 100
Unit Price = 0.89
Line Net Amount = 89
Tax 21%
Total Net Amount = 89.00
Total Gross Amount 107.69 (89+21%s/89)
Above is correct.

Go to tax tab and verify it is empty, therefore invoice posting shown below is not correct:
DEBIT 89.00 (60000) Compra de mercaderías
DEBIT 18.69 (90400) Cuenta de cuadre
CREDIT 107.69 (40000) Proveedores.
See issue related: 32514

Test Plan 2

Repeat same steps as test plan 1 but setting "Tarifa La Fruta es la Vida" as Price Including taxes =Yes.

Check that a new purchase invoice has been created. For instance 10000888.

Go to that invoice and verify below data:

Invoiced quantity = 100
Unit Price = 0.7355 (0.89/1.21)
Line Net Amount = 73.55
Tax 21%
Total Net Amount = 73.55
Total Gross Amount 89.00
Above is correct.

Go to tax tab and verify it is empty, therefore invoice posting shown below is not correct:
DEBIT 73.55(60000) Compra de mercaderías
DEBIT 15.45(90400) Cuenta de cuadre
CREDIT 89.00 (40000) Proveedores.
See issue related: 32514

(0085248)
psanjuan (manager)
2016-03-21 13:48

Test Plan above verified.

Issue can be code reviewed and closed.
(0085391)
hgbot (developer)
2016-04-01 14:39

Repository: erp/pmods/org.openbravo.procurement.contract
Changeset: 1fbaf864028f7967704a068f9b6d22055a71603f
Author: Mark <m.molina <at> nectus.com>
Date: Wed Mar 30 11:03:02 2016 -0400
URL: http://code.openbravo.com/erp/pmods/org.openbravo.procurement.contract/rev/1fbaf864028f7967704a068f9b6d22055a71603f [^]

Fixes issue 32514, Fixes Issue 32472 : Purchase Invoices with right Total Gross Amount
created from Procurement Contract Billing Process
The amounts for the created Purchase Invoices were updated.
No Tax line created after running "Create Invoice" process.
Tax line is created after running "Create Invoice" process in the "Procurement Contract Invoice Proposal" window.

---
M src/org/openbravo/procurement/contract/process/ProcurementContractInvoiceProcess.java
---
(0085393)
dmiguelez (developer)
2016-04-01 14:40

Code Review + Testing Ok
(0085397)
ngarcia (developer)
2016-04-01 15:03

Pending to publish the 1.0.200 version of Procurement Contracts module

- Issue History
Date Modified Username Field Change
2016-03-14 19:02 ngarcia New Issue
2016-03-14 19:02 ngarcia Assigned To => Triage Finance
2016-03-14 19:02 ngarcia Resolution time => 1460844000
2016-03-14 19:02 ngarcia Priority urgent => immediate
2016-03-14 19:02 ngarcia Relationship added caused by 0028366
2016-03-14 19:02 ngarcia Issue Monitored: networkb
2016-03-15 17:27 aferraz Relationship added related to 0032428
2016-03-16 15:36 psanjuan Note Added: 0085009
2016-03-17 15:31 markmm82 Assigned To Triage Finance => markmm82
2016-03-17 15:31 markmm82 Status new => scheduled
2016-03-18 18:53 markmm82 Note Added: 0085227
2016-03-21 12:07 psanjuan Note Edited: 0085227 View Revisions
2016-03-21 12:08 psanjuan Note Edited: 0085227 View Revisions
2016-03-21 12:09 psanjuan Note Edited: 0085227 View Revisions
2016-03-21 12:11 psanjuan Note Edited: 0085227 View Revisions
2016-03-21 12:12 psanjuan Note Added: 0085239
2016-03-21 12:31 psanjuan Note Edited: 0085239 View Revisions
2016-03-21 12:45 psanjuan Note Edited: 0085239 View Revisions
2016-03-21 13:13 psanjuan Note Edited: 0085239 View Revisions
2016-03-21 13:27 psanjuan Note Edited: 0085239 View Revisions
2016-03-21 13:33 psanjuan Note Edited: 0085239 View Revisions
2016-03-21 13:42 psanjuan Note Edited: 0085239 View Revisions
2016-03-21 13:47 psanjuan Note Edited: 0085239 View Revisions
2016-03-21 13:47 psanjuan Relationship added related to 0032514
2016-03-21 13:48 psanjuan Note Edited: 0085239 View Revisions
2016-03-21 13:48 psanjuan Note Added: 0085248
2016-03-30 10:07 psanjuan Relationship added related to 0032555
2016-04-01 14:39 hgbot Checkin
2016-04-01 14:39 hgbot Note Added: 0085391
2016-04-01 14:39 hgbot Status scheduled => resolved
2016-04-01 14:39 hgbot Resolution open => fixed
2016-04-01 14:39 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.procurement.contract/rev/1fbaf864028f7967704a068f9b6d22055a71603f [^]
2016-04-01 14:40 dmiguelez Review Assigned To => dmiguelez
2016-04-01 14:40 dmiguelez Note Added: 0085393
2016-04-01 14:40 dmiguelez Status resolved => closed
2016-04-01 15:03 ngarcia Note Added: 0085397
2016-05-04 10:04 aferraz Relationship added related to 0032844


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker