Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032460
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] Y. DBSourceManagerminorhave not tried2016-03-11 11:342016-03-23 08:57
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revision775ccd9fca46
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032460: Add a flag to run install.source and update.database without executing the module scripts

DescriptionIn some scenarios the person executing install.source or update.database knows for sure that there is no need to execute the modulescripts (i.e. because he knows for sure that the imported data does not need to be fixed).

It would be very useful have a flag to disable the execution of the modulescripts when executing those tasks.
Steps To Reproduce-
Proposed SolutionAdd a flag to the install.source and update.database task that disables the execution of modulescripts, like this:

ant install.source -Dexecute.modulescripts=false
ant update.database -Dexecute.modulescripts=false
ant smartbuild -Dlocal=no -Dexecute.modulescripts=false
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0084912)
vmromanos (developer)
2016-03-11 13:42

Same logic for smartbuild -Dlocal=no should be useful too
(0084942)
hgbot (developer)
2016-03-14 10:47

Repository: erp/devel/pi
Changeset: 8d0b0cebab04a2d42f478c54e79f0c2c39039bea
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Mar 14 10:42:09 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/8d0b0cebab04a2d42f478c54e79f0c2c39039bea [^]

Fixes issue 32460:install.source can be invoked without executing modulescripts

A flag called execute.modulescripts has been added to allow invoking the install.source task without executing the modulescripts. Specifically the flag has been added to the impo
rt.sample.data task, which is invoked from the install.source task. The new parameter is set like this:

ant install.source -Dexecute.modulescripts=false

If the new parameter is not specified, the modulescripts will be executed by default.

---
M build.xml
M src-db/database/build.xml
M src-db/database/lib/dbsourcemanager.jar
---
(0084943)
hgbot (developer)
2016-03-14 10:47

Repository: erp/devel/dbsm-main
Changeset: d6034c34392c641b05535ccbde24a05ea14c17f9
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Mar 14 09:59:58 2016 +0100
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/d6034c34392c641b05535ccbde24a05ea14c17f9 [^]

Fixes issue 32460:install.source can be invoked without executing modulescripts

A flag called execute.modulescripts has been added to allow invoking the install.source task without executing the modulescripts. Specifically the flag has been added to the impo
rt.sample.data task, which is invoked from the install.source task. The new parameter is set like this:

ant install.source -Dexecute.modulescripts=false

If the new parameter is not specified, the modulescripts will be executed by default.

---
M src/org/openbravo/ddlutils/task/ImportSampledata.java
---
(0084944)
AugustoMauch (developer)
2016-03-14 10:47

The fix has passed Try
(0084945)
AugustoMauch (developer)
2016-03-14 10:50

The documentation has been updated here [1]

[1] http://wiki.openbravo.com/wiki/How_to_create_a_Store_Server#Install_the_store_server_.26_data [^]
(0085022)
hgbot (developer)
2016-03-17 09:55

Repository: erp/devel/dbsm-main
Changeset: 5c5e182703137160a94f28e3df31b3bba59aad46
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Mar 17 09:48:34 2016 +0100
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/5c5e182703137160a94f28e3df31b3bba59aad46 [^]

Related with issue 32460: modulescripts can be disabled in update.database

The fix of 32460 has been extended to be able to disable the execution of modulescripts also when updating the database. It has been tested both with the update.database and with the smartbuild -Dlocal=no tasks.

---
M src/org/openbravo/ddlutils/task/AlterDatabaseDataAll.java
M src/org/openbravo/ddlutils/task/AlterDatabaseJava.java
---
(0085023)
hgbot (developer)
2016-03-17 09:56

Repository: erp/devel/pi
Changeset: 1295b207c102192a3cb2fd77caae8a62a0e4dffe
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Mar 17 09:50:30 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/1295b207c102192a3cb2fd77caae8a62a0e4dffe [^]

Related with issue 32460: modulescripts can be disabled in update.database

The fix of 32460 has been extended to be able to disable the execution of modulescripts also when updating the database. It has been tested both with the update.database and with
 the smartbuild -Dlocal=no tasks.

---
M src-db/database/build.xml
M src-db/database/lib/dbsourcemanager.jar
---
(0085197)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0085213)
hudsonbot (developer)
2016-03-17 20:32

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0a46b38a4b04 [^]
Maturity status: Test
(0085220)
alostale (developer)
2016-03-18 09:00

reopening due to code review:

  * Centralize definition of execute.modulescripts in build.xml: currently it's defined in 3 different places
  * Log info message when skipping module scripts
  * Ensure AlterDatabaseJava sets same falsy/truthy values than when AlterDatabase task is directly invoked from ant
(0085233)
hgbot (developer)
2016-03-21 09:26

Repository: erp/devel/pi
Changeset: 775ccd9fca460084f6872d15573f42a9aa349534
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Mar 21 09:22:39 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/775ccd9fca460084f6872d15573f42a9aa349534 [^]

Fixes issue 32460: Improves log. Supports true, yes and on literals

If modulescripts are skipped, it is shown in hte log. Also now it is possible to use 'yes', 'true' and 'on' as the property value to specify that the modulescripts should be exec
uted, as it is defined in the standard (see [1]).

Also the execute.modulescripts property is now defined only once in the build.xml.

[1] https://ant.apache.org/manual/develop.html [^]

---
M src-db/database/build.xml
M src-db/database/lib/dbsourcemanager.jar
---
(0085272)
hudsonbot (developer)
2016-03-23 01:59

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f4f7526c0d97 [^]
Maturity status: Test
(0085280)
hgbot (developer)
2016-03-23 08:51

Repository: erp/devel/dbsm-main
Changeset: c204e6f0767c6e40b640fd2f339383e598f85efd
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Mar 21 09:19:19 2016 +0100
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/c204e6f0767c6e40b640fd2f339383e598f85efd [^]

Related with issue 32460: Improves log. Supports true, yes and on literals

If modulescripts are skipped, it is shown in hte log. Also now it is possible to use 'yes', 'true' and 'on' as the property value to specify that the modulescripts should be executed, as it is defined in the standard (see [1]).

[1] https://ant.apache.org/manual/develop.html [^]

---
M src/org/openbravo/ddlutils/task/AlterDatabaseDataAll.java
M src/org/openbravo/ddlutils/task/AlterDatabaseJava.java
M src/org/openbravo/ddlutils/task/ImportSampledata.java
---
(0085281)
alostale (developer)
2016-03-23 08:57

code reviewed + tested

- Issue History
Date Modified Username Field Change
2016-03-11 11:34 AugustoMauch New Issue
2016-03-11 11:34 AugustoMauch Assigned To => platform
2016-03-11 11:34 AugustoMauch Modules => Core
2016-03-11 11:34 AugustoMauch Triggers an Emergency Pack => No
2016-03-11 13:42 vmromanos Note Added: 0084912
2016-03-14 10:03 AugustoMauch Review Assigned To => alostale
2016-03-14 10:47 hgbot Checkin
2016-03-14 10:47 hgbot Note Added: 0084942
2016-03-14 10:47 hgbot Status new => resolved
2016-03-14 10:47 hgbot Resolution open => fixed
2016-03-14 10:47 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/8d0b0cebab04a2d42f478c54e79f0c2c39039bea [^]
2016-03-14 10:47 hgbot Checkin
2016-03-14 10:47 hgbot Note Added: 0084943
2016-03-14 10:47 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/8d0b0cebab04a2d42f478c54e79f0c2c39039bea [^] => http://code.openbravo.com/erp/devel/dbsm-main/rev/d6034c34392c641b05535ccbde24a05ea14c17f9 [^]
2016-03-14 10:47 AugustoMauch Note Added: 0084944
2016-03-14 10:50 AugustoMauch Note Added: 0084945
2016-03-17 09:54 AugustoMauch Summary Add a flag to run install.source without executing the module scripts => Add a flag to run install.source and update.database without executing the module scripts
2016-03-17 09:54 AugustoMauch Description Updated View Revisions
2016-03-17 09:54 AugustoMauch Proposed Solution updated
2016-03-17 09:55 hgbot Checkin
2016-03-17 09:55 hgbot Note Added: 0085022
2016-03-17 09:56 hgbot Checkin
2016-03-17 09:56 hgbot Note Added: 0085023
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085197
2016-03-17 20:32 hudsonbot Checkin
2016-03-17 20:32 hudsonbot Note Added: 0085213
2016-03-18 08:29 alostale Assigned To platform => AugustoMauch
2016-03-18 09:00 alostale Note Added: 0085220
2016-03-18 09:00 alostale Status resolved => new
2016-03-18 09:00 alostale Resolution fixed => open
2016-03-21 09:26 hgbot Checkin
2016-03-21 09:26 hgbot Note Added: 0085233
2016-03-21 09:26 hgbot Status new => resolved
2016-03-21 09:26 hgbot Resolution open => fixed
2016-03-21 09:26 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/dbsm-main/rev/d6034c34392c641b05535ccbde24a05ea14c17f9 [^] => http://code.openbravo.com/erp/devel/pi/rev/775ccd9fca460084f6872d15573f42a9aa349534 [^]
2016-03-23 01:59 hudsonbot Checkin
2016-03-23 01:59 hudsonbot Note Added: 0085272
2016-03-23 08:51 hgbot Checkin
2016-03-23 08:51 hgbot Note Added: 0085280
2016-03-23 08:57 alostale Note Added: 0085281
2016-03-23 08:57 alostale Status resolved => closed
2016-03-23 08:57 alostale Fixed in Version => 3.0PR16Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker