Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032392
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2016-03-03 09:442016-06-17 19:36
ReporterngarciaView Statuspublic 
Assigned Tomarkmm82 
PriorityurgentResolutionfixedFixed in Version3.0PR16Q3
StatusclosedFix in branchFixed in SCM revision8f219033b0d8
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032392: Wrong value in qtyreserved column of m_storage_pending when creating an order from a sales quotation

DescriptionWrong value in qtyreserved column of m_storage_pending when creating an order from a sales quotation
Steps To ReproduceAs group admin role:
   Create a new product, set it as stocked and add a sales price list to it
   Create a Sales Quotation and add it
   Check the M_STORAGE_PENDING is empty for that product
   Launch the Create Order process from it
   Check qtyreserved is twice the ordered quantity in the M_STORAGE_PENDING for that product. It should be the ordered quantity
   Create the shipment
   Check qtyreserved is the ordered quantity in the M_STORAGE_PENDING for that product. It should be 0
   
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0031833 closedaferraz Inconsistent data in M_STORAGE_PENDING table if the product is changed from Not Stocked to Stocked having pending orders 
related to defect 00246203.0MP28 closedpramakrishnan Sales quotation is modifying qty reserved in m_storage_pending table and it shouldn't 

-  Notes
(0085314)
markmm82 (developer)
2016-03-29 14:46

Test Plan:

As group admin role:
   Create a new product, set it as stocked and add a sales price list to it
   Create a Sales Quotation and add it
   Check the M_STORAGE_PENDING is empty for that product
   Launch the Create Order process from it
   Check qtyreserved is the ordered quantity in the M_STORAGE_PENDING for that product as expected.
   Create goods receipt for product created, with a movement quantity greater than reserved
   Create the shipment from the generated Order
   Check qtyreserved is 0 inside the M_STORAGE_PENDING for that product as expected.
(0085363)
psanjuan (manager)
2016-03-31 14:21

Test plan above verified.

Issue can be code reviewed and closed.
(0085407)
hgbot (developer)
2016-04-04 12:01

Repository: erp/devel/pi
Changeset: 8f219033b0d838be1b2cabd688b7d953bab9d193
Author: Mark <m.molina <at> nectus.com>
Date: Mon Mar 28 12:44:57 2016 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/8f219033b0d838be1b2cabd688b7d953bab9d193 [^]

Fixes issue 32392: Wrong value in qtyreserved column of m_storage_pending in sales quotation.

When the "Create Order process" was launched from a Sales Quotation that generates pending storage, the ordered quantity in the M_STORAGE_PENDING was the double than the original for a recently created product. It was caused because a double call of the M_UPDATE_STORAGE_PENDING PL. Inside the C_ORDER_POST PL (it creates the entry inside the M_STORAGE_PENDING with the quantity reserved), and then the lines were processed again, the M_UPDATE_STORAGE_PENDING was called again and it updates the previously created entry increasing the quantity reserved once more time.
The process is working as expected now.

---
M src/org/openbravo/erpCommon/ad_process/ConvertQuotationIntoOrder.java
---
(0085408)
hgbot (developer)
2016-04-04 12:01

Repository: erp/devel/pi
Changeset: b678870f424ca70165e1f2f1c7abe504073b018e
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Apr 04 11:59:06 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b678870f424ca70165e1f2f1c7abe504073b018e [^]

Related to issue 32392: Remove unused variables and methods

---
M src/org/openbravo/erpCommon/ad_process/ConvertQuotationIntoOrder.java
---
(0085409)
aferraz (developer)
2016-04-04 12:03

Code review OK
(0087414)
hudsonbot (developer)
2016-06-17 19:36

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0dc7be081b1c [^]
Maturity status: Test
(0087415)
hudsonbot (developer)
2016-06-17 19:36

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0dc7be081b1c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-03-03 09:44 ngarcia New Issue
2016-03-03 09:44 ngarcia Assigned To => Triage Finance
2016-03-03 09:44 ngarcia Modules => Core
2016-03-03 09:44 ngarcia Triggers an Emergency Pack => No
2016-03-03 09:45 ngarcia Issue Monitored: networkb
2016-03-03 09:49 ngarcia Relationship added related to 0031833
2016-03-28 07:43 Sanjota Assigned To Triage Finance => Sanjota
2016-03-29 14:35 markmm82 Note Added: 0085313
2016-03-29 14:37 markmm82 Note Deleted: 0085313
2016-03-29 14:46 markmm82 Note Added: 0085314
2016-03-29 16:58 markmm82 Assigned To Sanjota => markmm82
2016-03-29 16:58 markmm82 Status new => scheduled
2016-03-31 14:21 psanjuan Note Added: 0085363
2016-04-04 11:41 aferraz Relationship added related to 0024620
2016-04-04 12:01 hgbot Checkin
2016-04-04 12:01 hgbot Note Added: 0085407
2016-04-04 12:01 hgbot Status scheduled => resolved
2016-04-04 12:01 hgbot Resolution open => fixed
2016-04-04 12:01 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/8f219033b0d838be1b2cabd688b7d953bab9d193 [^]
2016-04-04 12:01 hgbot Checkin
2016-04-04 12:01 hgbot Note Added: 0085408
2016-04-04 12:03 aferraz Review Assigned To => aferraz
2016-04-04 12:03 aferraz Note Added: 0085409
2016-04-04 12:03 aferraz Status resolved => closed
2016-04-04 12:03 aferraz Fixed in Version => 3.0PR16Q3
2016-06-17 19:36 hudsonbot Checkin
2016-06-17 19:36 hudsonbot Note Added: 0087414
2016-06-17 19:36 hudsonbot Checkin
2016-06-17 19:36 hudsonbot Note Added: 0087415


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker