Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032323
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2016-02-23 18:582016-04-08 11:00
ReportermalsasuaView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision85f5f008873a
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2015-08-19
Regression introduced in release3.0PR15Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/d451a9fb55e553d4c6df0b6c3c57d02c90f52567 [^]
Triggers an Emergency PackNo
Summary

0032323: "generate invoice from receipt" button is not working

Descriptionin goods receipt window, if you try to execute the "generate invoice from receipt" process, error is returned:
null value in column "grosspricestd" violates not-null constraint
Steps To Reproduce. create a new good receipt
. add new line
. process
. click in "generate invoice from receipt"
error is returned:
null value in column "grosspricestd" violates not-null constraint
TagsNo tags attached.
Attached Filespng file icon Issue_32323.png [^] (95,138 bytes) 2016-02-24 10:27

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00323273.0PR16Q1 closedAtulOpenbravo "generate invoice from receipt" button is not working 
depends on backport 00323283.0PR15Q4.4 closedAtulOpenbravo "generate invoice from receipt" button is not working 
caused by defect 00305043.0PR15Q4 closedAtulOpenbravo "Gross List Price" information is not copied to invoice when using Generate Invoice from Receipt process 

-  Notes
(0084455)
psanjuan (manager)
2016-02-24 10:26

Issue verified. See image attached.
(0084460)
AtulOpenbravo (developer)
2016-02-24 13:54
edited on: 2016-02-25 09:15

Test Plan
- Create a new good receipt.
- Add new line, i.e. Product = Cerveza Ale 0.5L, Qty =1
- Complete the receipt.
- Click in "Generate Invoice From Receipt", choose "Tarifa Bebidas Alegres" price list version.
- Check that green message is shown saying that the purchase invoice has been created successfully. Take note of the Document Nº i.e. 100000870
- Go to Purchase Invoice window and check that the purchase invoice created is correct,that is:
Product = Cerveza Ale 0.5L
Qty = 1
Net Unit Price = 1.36
Total Net Amount = 1.36
Tax = Adquisiciones IVA 21%
Total Gross Amount = 1.65

(0084461)
AtulOpenbravo (developer)
2016-02-24 14:10
edited on: 2016-02-25 09:20

Test Plan
- Set "Price Includes Tax" = Yes for price list "Tarifa Bebidas Alegres".
- Create a new good receipt for Business Partner "Bebidas Alegres".
- Add new line, for Product = Cerveza Ale 0.5L, Qty = 1.
- Complete the receipt.
- Click in "Generate Invoice From Receipt".
- Check that a green successful message is shown. Take note of the Document Nº ie. 100000871.
- Go to Purchase Invoice window and check that the invoice is correct, as:
Product = Cerveza Ale 0.5L
Qty = 1
Net Unit price = 1.12 (1.36/1.21)
Tax rate (21%)
Total Net Amount = 1.12
Total Gross Amount = 1.36

(0084483)
psanjuan (manager)
2016-02-25 09:20
edited on: 2016-02-25 09:31

Test Plan above verified.

Issue can be reviewed and closed.

(0084506)
hgbot (developer)
2016-02-25 14:02

Repository: erp/devel/pi
Changeset: 85f5f008873a92e5740a131777103d332bb56a27
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Wed Feb 24 18:05:08 2016 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/85f5f008873a92e5740a131777103d332bb56a27 [^]

Fixes Issue 32323:"Generate invoice from receipt" button is not working

In case tax not included in price list, gross std price and list price
was set will null value which is not allowed by db table. now they are
initiated to value zero first.

---
M src-db/database/model/functions/M_INOUT_CREATEINVOICE.xml
---
(0084509)
vmromanos (developer)
2016-02-25 14:03

Code review + testing OK
(0084668)
aferraz (developer)
2016-03-02 18:20

Test case in TestLink: https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-10002 [^]
(0085169)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0085526)
hgbot (developer)
2016-04-08 11:00

Repository: tools/automation/int
Changeset: 1949469fab525e4859bbc15a9d8fb8cd39c9155e
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu Mar 03 13:40:40 2016 +0100
URL: http://code.openbravo.com/tools/automation/int/rev/1949469fab525e4859bbc15a9d8fb8cd39c9155e [^]

Related to issue 32323: Added an automated test

---
M src-test/com/openbravo/test/integration/erp/data/procurement/transactions/goodsreceipt/GoodsReceiptLinesData.java
M src-test/com/openbravo/test/integration/erp/data/procurement/transactions/purchaseinvoice/PurchaseInvoiceLinesData.java
M src-test/com/openbravo/test/integration/erp/gui/popups/RequestProcessPopUp.java
M src-test/com/openbravo/test/integration/erp/gui/procurement/transactions/goodsreceipt/GoodsReceiptHeaderTab.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/procurement/testsuites/PRO_Regressions/PRO_RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/procurement/testsuites/PRO_Regressions/build.xml
M src-test/com/openbravo/test/integration/erp/testscripts/procurement/transactions/GoodsReceipt.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/procurement/testsuites/PRO_Regressions/PRORegression32323.java
---

- Issue History
Date Modified Username Field Change
2016-02-23 18:58 malsasua New Issue
2016-02-23 18:58 malsasua Assigned To => Triage Finance
2016-02-23 18:58 malsasua Modules => Core
2016-02-23 18:58 malsasua Triggers an Emergency Pack => No
2016-02-23 19:01 malsasua Relationship added related to 0030504
2016-02-23 21:08 malsasua Regression level => Production - Confirmed Stable
2016-02-23 21:08 malsasua Regression introduced in release => 3.0PR15Q4
2016-02-24 10:02 AtulOpenbravo Assigned To Triage Finance => AtulOpenbravo
2016-02-24 10:26 psanjuan Note Added: 0084455
2016-02-24 10:27 psanjuan File Added: Issue_32323.png
2016-02-24 13:54 AtulOpenbravo Note Added: 0084460
2016-02-24 14:10 AtulOpenbravo Note Added: 0084461
2016-02-24 14:12 AtulOpenbravo Regression date => 2015-08-19
2016-02-24 14:12 AtulOpenbravo Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/d451a9fb55e553d4c6df0b6c3c57d02c90f52567 [^]
2016-02-24 14:23 AtulOpenbravo Status new => scheduled
2016-02-24 14:35 AtulOpenbravo Relationship replaced caused by 0030504
2016-02-24 15:03 psanjuan Note Edited: 0084460 View Revisions
2016-02-24 15:07 psanjuan Note Edited: 0084460 View Revisions
2016-02-25 08:59 psanjuan Note Edited: 0084460 View Revisions
2016-02-25 09:09 psanjuan Note Edited: 0084460 View Revisions
2016-02-25 09:15 psanjuan Note Edited: 0084460 View Revisions
2016-02-25 09:20 psanjuan Note Edited: 0084461 View Revisions
2016-02-25 09:20 psanjuan Note Added: 0084483
2016-02-25 09:22 psanjuan Relationship added related to 0032336
2016-02-25 09:22 psanjuan Note Edited: 0084483 View Revisions
2016-02-25 09:31 psanjuan Note Edited: 0084483 View Revisions
2016-02-25 09:31 psanjuan Relationship deleted related to 0032336
2016-02-25 11:26 vmromanos Regression level Production - Confirmed Stable => Production - QA Approved
2016-02-25 14:02 hgbot Checkin
2016-02-25 14:02 hgbot Note Added: 0084506
2016-02-25 14:02 hgbot Status scheduled => resolved
2016-02-25 14:02 hgbot Resolution open => fixed
2016-02-25 14:02 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/85f5f008873a92e5740a131777103d332bb56a27 [^]
2016-02-25 14:03 vmromanos Review Assigned To => vmromanos
2016-02-25 14:03 vmromanos Note Added: 0084509
2016-02-25 14:03 vmromanos Status resolved => closed
2016-03-02 18:20 aferraz Note Added: 0084668
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085169
2016-04-08 11:00 hgbot Checkin
2016-04-08 11:00 hgbot Note Added: 0085526


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker