Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032217
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Discounts and Promotionsmajoralways2016-02-12 12:132016-03-07 17:27
ReportermalsasuaView Statuspublic 
Assigned Tojorge-garcia 
PriorityhighResolutionfixedFixed in VersionRR16Q1
StatusclosedFix in branchFixed in SCM revisiondcf5fd700abc
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032217: [RR15Q4] [Multipricelist] discretionary discounts are removed when business partner is changed (with multiprice list)

Descriptionwith multiprice list activated, when the business partner is changed, the discretionary discounts are removed in ticket
Steps To Reproducein webpos: store MPL1
. business partner: Arturo Montoro
. add "adhesive body warmers"
. apply discretionary discount "disc 5%"
. change the business partner to Bryan Raymond
the discretionary discount has been removed
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0032115 closedjorge-garcia [Multipricelist] multiprice is not working when pricelist is not selected in the store 
depends on backport 0032225RR16Q1 closedguilleaer [RR15Q4] [Multipricelist] discretionary discounts are removed when business partner is changed (with multiprice list) 
depends on backport 0032226RR15Q4.5 closedjorge-garcia [RR15Q4] [Multipricelist] discretionary discounts are removed when business partner is changed (with multiprice list) 

-  Notes
(0084416)
hgbot (developer)
2016-02-23 10:33

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: dcf5fd700abc4b90c5601a0359e5e29d7a004eb4
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Fri Feb 19 14:43:08 2016 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/dcf5fd700abc4b90c5601a0359e5e29d7a004eb4 [^]

Fixed issue 32217: Discretionary discounts are removed when business partner
is changed with multiprice list

A calculateReceipt is made before the business partner changes, and the
discretionary discounts are removed from the products.

Now, the problem is fixed and the discretionary discounts are not deleted.

---
M web/org.openbravo.retail.posterminal/js/model/order.js
M web/org.openbravo.retail.posterminal/js/pointofsale/model/pointofsale-model.js
---
(0084417)
hgbot (developer)
2016-02-23 10:34

Repository: erp/pmods/org.openbravo.retail.sampledata
Changeset: 34bb80a4a4003b8ef193d239723a7ad8c137671c
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Fri Feb 19 09:07:01 2016 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.sampledata/rev/34bb80a4a4003b8ef193d239723a7ad8c137671c [^]

Related to issue 32217: Discretionary discounts are removed when business partner
is changed with multiprice list

Sampledata needs to be changed due to the new tests:
* New promotion created only for Stephane Cluster.
* Stephane Cluster has no taxes (tax excempt).

---
M referencedata/sampledata/The_White_Valley_Group/C_BPARTNER.xml
M referencedata/sampledata/The_White_Valley_Group/M_OFFER.xml
M referencedata/sampledata/The_White_Valley_Group/M_OFFER_PRODUCT.xml
A referencedata/sampledata/The_White_Valley_Group/M_OFFER_BPARTNER.xml
---
(0084418)
hgbot (developer)
2016-02-23 10:34

Repository: tools/automation/pi-mobile
Changeset: edbe4e37d7dfa610fb3bda5cd5a6181d1fe7aa68
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Tue Feb 23 10:31:10 2016 +0100
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/edbe4e37d7dfa610fb3bda5cd5a6181d1fe7aa68 [^]

Verifies issue 32217: Discretionary discounts are removed when business partner
is changed with multiprice list

Added test:
* I32217_MPLDiscountOnlyForOneCustomerAndDifferentTaxes
* I32217_MPLDiscretionaryPromotions

---
M src-test/org/openbravo/test/mobile/common/selenium/javascript/TestId.java
A src-test/org/openbravo/test/mobile/quarantine/pack/JGA/multipricelist/I32217_MPLDiscountOnlyForOneCustomerAndDifferentTaxes.java
A src-test/org/openbravo/test/mobile/quarantine/pack/JGA/multipricelist/I32217_MPLDiscretionaryPromotions.java
---
(0084527)
guilleaer (developer)
2016-02-25 19:47

Attributes of a backbone model should be accessed and set through get and set functions instead of assign it directly.

I.E.
me.attributes.lines.at(index).set('promotions', lines[index].attributes.promotions);

should be

me.get('lines').at(index).set('promotions', lines[index].get('promotions'));
(0084582)
marvintm (developer)
2016-02-29 09:32

The fix can be improved so that instead of executing calculateReceipt twice, it's done just once.
(0084705)
hgbot (developer)
2016-03-04 08:30

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 560b5385b3305f4057d96d47ae1d54564e41b8c8
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Thu Mar 03 15:47:03 2016 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/560b5385b3305f4057d96d47ae1d54564e41b8c8 [^]

Related to issue 32217: Discretionary discounts are removed when business
partner is changed (with multiprice list)

Some changes are necessary to improve performance.

---
M web/org.openbravo.retail.posterminal/js/model/discounts.js
M web/org.openbravo.retail.posterminal/js/model/order.js
---
(0084788)
hgbot (developer)
2016-03-07 17:27

Repository: retail/backports/3.0RR15Q4.5/org.openbravo.retail.posterminal
Changeset: fa14d19acc1ca15488172ba6851cf4b14b98bf9b
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Mon Mar 07 16:47:36 2016 +0100
URL: http://code.openbravo.com/retail/backports/3.0RR15Q4.5/org.openbravo.retail.posterminal/rev/fa14d19acc1ca15488172ba6851cf4b14b98bf9b [^]

Fixed issue 32226: discretionary discounts are removed when business partner
is changed with multiprice list

Backport of the issue 32217 for 3.0RR15Q4.5

---
M web/org.openbravo.retail.posterminal/js/model/discounts.js
M web/org.openbravo.retail.posterminal/js/model/order.js
M web/org.openbravo.retail.posterminal/js/pointofsale/model/pointofsale-model.js
---

- Issue History
Date Modified Username Field Change
2016-02-12 12:13 malsasua New Issue
2016-02-12 12:13 malsasua Assigned To => Retail
2016-02-12 12:13 malsasua Triggers an Emergency Pack => No
2016-02-12 12:55 Orekaria Summary discretionary discounts are removed when business partner is changed (with multiprice list) => [RR15Q4] [Multipricelist] discretionary discounts are removed when business partner is changed (with multiprice list)
2016-02-12 12:56 Orekaria Status new => acknowledged
2016-02-12 13:32 Orekaria Status acknowledged => scheduled
2016-02-12 18:03 Orekaria Relationship added related to 0032115
2016-02-15 17:24 jorge-garcia Assigned To Retail => jorge-garcia
2016-02-23 10:33 hgbot Checkin
2016-02-23 10:33 hgbot Note Added: 0084416
2016-02-23 10:33 hgbot Status scheduled => resolved
2016-02-23 10:33 hgbot Resolution open => fixed
2016-02-23 10:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/dcf5fd700abc4b90c5601a0359e5e29d7a004eb4 [^]
2016-02-23 10:34 hgbot Checkin
2016-02-23 10:34 hgbot Note Added: 0084417
2016-02-23 10:34 hgbot Checkin
2016-02-23 10:34 hgbot Note Added: 0084418
2016-02-25 19:47 guilleaer Note Added: 0084527
2016-02-29 09:32 marvintm Note Added: 0084582
2016-02-29 09:32 marvintm Status resolved => new
2016-02-29 09:32 marvintm Resolution fixed => open
2016-02-29 13:05 marvintm Status new => scheduled
2016-03-04 08:30 hgbot Checkin
2016-03-04 08:30 hgbot Note Added: 0084705
2016-03-04 12:24 marvintm Status scheduled => resolved
2016-03-04 12:24 marvintm Resolution open => fixed
2016-03-07 11:33 marvintm Review Assigned To => marvintm
2016-03-07 11:33 marvintm Status resolved => closed
2016-03-07 11:33 marvintm Fixed in Version => RR16Q1
2016-03-07 17:27 hgbot Checkin
2016-03-07 17:27 hgbot Note Added: 0084788


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker