Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032206
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2016-02-11 13:312016-03-17 10:56
ReportervmromanosView Statuspublic 
Assigned Tovmromanos 
PrioritynormalResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revision5543dcdb0d5f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032206: System should avoid to reactivate an invoice linked to a Manual Cash VAT Settlement

DescriptionWhen an invoice has any payment associated, the system avoids to reactivate the invoice. Thus we can control the cash vat information for the invoice.

The same logic should be applied when the invoice is linked to a manual cash vat settlement
Steps To ReproduceInstall and configure Cash VAT module. Apply its dataset to * org
Create a cash vat tax rate
Create a purchase invoice with the previous cash vat tax rate. Complete and post it.
Go to Manual Cash VAT Settlement window, create a new record for this year and include the previously created invoice. Complete it.
Go to the invoice and try to reactivate it. The system allows to do it, but it shouldn't
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00321003.0PR16Q2 closedvmromanos Error when processing CashVAT invoice that has been previously reactivated 

-  Notes
(0084113)
vmromanos (developer)
2016-02-11 16:12
edited on: 2016-02-12 13:20

Test plan:
Install and configure Cash VAT module. Apply its dataset to * org
Create a cash vat tax rate
Create a purchase invoice with the previous cash vat tax rate. Complete and post it.
Go to Manual Cash VAT Settlement window, create a new record for this year and include the previously created invoice. Complete it.
Go to the invoice and try to reactivate it. Verify an error message is shown, saying: "The invoice is already included into a Manual Cash VAT Settlement".

Go to Manual Cash VAT Settlement and reactivate it by choosing the option "Reactivate" therefore lines tab is not empty.

Go to the invoice and try to reactivate it.
The system allows you to reactivate the invoice.

Add a new line to the invoice for another product with the same cash vat tax rate. Complete the invoice.

Go to Manual Cash VAT Settlement window and check that regardless there is a line pointing to the invoice, you need to one more press Pick Lines & Complete.

Once in the Pick Lines & Complete window, check that the invoice reflects the proper Grand Total Amount (by taking into account the change done in the invoice).

Repeat same flow for sales invoice.

(0084141)
psanjuan (manager)
2016-02-12 09:19
edited on: 2016-02-12 09:24

Issue verified. Issue can be reproduced, it is possible to reactivate the invoice regardless there is a manual VAT settlement assigned to it.
an error will be shown whenever you try now to change the invoice quantity or the net unit price, or the tax rate, of any data of the purchase invoice line.

Only action allowed is to add a new line and then complete. Invoice Posting is not correct because all VAT is considered Temporary VAT while there is already a Cash VAT amount settle as "final" VAT.

That invoice can not be included in a Manual Cash VAT Settle anymore.

If a payment of the invoice is created, no new record in the Cash VAT tab would be created, which is not correct.

Due to all this inconsistency data that can be created, the fix to this issue will be not to allow reactivating an invoice which do have related a manual cash vat unless manual cash vat is unpost and reactivated.

(0084153)
psanjuan (manager)
2016-02-12 13:21

Test Plan above verified.

Issue can be code reviewed and closed.
(0084174)
hgbot (developer)
2016-02-15 11:14

Repository: erp/devel/pi
Changeset: 5543dcdb0d5fb093f5df6ea63b4114a4ab113167
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Thu Feb 11 15:59:45 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/5543dcdb0d5fb093f5df6ea63b4114a4ab113167 [^]

Fixed bug 32206: Invoice reactivation with Manual Cash VAT Settlement

Avoid to reactivate an invoice linked to a Manual Cash VAT Settlement

---
M modules/org.openbravo.advpaymentmngt/src-db/database/model/functions/APRM_GEN_PAYMENTSCHEDULE_INV.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_MESSAGE.xml
---
(0084176)
aferraz (developer)
2016-02-15 11:14

Code review OK
(0085137)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-02-11 13:31 vmromanos New Issue
2016-02-11 13:31 vmromanos Assigned To => vmromanos
2016-02-11 13:31 vmromanos Modules => Core
2016-02-11 13:31 vmromanos Triggers an Emergency Pack => No
2016-02-11 13:31 vmromanos Relationship added blocks 0032100
2016-02-11 13:31 vmromanos Status new => scheduled
2016-02-11 16:12 vmromanos Note Added: 0084113
2016-02-12 09:19 psanjuan Note Added: 0084141
2016-02-12 09:20 psanjuan Note Edited: 0084141 View Revisions
2016-02-12 09:22 psanjuan Note Edited: 0084141 View Revisions
2016-02-12 09:24 psanjuan Note Edited: 0084141 View Revisions
2016-02-12 09:24 psanjuan Note Edited: 0084141 View Revisions
2016-02-12 13:12 psanjuan Note Edited: 0084113 View Revisions
2016-02-12 13:13 psanjuan Note Edited: 0084113 View Revisions
2016-02-12 13:15 psanjuan Note Edited: 0084113 View Revisions
2016-02-12 13:18 psanjuan Note Edited: 0084113 View Revisions
2016-02-12 13:20 psanjuan Note Edited: 0084113 View Revisions
2016-02-12 13:21 psanjuan Note Added: 0084153
2016-02-15 11:14 hgbot Checkin
2016-02-15 11:14 hgbot Note Added: 0084174
2016-02-15 11:14 hgbot Status scheduled => resolved
2016-02-15 11:14 hgbot Resolution open => fixed
2016-02-15 11:14 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5543dcdb0d5fb093f5df6ea63b4114a4ab113167 [^]
2016-02-15 11:14 aferraz Review Assigned To => aferraz
2016-02-15 11:14 aferraz Note Added: 0084176
2016-02-15 11:14 aferraz Status resolved => closed
2016-02-15 11:14 aferraz Fixed in Version => 3.0PR16Q2
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085137


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker