Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032089
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2016-02-02 13:272016-03-17 10:56
ReporterngarciaView Statuspublic 
Assigned Toaferraz 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision9780a5222687
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032089: Product with stock in second UOM is automatically reserved but it is not possible to reserve it manually

DescriptionProduct with stock in second UOM is automatically reserved but it is not possible to reserve it manually
Steps To ReproduceAs system admin role:
   Set as displayed the 'Order UOM' and 'Order Quantity' fields of the Sales Order and Goods Receipt windows
   Set as Active the 'Product - UOM' and 'Unit Of Measure - Conversion' tabs
As group admin role:
   Enable the Stock Reservation preference
   Create a new product and add a sales price to it
   Add a Unit Of Measure to it in the UOM tab
   Define a conversion between that UOM and the Unit of the Product tab
   Create a goods receipt, add the already created product in the line and set the Order UOM and Order Quantity fields. Storage bin Rn-0-0-0
   Complete it
   Create another goods receipt, add the already created product in the line and set the Order UOM and Order Quantity fields. Make sure the storage bin selected is a different one. RN-1-0-0.
   Create a Sales Order, add the already created product in the line and set the Order UOM and Order Quantity fields
   Complete it
   Click on the Manage Reservation button and check that only one line is shown in there, regardless there is available stock in two different storage bins.
   Create a similar Sales Order but set the Stock Reservation = Automatic in the line
   Complete it and check the stock has been reserved, 10 units from RN-0-0-0 and 10 units from Rn-1-0-0
Proposed SolutionReservations feature current design is not supposed to support reservations for item having a second UOM, therefore no reservation should be created.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0032090 newTriage Finance Stock Reservations feature should support second UOM 
related to design defect 00280513.0PR15Q2 closedumartirena Reserved quantity is not correct under certain circumstancies 
depends on defect 00320783.0PR16Q2 closedaferraz Reserved quantity is not correct under certain circumstances 

-  Notes
(0083960)
aferraz (developer)
2016-02-05 11:40
edited on: 2018-07-19 11:55

Test plan I:

As system admin role:
   Set as displayed the 'Order UOM' and 'Order Quantity' fields of the Sales Order and Goods Receipt windows
   Set as Active the 'Product - UOM' and 'Unit Of Measure - Conversion' tabs
As group admin role:
   Enable the Stock Reservation preference
   Create a new product and add a sales price to it
   Add a Unit Of Measure to it in the UOM tab
   Define a conversion between that UOM and the Unit of the Product tab
   Create a goods receipt, add the already created product in the line and set the Order UOM and Order Quantity fields
   Complete it
   Create a Sales Order, add the already created product in the line and set the Order UOM and Order Quantity fields
   Complete it
   Check that Reservation Status column shows "Not Reserved".
   Click on the Manage Reservation button and check no lines are shown.
   Click Done.
   Check in Stock Reservation, no record is created for Sales Order created above.
   Create a similar Sales Order but set the Stock Reservation = Automatic in the line.
   Click on the Manage Reservation button and check no lines are shown.
   Click Done.
   Complete it and check that a Stock Reservation has been created, with sales order line quantity, reserved qty = 0 in draft status. Once more this stock reservation has no lines.

(0083961)
aferraz (developer)
2016-02-05 11:44
edited on: 2018-07-19 11:56

Test plan II:

As group admin role:
   Enable the Stock Reservation preference
   Create a new product and add a sales price to it
   Create a Sales Order, add the already created product in the line and set any quantity.
   Complete it
   Click on the Manage Reservation button and check no lines are shown.
   Click Done.
   Check Stock Reservation and realize that no record is created for previous processed order.
   Create a similar Sales Order but set the Stock Reservation = Automatic in the line
   Complete it and realize a Stock Reservation has been created with sales order line quantity and draft status but with no lines, because there is no stock.

(0083987)
psanjuan (manager)
2016-02-05 15:11
edited on: 2016-02-08 13:04

Issue verified.

(0084001)
psanjuan (manager)
2016-02-08 13:08

Test plan above verified.

Issue can be code reviewed and close.
(0084089)
hgbot (developer)
2016-02-10 17:25

Repository: erp/devel/pi
Changeset: 9780a522268784f86d28accf478a6774dad6af3a
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Fri Feb 05 12:02:24 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/9780a522268784f86d28accf478a6774dad6af3a [^]

Fixes issue 32089: Reservations with stock in second UOM will not be created

M_RESERVE_STOCK_AUTO will exclude lines from m_storage_detail with second uom to avoid create stock reservation lines for products with stock in second UOM, as it is done in M_CREATE_RESERVE_FROM_SOL.

---
M src-db/database/model/functions/M_RESERVE_STOCK_AUTO.xml
---
(0084090)
vmromanos (developer)
2016-02-10 17:25

Code review OK
(0085127)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-02-02 13:27 ngarcia New Issue
2016-02-02 13:27 ngarcia Assigned To => Triage Finance
2016-02-02 13:27 ngarcia Modules => Core
2016-02-02 13:27 ngarcia Triggers an Emergency Pack => No
2016-02-02 13:27 ngarcia Issue Monitored: networkb
2016-02-02 13:31 ngarcia Relationship added related to 0032090
2016-02-04 14:15 aferraz Status new => scheduled
2016-02-04 14:15 aferraz Assigned To Triage Finance => aferraz
2016-02-05 11:40 aferraz Note Added: 0083960
2016-02-05 11:40 aferraz Relationship added related to 0032078
2016-02-05 11:41 aferraz Relationship added related to 0028051
2016-02-05 11:43 aferraz Note Edited: 0083960 View Revisions
2016-02-05 11:44 aferraz Note Added: 0083961
2016-02-05 13:20 aferraz Relationship deleted related to 0032078
2016-02-05 13:20 aferraz Relationship added depends on 0032078
2016-02-05 15:03 psanjuan Steps to Reproduce Updated View Revisions
2016-02-05 15:05 psanjuan Steps to Reproduce Updated View Revisions
2016-02-05 15:09 psanjuan Steps to Reproduce Updated View Revisions
2016-02-05 15:09 psanjuan Proposed Solution updated
2016-02-05 15:11 psanjuan Note Added: 0083987
2016-02-08 12:53 psanjuan Note Edited: 0083960 View Revisions
2016-02-08 13:01 psanjuan Note Edited: 0083960 View Revisions
2016-02-08 13:04 psanjuan Note Edited: 0083987 View Revisions
2016-02-08 13:07 psanjuan Note Edited: 0083961 View Revisions
2016-02-08 13:08 psanjuan Note Added: 0084001
2016-02-10 17:25 hgbot Checkin
2016-02-10 17:25 hgbot Note Added: 0084089
2016-02-10 17:25 hgbot Status scheduled => resolved
2016-02-10 17:25 hgbot Resolution open => fixed
2016-02-10 17:25 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9780a522268784f86d28accf478a6774dad6af3a [^]
2016-02-10 17:25 vmromanos Review Assigned To => vmromanos
2016-02-10 17:25 vmromanos Note Added: 0084090
2016-02-10 17:25 vmromanos Status resolved => closed
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085127
2018-07-19 11:55 AtulOpenbravo Note Edited: 0083960 View Revisions
2018-07-19 11:56 AtulOpenbravo Note Edited: 0083961 View Revisions


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker