Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032007
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorsometimes2016-01-26 09:372016-03-17 10:55
ReportermalsasuaView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revisionbaf72de5b678
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032007: Double request to FIC in CHANGE mode when the form is redrawn by overflow under some circumstances

DescriptionDouble request to FIC in CHANGE mode when the form is redrawn by overflow after changing a combo/selector value which has a callout. In some cases, this can cause that the callouts are not working properly.
Steps To ReproduceConfiguration Steps (System Admin Role)
- Go to [Windows, Tabs and Fields]. Look for the [Sales Order] window
- Navigate to the [Lines] tab and select the Project field.
- Set the following display logic for the Project field: @M_Product_ID@='BDE2F1CF46B54EF58D33E20A230DA8D2' (This field is displaying when the selected product is 'Agua sin Gas 1L')

Steps To Reproduce (Group Admin Role)
- Navigate to the [Sales Order] window.
- Create a new record in the header.
- Create a new record in the [Lines] tab, using form view. Notice that the tab content is shown without scrolling. (See attached image, img1.png)
- Select the product 'Bebida Energética': one request is done to the FIC in CHANGE mode. This is correct.
- Select the product 'Agua Sin Gas 1L': the project field is displayed causing the appearance of the scrolling (See attached image, img2.png). Notice that in this case, two requests are done to the FIC in CHANGE mode.
TagsPerformance
Attached Filespng file icon img1.png [^] (59,021 bytes) 2016-01-27 10:12


png file icon img2.png [^] (63,813 bytes) 2016-01-27 10:13

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0032030 acknowledgedplatform Double FIC request after selecting the empty value on a combo with a callout 
causes defect 0037842 closedplatform Callout not triggered when clearing a selector 

-  Notes
(0083605)
malsasua (developer)
2016-01-26 09:49

It is reproducible using the next chrome extension to 1600x900:

http://wiki.openbravo.com/wiki/Retail:Developers_Guide/How-to/How_to_test_screen_resolutions [^]
(0083646)
caristu (developer)
2016-01-27 19:10

Fix pushed to try
(0083689)
hgbot (developer)
2016-01-28 17:23

Repository: erp/devel/pi
Changeset: baf72de5b678a308c36d5946af3e143d08625eca
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Jan 28 17:22:21 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/baf72de5b678a308c36d5946af3e143d08625eca [^]

fixes issue 32007: combo/selector with a callout can cause a double FIC request

If a form redrawal was fired after selecting a value of a combo/selector with a callout, a double request to the datasource was being performed due to asynchrony problems. An example of this scenario is when after selecting a value of a combo/selector with a callout, the form needs to be scrolled (overflow) because new fields are displayed in the form (for example because this fields have a display logic).

This kind of scenarios are now detected in the change event of the OBSelectorItem class, when the value to be updated is null but at the same time the pick list already contains a selected value.

---
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-selector-item.js
---
(0083711)
hgbot (developer)
2016-01-29 09:17

Repository: erp/devel/pi
Changeset: 759c92f6e8a28c69180c938f4ea621286b765b16
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Jan 29 09:17:02 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/759c92f6e8a28c69180c938f4ea621286b765b16 [^]

related to bug 32007: use single qoutes to enclose js strings

---
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-selector-item.js
---
(0083712)
alostale (developer)
2016-01-29 09:18

code reviewed + tested
(0085084)
hudsonbot (developer)
2016-03-17 10:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0085086)
hudsonbot (developer)
2016-03-17 10:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-01-26 09:37 malsasua New Issue
2016-01-26 09:37 malsasua Assigned To => platform
2016-01-26 09:37 malsasua Modules => Core
2016-01-26 09:37 malsasua Triggers an Emergency Pack => No
2016-01-26 09:49 malsasua Note Added: 0083605
2016-01-26 19:39 caristu Status new => scheduled
2016-01-26 19:39 caristu Assigned To platform => caristu
2016-01-27 10:08 caristu Summary callouts are not working with screen resolution 1600x900 => Double request to FIC in CHANGE mode when the form is redrawn by overflow
2016-01-27 10:08 caristu Description Updated View Revisions
2016-01-27 10:08 caristu Steps to Reproduce Updated View Revisions
2016-01-27 10:11 caristu Steps to Reproduce Updated View Revisions
2016-01-27 10:12 caristu File Added: img1.png
2016-01-27 10:12 caristu File Added: img2.png
2016-01-27 10:13 caristu File Deleted: img2.png
2016-01-27 10:13 caristu File Added: img2.png
2016-01-27 19:08 caristu Relationship added related to 0032030
2016-01-27 19:10 caristu Note Added: 0083646
2016-01-28 17:09 caristu Summary Double request to FIC in CHANGE mode when the form is redrawn by overflow => Double request to FIC in CHANGE mode when the form is redrawn by overflow under some cirmcustances
2016-01-28 17:09 caristu Description Updated View Revisions
2016-01-28 17:09 caristu Summary Double request to FIC in CHANGE mode when the form is redrawn by overflow under some cirmcustances => Double request to FIC in CHANGE mode when the form is redrawn by overflow under some circumstances
2016-01-28 17:23 hgbot Checkin
2016-01-28 17:23 hgbot Note Added: 0083689
2016-01-28 17:23 hgbot Status scheduled => resolved
2016-01-28 17:23 hgbot Resolution open => fixed
2016-01-28 17:23 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/baf72de5b678a308c36d5946af3e143d08625eca [^]
2016-01-28 17:24 caristu Review Assigned To => alostale
2016-01-28 17:24 caristu Issue Monitored: alostale
2016-01-29 09:17 hgbot Checkin
2016-01-29 09:17 hgbot Note Added: 0083711
2016-01-29 09:18 alostale Note Added: 0083712
2016-01-29 09:18 alostale Status resolved => closed
2016-01-29 09:18 alostale Fixed in Version => 3.0PR16Q2
2016-01-29 10:04 alostale Tag Attached: Performance
2016-03-17 10:55 hudsonbot Checkin
2016-03-17 10:55 hudsonbot Note Added: 0085084
2016-03-17 10:55 hudsonbot Checkin
2016-03-17 10:55 hudsonbot Note Added: 0085086
2018-02-07 13:07 alostale Relationship added causes 0037842


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker