Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031888
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2016-01-14 11:002016-03-17 10:54
ReporterngarciaView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisiond4762042e1ad
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031888: Create Order from Sales Quotation is not truncating date fields, thus, payment against invoice is being considered a prepayment

DescriptionCreate Order from Sales Quotation is not truncating date fields, thus, payment against invoice is being considered a prepayment

C_ORDER: dateordered, dateacct
M_INOUT: dateordered, movementdate
C_INVOICE: dateinvoiced, dateacct, dateordered, taxdate...
Steps To ReproduceTwo ways of reproduce it:
1. Create a Sales Quotation, add a line to it and book it
   Launch the Create Order process
   Go to Sales Order screen and set its Invoice Terms as Immediate
   Launch the Create Invoices from Orders process and do not assign an invoice date (the order date will be taken as invoice date, C_INVOICE_CREATE)
   Add a Payment In to that invoice with the same date
   Post it and check a prepayment entry is made

2. Go to Quotation document type and configure POS Order as Document Type for Order
   Create a Sales Quotation, add a line to it and book it
   Launch the Create Order process
   Navigate to the Sales Invoice created.
   Add a Payment In to that invoice with the same date
   Post it and check a prepayment entry is made
TagsNo tags attached.
Attached Filesdiff file icon 31888_ms.diff [^] (7,461 bytes) 2016-01-19 16:03 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00270893.0PR15Q1 closedfsoto82 Invoice Date and Accounting Date should be truncated when invoice is created using "Generate Invoice from Receipt" process 

-  Notes
(0083368)
AtulOpenbravo (developer)
2016-01-18 12:28
edited on: 2016-01-19 14:26

Test Plan A
- Create a Sales Quotation, add a line to it and book it
- Launch the Create Order process
- Go to Sales Order screen and set it
s Invoice Terms as Immediate
- Launch the Create Invoices from Orders process and do not assign an invoice
  date (the order date will be taken as invoice date, C_INVOICE_CREATE).
- Add a Payment In to that invoice with the same date and choose option
  "Process Payment Received and Deposit".
- Post it and check that no prepayment entry is made. If Posting is disabled in Payment In, it could be done in Financial Account Transaction Tab.

Test Plan B
- Go to Quotation document type and configure POS Order as Document Type for
  Order.
- Create a Sales Quotation, add a line to it and book it.
- Launch the Create Order process.
- Navigate to the Sales Invoice created.
- Add a Payment In to that invoice with the same date and choose option
  "Process Payment Received and Deposit".
- Post it and check that no prepayment entry is made. If Posting is disabled in Payment In, it could be done in Financial Account Transaction Tab.

Test Plan C
Repeat Test Plan A above by entering below dates:
Quotation = 19-01-2016
Sales Order = 19-01-2016 (by using Create Order process from the Quotation)
Sales Invoice = 18-01-2016 (by entering an invoice date = 18-01-2016 in "Create Invoices from Orders window).
Payment In date = 18-01-2016

check that no customer prepayment is used either while posting the payment or the invoice.

Test Plan D

Repeat Test Plan A above by entering below dates:
Quotation = 19-01-2016
Sales Order = 19-01-2016 (by using Create Order process from the Quotation)
Sales Invoice = 18-01-2016 (by entering an invoice date = 18-01-2016 in "Create Invoices from Orders window).
Payment In date = 15-01-2016

check that a customer prepayment is used while posting the payment while no customer prepayment is used while posting the invoice, which is correct.

Invoice Posting looks like (18-01-2015)
55.54 (43000) Account Receivables DEBIT
5.10 (70000) Product Revenue (discount) DEBIT
51.00 (70000) Product Revenue CREDIT
9.64 (47700) Sales Tax CREDIT

Payment Posting looks like:
15-01-2015
55.54 (57200) Bank DEBIT
55.54 (43800) Customer Prepayments CREDIT

18-01-2015
55.54 (43800) Customer Prepayments DEBIT
55.54 (43000) Account Receivables CREDIT

(0083385)
psanjuan (manager)
2016-01-18 18:13

Issue verified.
(0083406)
hgbot (developer)
2016-01-19 16:05

Repository: erp/devel/pi
Changeset: d4762042e1ad755083f8a3f2c3d2f880cde6ac85
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Mon Jan 18 16:22:34 2016 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/d4762042e1ad755083f8a3f2c3d2f880cde6ac85 [^]

Fixes Issue 31888: Create Order from Sales Quotation is not truncating date
fields, thus, payment against invoice is being considered a prepayment

While creating sales order header, order date is truncated and set.

---
M src/org/openbravo/erpCommon/ad_process/ConvertQuotationIntoOrder.java
---
(0083407)
vmromanos (developer)
2016-01-19 16:24

Code review + testing OK

Attached 31888_ms.diff which is the module script modification to fix wrong data.
We don't include it in core as it might impact the time for the update database process in high volume instances.
(0085054)
hudsonbot (developer)
2016-03-17 10:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-01-14 11:00 ngarcia New Issue
2016-01-14 11:00 ngarcia Assigned To => Triage Finance
2016-01-14 11:00 ngarcia Modules => Core
2016-01-14 11:00 ngarcia Triggers an Emergency Pack => No
2016-01-14 11:01 ngarcia Issue Monitored: networkb
2016-01-14 11:02 ngarcia Relationship added related to 0027089
2016-01-18 11:22 AtulOpenbravo Assigned To Triage Finance => AtulOpenbravo
2016-01-18 11:22 AtulOpenbravo Status new => scheduled
2016-01-18 12:28 AtulOpenbravo Note Added: 0083368
2016-01-18 18:13 psanjuan Note Added: 0083385
2016-01-19 14:01 psanjuan Note Edited: 0083368 View Revisions
2016-01-19 14:08 psanjuan Steps to Reproduce Updated View Revisions
2016-01-19 14:09 psanjuan Note Edited: 0083368 View Revisions
2016-01-19 14:10 psanjuan Note Edited: 0083368 View Revisions
2016-01-19 14:16 psanjuan Note Edited: 0083368 View Revisions
2016-01-19 14:26 psanjuan Note Edited: 0083368 View Revisions
2016-01-19 16:03 vmromanos File Added: 31888_ms.diff
2016-01-19 16:05 hgbot Checkin
2016-01-19 16:05 hgbot Note Added: 0083406
2016-01-19 16:05 hgbot Status scheduled => resolved
2016-01-19 16:05 hgbot Resolution open => fixed
2016-01-19 16:05 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d4762042e1ad755083f8a3f2c3d2f880cde6ac85 [^]
2016-01-19 16:24 vmromanos Review Assigned To => vmromanos
2016-01-19 16:24 vmromanos Note Added: 0083407
2016-01-19 16:24 vmromanos Status resolved => closed
2016-03-17 10:54 hudsonbot Checkin
2016-03-17 10:54 hudsonbot Note Added: 0085054


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker