Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031860
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2016-01-11 14:142016-03-17 10:54
ReporterngarciaView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionc2ba9553dc85
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2015-03-23
Regression introduced in release3.0PR15Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/908de92996757265cce434502b36adf8860d6450 [^]
Triggers an Emergency PackNo
Summary

0031860: Cannot save a G/L Journal header with the date of the adjustment period if both periods are opened

DescriptionCannot save a G/L Journal header with the date of the adjustment period if both periods are opened
Steps To ReproduceAs group admin role:
   Create a new year in the Fiscal Calendar window
   Create periods and select the option to create the adjustment period
   Open all periods
   Go to G/L Journal window and create a record with the date of the adjustment period (31/12)
   Create a Header with the same date. Check you cannot save the record neither if you select the common period nor the adjustment period. The following error message is shown:
      Saving failed. No valid period for this accounting date.
   
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00318963.0PR16Q1 closedAtulOpenbravo Cannot save a G/L Journal header with the date of the adjustment period if both periods are opened 
depends on backport 00318973.0PR15Q4.2 closedAtulOpenbravo Cannot save a G/L Journal header with the date of the adjustment period if both periods are opened 
depends on backport 00318983.0PR15Q3.5 closedAtulOpenbravo Cannot save a G/L Journal header with the date of the adjustment period if both periods are opened 
caused by defect 00289523.0PR15Q3 closedfsoto82 Period Not Updated in G/L Journal if the Accounting Date belongs to a closed period. It is not possible to unpost it 

-  Notes
(0083275)
AtulOpenbravo (developer)
2016-01-14 04:26
edited on: 2016-01-14 04:31

Test Plan
- Login as Group admin role:
- Create a new year in the Fiscal Calendar window
- Create periods and select the option to create the adjustment period
- Open all periods.
- Go to G/L Journal window and create a record with the date of the adjustment period (31/12)
- Create a Header with the same date. Check you can save the record.

Test Plan for 28952 is also tested.

(0083318)
hgbot (developer)
2016-01-14 18:06

Repository: erp/devel/pi
Changeset: c2ba9553dc85c07b2461e34c9a5b4d81c70a43d2
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Wed Jan 13 21:13:18 2016 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/c2ba9553dc85c07b2461e34c9a5b4d81c70a43d2 [^]

Fixes Issue 31860:Cannot save a G/L Journal header with the date of the
adjustment period if both periods are opened

c_chk_open_period returns value more than 1 in case standard period and
adjustment period is open in which the date of GL journal is included.
<> 1 check is failed in this case so check is changed to < 1 to show
error message in case period id not available

---
M src-db/database/model/triggers/GL_JOURNAL_CHK_RESTRICT_TRG.xml
---
(0083319)
dmiguelez (developer)
2016-01-14 18:06

Code Review + Testing Ok
(0085047)
hudsonbot (developer)
2016-03-17 10:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-01-11 14:14 ngarcia New Issue
2016-01-11 14:14 ngarcia Assigned To => Triage Finance
2016-01-11 14:14 ngarcia Modules => Core
2016-01-11 14:14 ngarcia Triggers an Emergency Pack => No
2016-01-11 14:15 ngarcia Relationship added caused by 0028952
2016-01-11 14:17 ngarcia Issue Monitored: networkb
2016-01-13 07:37 AtulOpenbravo Assigned To Triage Finance => AtulOpenbravo
2016-01-13 07:38 AtulOpenbravo Status new => scheduled
2016-01-14 04:26 AtulOpenbravo Note Added: 0083275
2016-01-14 04:31 AtulOpenbravo Note Edited: 0083275 View Revisions
2016-01-14 17:09 dmiguelez Regression level => Production - Confirmed Stable
2016-01-14 17:09 dmiguelez Regression date => 2015-03-23
2016-01-14 17:09 dmiguelez Regression introduced in release => 3.0PR15Q3.3
2016-01-14 17:09 dmiguelez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/908de92996757265cce434502b36adf8860d6450 [^]
2016-01-14 17:09 dmiguelez Regression introduced in release 3.0PR15Q3.3 => 3.0PR15Q3
2016-01-14 17:17 dmiguelez Status scheduled => feedback
2016-01-14 17:17 dmiguelez Status feedback => new
2016-01-14 17:53 dmiguelez Status new => scheduled
2016-01-14 18:06 hgbot Checkin
2016-01-14 18:06 hgbot Note Added: 0083318
2016-01-14 18:06 hgbot Status scheduled => resolved
2016-01-14 18:06 hgbot Resolution open => fixed
2016-01-14 18:06 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c2ba9553dc85c07b2461e34c9a5b4d81c70a43d2 [^]
2016-01-14 18:06 dmiguelez Review Assigned To => dmiguelez
2016-01-14 18:06 dmiguelez Note Added: 0083319
2016-01-14 18:06 dmiguelez Status resolved => closed
2016-03-17 10:54 hudsonbot Checkin
2016-03-17 10:54 hudsonbot Note Added: 0085047


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker