Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031676
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2015-12-09 17:262015-12-15 23:49
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q1
StatusclosedFix in branchFixed in SCM revision7c6686c84928
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2015-04-13
Regression introduced in release3.0PR15Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/ac68a43ce6569746a77f67d78906d7addbac841b [^]
Triggers an Emergency PackNo
Summary

0031676: Some values are not shown in XLS format after Jasper Library Upgrade using Microsoft Office 2007

DescriptionSome values are not shown in XLS format after Jasper Library Upgrade using Microsoft Office 2007
Steps To Reproduce1. Run any manual report in XLS format
2. Open xls file with Microsoft Excel 2007and realize that Credit and Debit values are not shown
Proposed SolutionThe cell auto detect feature of Jasper is generating the format of the column as "Personalize", this causes the values not be shown.

Without using this feature all the values are exported as strings.

Notice that this is problem not happening with LibreOffice.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0031648 closedTriage Finance Review the export of the reports to Excel using Microsoft Office 2007 
depends on backport 00316833.0PR15Q4.1 closedcaristu Some values are not shown in XLS format after Jasper Library Upgrade using Microsoft Office 2007 
depends on backport 00316843.0PR15Q3.5 closedcaristu Some values are not shown in XLS format after Jasper Library Upgrade using Microsoft Office 2007 
caused by feature request 0029566 closedcaristu Upgrade Jasper Libraries 
related to defect 0031710 closedcollazoandy4 Review XLS reports to apply cell type when required 
related to feature request 0033743 newplatform Numeric Values in Reports are Text, not numeric in Excel 

-  Notes
(0082728)
hgbot (developer)
2015-12-14 16:28

Repository: erp/devel/pi
Changeset: 7c6686c849289aee3d72d86dc1f9ab5397c6adcb
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Dec 14 16:26:16 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/7c6686c849289aee3d72d86dc1f9ab5397c6adcb [^]

fixes issue 31676: Some values are not shown in XLS format using MS Office

The detect cell type feature was not working properly for BigInteger values in Office after the Jasper Library Upgrade. A personalized format was applied causing the data not be shown when opening the report.

To solve this problem the detect cell type feature has been disabled. This way, by default, all the values in the XLS will be exported as strings.

This default configuration can be overriden at report level. As an example, the General Ledger Report and Trial Balance report have been updated properly. With this configuration, those reports are now using number formatting for the cells showing the BigDecimal values.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/report/ReportingUtils.java
M src/org/openbravo/erpCommon/ad_reports/ReportGeneralLedgerExcel.jrxml
M src/org/openbravo/erpCommon/ad_reports/ReportTrialBalanceExcel.jrxml
---
(0082729)
caristu (developer)
2015-12-14 16:32
edited on: 2015-12-15 08:43

Now the detect cell type feature is disabled by default. The XLS report content is exported as string now.

This configuration can be overridden at report level, adding the following content into the .jrxml template:

1) Add the "net.sf.jasperreports.export.xls.detect.cell.type" property with true as its value.
2) Add a pattern for the text field. For example, the patternExpression tag can be used to define the numeric mask.

As an example the General Ledger Report and the Trial Balance has been updated properly. We are using the numeric format output defined for reports in the Format.xml file. This way this reports can apply that format automatically.

(0082747)
alostale (developer)
2015-12-15 09:19

code reviewed

Tested:
-General Ledger and Trial Balance reports are correctly exported, numeric values are seen as numbers in spreadsheet (both libreoffice and office)
-Reports can be exported to PDF
-Other reports (ie. Purchase Order Report) are correctly exported to XLS but their numeric columns are seen as string (both libreoffice and office)
(0082752)
caristu (developer)
2015-12-15 09:53

Wiki page updated: http://wiki.openbravo.com/wiki/How_to_create_a_Report#Configuring_Cell_Type_in_XLS_Reports [^]
(0082791)
hudsonbot (developer)
2015-12-15 23:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ecd185534f50 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-12-09 17:26 caristu New Issue
2015-12-09 17:26 caristu Assigned To => caristu
2015-12-09 17:26 caristu Modules => Core
2015-12-09 17:26 caristu Regression level => Production - Confirmed Stable
2015-12-09 17:26 caristu Regression date => 2015-04-13
2015-12-09 17:26 caristu Regression introduced in release => 3.0PR15Q3
2015-12-09 17:26 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/ac68a43ce6569746a77f67d78906d7addbac841b [^]
2015-12-09 17:26 caristu Triggers an Emergency Pack => No
2015-12-09 17:26 caristu Relationship added caused by 0029566
2015-12-10 09:37 alostale Relationship added related to 0031648
2015-12-10 09:37 alostale Priority high => immediate
2015-12-10 09:38 alostale Status new => scheduled
2015-12-14 16:28 hgbot Checkin
2015-12-14 16:28 hgbot Note Added: 0082728
2015-12-14 16:28 hgbot Status scheduled => resolved
2015-12-14 16:28 hgbot Resolution open => fixed
2015-12-14 16:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/7c6686c849289aee3d72d86dc1f9ab5397c6adcb [^]
2015-12-14 16:32 caristu Note Added: 0082729
2015-12-14 16:34 caristu Note Edited: 0082729 View Revisions
2015-12-14 16:34 caristu Assigned To caristu => alostale
2015-12-14 16:35 caristu Assigned To alostale => caristu
2015-12-14 16:35 caristu Review Assigned To => alostale
2015-12-14 16:35 caristu Issue Monitored: alostale
2015-12-14 17:18 caristu Proposed Solution updated
2015-12-14 17:21 caristu Note Edited: 0082729 View Revisions
2015-12-15 08:43 caristu Note Edited: 0082729 View Revisions
2015-12-15 09:19 alostale Note Added: 0082747
2015-12-15 09:19 alostale Status resolved => closed
2015-12-15 09:19 alostale Fixed in Version => 3.0PR16Q1
2015-12-15 09:53 caristu Note Added: 0082752
2015-12-15 10:06 caristu Relationship added related to 0031710
2015-12-15 23:49 hudsonbot Checkin
2015-12-15 23:49 hudsonbot Note Added: 0082791
2016-08-23 08:33 caristu Relationship added related to 0033743


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker