Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031061
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2015-10-06 12:172015-11-23 21:17
ReporterVictorVillarView Statuspublic 
Assigned Toaferraz 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision965d59c74291
ProjectionnoneETAnoneTarget Version3.0PR16Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031061: Not possible to reactivate a purchase invoice because there is a relation with a landed cost

DescriptionNot possible to reactivate a purchase invoice because there is a relation with a landed cost
Steps To ReproduceAs Group admin role,
  Go to Landed Cost Type window:
       Org: *
       Landed Cost Distribution Algorithm: by amount
       Product: Descuento 10%
  Go to Purchase order window
      create a new one for Cerveza Ale
  Create the Goods Receipt related.
  Create the Purchase invoice related.
      Add the Discount: Descuento 10%
 Process it.

Go to Landed Cost window,
   create a new one for EspaƱa and the Landed Cost Type:created before
   Cost tab: add a cost value = 10
   Receipt tab: select the goods receipt created before.
Process it.

Go to the purchase invoice line Descuento 10% of the purchase invoice created before. Click on Match LC Cost button and select the Landed Cost created before. Enter a Matched Amount. Click on Done button.

Try to reactivate the Purchase Invoice. You can not do that because there are related items. This is wrong because the Process Matching has not been launched yet, you should be able to reactivate the invoice
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0081615)
aferraz (developer)
2015-11-09 11:18
edited on: 2015-11-11 14:43

(*) Test plan 1 - Account Landed Cost type.

As QA Admin:

Go to G/L window and create a new one for Spain Org with below setup:

Name = Fees
Enable in Financial Invoices = Yes
Tax Category = Exempt

In the accounting tab, select any ledger account.

Go to Landed Cost Type window. Create a new landed cost type for Spain org with below setup:

Name = Fees
Landed Cost Distribution Algorithm: by amount
Account: select Fees G/L Item
  
Go to Purchase order window and create a new one for Spain, Vendor A BP. Add a purchase order line for Raw Material product, 15 units.Book the order.
  
Create the Goods Receipt related by using the option "Create Lines From" to select the order above, add a storage bin and an attribute set value. Complete it.
 
Run Costing Background process for QA Client. Verify it ends successfully so the cost of Raw Material product is calculated.

Create the Purchase invoice related by using the option "Create Lines From", select the receipt created above.
Add a new line set as financial invoice. Select the Account: Fees. Add a net unit price of 15.00 so total line net amount is 15.00. Complete the Invoice, do not use credit if any.

Go to Landed Cost window, and create a new one for Spain org.
Select the Landed Cost Type "Fees" in the cost tab, add a cost value = 150
In the Receipt tab: select the goods receipt created before.

Process landed cost.

Go back to the purchase invoice. Select invoice line "Fees".

Click on Match LC Cost button and select the Landed Cost created before. Enter a Matched Amount of 50
Click on Done button.

Go to landed cost window and check that a matched amount of 50 is shown in the landed cost document, Matched Amount tab.

Try to reactivate the Purchase Invoice. It is possible to reactivate the purchase invoice to change net price for instance of Raw Material product.

Go to landed cost window and check that the matched amount of 50 remains there.

Complete the invoice one again.

Click on "Match LC Cost" button and remove the selection. Press Done.

Go to landed cost window and check that the matched amount of 50 is not there.

Go back to the invoice and click on "Match LC Cost" button and select Fees landed cost line. Enter a Matched Amount of 15, select "Process Matching". Press Done.

Try to Reactivate the invoice. It is possible to reactivate the invoice in case any data of the invoice needs to be changed but landed cost data; otherwise process matching would need to be cancelled from Landed Cost window.


(*) Test plan 2 - Product Landed Cost type.

Go to product window and create a new product named "Transportation Cost" with below setup:
Product Category = Services
Product Type = Service
Price List Version = Purchase
Unit/list Price = 105

Go to landed cost type window and create a new one with below setup:
Name = Transportation cost
Landed cost distribution algorithm = Amount
Product = Transportation Cost.

Go to Purchase order window and create a new one for Spain, Vendor A BP. Add a purchase order line for Raw Material product, 15 units. Book the order.
  
Create the Goods Receipt related by using the option "Create Lines From" to select the order above, add a storage bin and an attribute set value. Complete it.
 
Run Costing Background process for QA Client. Verify it ends successfully so the cost of Raw Material product is calculated.

Create the Purchase invoice related by using the option "Create Lines From", select the receipt created above.
Add a new line set as financial invoice. Select the Product: Transportation Cost. Add a net unit price of 15.00 so total line net amount is 15.00. Complete the Invoice, do not use credit if any.

Go to Landed Cost window, and create a new one for Spain org.
Select the Landed Cost Type "Transportation Cost" in the cost tab, add a cost value = 25
In the Receipt tab: select the goods receipt created before.

Process landed cost.

Go back to the purchase invoice. Select invoice line "Transportation Cost".

Click on Match LC Cost button and select the Landed Cost created before. Enter a Matched Amount of 5.00.
Click on Done button.

Go to landed cost window and check that a matched amount of 5.00 is shown in the landed cost document, Matched Amount tab.

Try to reactivate the Purchase Invoice. It is possible to reactivate the purchase invoice to change net price for instance of Raw Material product.

Go to landed cost window and check that the matched amount of 5.00 remains there.

Complete the invoice one again.

Click on "Match LC Cost" button and remove the selection. Press Done.

Go to landed cost window and check that the matched amount of 5.00 is not there.

Go back to the invoice and click on "Match LC Cost" button and select "Transportation Cost" landed cost line. Enter a Matched Amount of 15, select "Process Matching". Press Done.

Try to Reactivate the invoice. It is possible to reactivate the invoice in case any data of the invoice needs to be changed but landed cost data; otherwise process matching would need to be cancelled from Landed Cost window.

(*) Test plan 3 - Product Landed Cost type (Discount).

As QA Admin:

Go to Landed Cost Type window. Create a new landed cost type for Spain org with below setup:

Name = Discount
Landed Cost Distribution Algorithm: by amount
product: discount 10%
  
Go to Purchase order window and create a new one for Spain, Vendor A BP. Add a purchase order line for Raw Material product, 15 units.Book the order.
  
Create the Goods Receipt related by using the option "Create Lines From" to select the order above, add a storage bin and an attribute set value. Complete it.
 
Run Costing Background process for QA Client. Verify it ends successfully so the cost of Raw Material product is calculated.

Create the Purchase invoice related by using the option "Create Lines From", select the receipt created above.
go to basic discounts tab and add the discount.
Complete the Invoice, do not use credit if any.
Check that a new invoice line for the discount has been used for an amount of -3.00

Go to Landed Cost window, and create a new one for Spain org.
Select the Landed Cost Type "Discount" in the cost tab, add a cost value = -5
In the Receipt tab: select the goods receipt created before.

Process landed cost.

Go back to the purchase invoice. Select invoice line "Discount".

Click on Match LC Cost button and select the Landed Cost created before. Enter a Matched Amount of -5
Click on Done button.

Go to landed cost window and check that a matched amount of -5 is shown in the landed cost document, Matched Amount tab.

Try to reactivate the Purchase Invoice. It is not possible to reactivate the purchase invoice because this process removes the discount line and that one has a matched landed cost amount (not processed) related.

Go to Discount line and click on Match LC cost button, remove the selection. Press Done.

Go to landed cost window and check that a matched amount of -5 is not shown in the landed cost document, Matched Amount tab.

Go back to the purchase invoice and try to reactivate it.
Check that it can be reactivated and discount line is removed.

(0081915)
hgbot (developer)
2015-11-17 10:25

Repository: erp/devel/pi
Changeset: 965d59c74291f20e61a21ee62ca986f3963dd431
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Nov 09 11:11:18 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/965d59c74291f20e61a21ee62ca986f3963dd431 [^]

Fixes issue 31061: Can not reactivate a invoice if it's related to a LandedCost

It is not possible to reactivate a purchase invoice if any line has a related landed cost matched.
Now, it will be possible to manually remove this landed cost matched, if matching is not processed, by unselecting it in Match LC Costs pick and edit, and then reactivate purchase invoice.

---
M src/org/openbravo/costing/LCCostMatchFromInvoiceHandler.java
---
(0081916)
dmiguelez (developer)
2015-11-17 10:26

Code Review + Testing Ok
(0082247)
hudsonbot (developer)
2015-11-23 21:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-10-06 12:17 VictorVillar New Issue
2015-10-06 12:17 VictorVillar Assigned To => Triage Finance
2015-10-06 12:17 VictorVillar Modules => Core
2015-10-06 12:17 VictorVillar Triggers an Emergency Pack => No
2015-10-06 12:17 VictorVillar Issue Monitored: networkb
2015-11-05 12:49 aferraz Assigned To Triage Finance => aferraz
2015-11-05 12:50 aferraz Status new => scheduled
2015-11-09 11:18 aferraz Note Added: 0081615
2015-11-09 11:20 aferraz Note Edited: 0081615 View Revisions
2015-11-10 13:16 psanjuan Steps to Reproduce Updated View Revisions
2015-11-10 14:07 psanjuan Note Edited: 0081615 View Revisions
2015-11-10 14:10 psanjuan Note Edited: 0081615 View Revisions
2015-11-10 14:17 psanjuan Note Edited: 0081615 View Revisions
2015-11-10 14:43 psanjuan Note Edited: 0081615 View Revisions
2015-11-10 14:46 psanjuan Note Edited: 0081615 View Revisions
2015-11-10 14:47 psanjuan Note Edited: 0081615 View Revisions
2015-11-10 14:49 psanjuan Note Edited: 0081615 View Revisions
2015-11-10 14:53 psanjuan Note Edited: 0081615 View Revisions
2015-11-11 13:57 psanjuan Note Edited: 0081615 View Revisions
2015-11-11 14:01 psanjuan Note Edited: 0081615 View Revisions
2015-11-11 14:03 psanjuan Note Edited: 0081615 View Revisions
2015-11-11 14:04 psanjuan Note Edited: 0081615 View Revisions
2015-11-11 14:24 psanjuan Note Edited: 0081615 View Revisions
2015-11-11 14:24 psanjuan Note Edited: 0081615 View Revisions
2015-11-11 14:25 psanjuan Note Edited: 0081615 View Revisions
2015-11-11 14:26 psanjuan Note Edited: 0081615 View Revisions
2015-11-11 14:30 psanjuan Note Edited: 0081615 View Revisions
2015-11-11 14:36 psanjuan Note Edited: 0081615 View Revisions
2015-11-11 14:43 psanjuan Note Edited: 0081615 View Revisions
2015-11-17 10:25 hgbot Checkin
2015-11-17 10:25 hgbot Note Added: 0081915
2015-11-17 10:25 hgbot Status scheduled => resolved
2015-11-17 10:25 hgbot Resolution open => fixed
2015-11-17 10:25 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/965d59c74291f20e61a21ee62ca986f3963dd431 [^]
2015-11-17 10:26 dmiguelez Review Assigned To => dmiguelez
2015-11-17 10:26 dmiguelez Note Added: 0081916
2015-11-17 10:26 dmiguelez Status resolved => closed
2015-11-23 21:17 hudsonbot Checkin
2015-11-23 21:17 hudsonbot Note Added: 0082247


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker