Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031041
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2015-10-05 12:432015-11-23 21:16
ReporterVictorVillarView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision9a8285081a69
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031041: The inventory amount update is not working fine under some circunstancies

DescriptionThe inventory amount update is not working fine under some circunstancies
Steps To ReproduceAs group admin role,
   Go to inventory amount update
       España
       date: today
  Go to Lines tab:
      date: 03/06/2015
      Product: Zumo de Naranja
      Unit cost: 200
Process it. Realise that the following error appears but it should not, because there is stock.
Insuffient stock for Product 'Zumo de Naranja Bio 0,33L' with Attribute 'L0', UOM 'Unit' and Storage Bin 'Rn-0-0-0'
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0031026 closedaferraz wrong warehouse in the lines of the inventory amount update 

-  Notes
(0080844)
psanjuan (manager)
2015-10-06 14:52

Issue verified with below error message:
Insuffient stock for Product 'Zumo de Naranja Bio 0,33L' with Attribute 'L582', UOM 'Unit' and Storage Bin 'RS-0-0-0'

however stock is = 69100
(0081071)
psanjuan (manager)
2015-10-19 12:11
edited on: 2015-10-19 17:17

When the closing and opening inventories created by an Inventory Amount Update booked in the past are being processed, it is not necessary to check the stock (same as with "Reservations"), as an opening inventory is going to be created for the same quantity as closing inventory.

(0081097)
aferraz (developer)
2015-10-19 17:15
edited on: 2015-10-22 10:55

Test plan:

Make sure F&B España has assigned a costing rule with Average Algorithm configured. Warehouse Dimension = No.

As group admin role,
   Go to inventory amount update. Create a new one for F&B España on current date.
  Go to Lines tab:
      enter reference date: 03/06/2015
      Select Product: Zumo de Naranja
      Enter a Unit cost: 200
Process it. Check that the process is completed successfully.

(0081191)
psanjuan (manager)
2015-10-22 10:56

Test Plan above verified.
Checked that the process now is completed successfully, because now the stock is not check as it does not make any sense. Both a closing and an opening inventory for both warehouse with same stock details have been created.
(0081294)
hgbot (developer)
2015-10-26 09:53

Repository: erp/devel/pi
Changeset: 9a8285081a6988ce808bdd4c49d1794c65b4eeed
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Oct 19 17:11:49 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/9a8285081a6988ce808bdd4c49d1794c65b4eeed [^]

Fixes issue 31041: Insuffient stock error message when processing an inventory

Avoid "insufficient stock" error message when processing an Inventory Amount Update created in the past.
Now, when processing related closing and opening inventories, negative stock will not be checked.

---
M src/org/openbravo/materialmgmt/InventoryCountProcess.java
---
(0081295)
dmiguelez (developer)
2015-10-26 09:54

Code Review + Testing Ok
(0082156)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-10-05 12:43 VictorVillar New Issue
2015-10-05 12:43 VictorVillar Assigned To => Triage Finance
2015-10-05 12:43 VictorVillar Modules => Core
2015-10-05 12:43 VictorVillar Triggers an Emergency Pack => No
2015-10-05 12:44 VictorVillar Relationship added related to 0031026
2015-10-06 13:03 aferraz Assigned To Triage Finance => aferraz
2015-10-06 13:03 aferraz Status new => scheduled
2015-10-06 14:52 psanjuan Note Added: 0080844
2015-10-09 11:02 aferraz Status scheduled => feedback
2015-10-19 12:11 psanjuan Note Added: 0081071
2015-10-19 15:00 psanjuan Note Edited: 0081071 View Revisions
2015-10-19 15:01 psanjuan Note Edited: 0081071 View Revisions
2015-10-19 16:36 aferraz Status feedback => scheduled
2015-10-19 17:15 aferraz Note Added: 0081097
2015-10-19 17:17 aferraz Note Edited: 0081071 View Revisions
2015-10-22 10:04 psanjuan Note Edited: 0081097 View Revisions
2015-10-22 10:09 psanjuan Note Edited: 0081097 View Revisions
2015-10-22 10:55 psanjuan Note Edited: 0081097 View Revisions
2015-10-22 10:56 psanjuan Note Added: 0081191
2015-10-26 09:53 hgbot Checkin
2015-10-26 09:53 hgbot Note Added: 0081294
2015-10-26 09:53 hgbot Status scheduled => resolved
2015-10-26 09:53 hgbot Resolution open => fixed
2015-10-26 09:53 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9a8285081a6988ce808bdd4c49d1794c65b4eeed [^]
2015-10-26 09:54 dmiguelez Review Assigned To => dmiguelez
2015-10-26 09:54 dmiguelez Note Added: 0081295
2015-10-26 09:54 dmiguelez Status resolved => closed
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082156


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker