Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031039
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 08. Project and service managementmajoralways2015-10-05 11:102015-11-23 21:16
ReporterngarciaView Statuspublic 
Assigned Tovmromanos 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision910a0f8b417c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031039: Cannot create sales order from project phase if the customer default invoice terms is Contract Billing

DescriptionCannot create sales order from project phase if the customer default invoice terms is Contract Billing
Steps To ReproduceAs system admin role:
   Install the Service Contract Management module
As group admin role:
   Set the Invoice Terms = Contract Billing to a BP - Customer
   Create a Multiphase Project for that BP
   Add a Sales Representative to it
   Add a phase to it
   Change Project Status to Order
   Select the phase and launch the Create Sales Order from Project Phase process
   Check the following error message is shown:
      value too long for type character(1)
   
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0081020)
vmromanos (developer)
2015-10-14 16:43

Note that Contracts and Projects are both mutually exclusive; that means that if you install Contract modules is because you don't want to use Projects (contact ICI for more details).

If you try to use both at the same time you might find conflicts or other problems. It is highly recommended to avoid this practice, which is not supported by the system.


In this concrete bug, since the fix is riskless for Core, we are fixing it. But this is an exception, and as a general rule we won't be fixing other issues related to supporting both contracts and projects at the same time.
(0081021)
vmromanos (developer)
2015-10-14 16:51

Test plan:

As system admin role:
   Install the Service Contract Management module
As group admin role:
   Set the Invoice Terms = Contract Billing to a BP - Customer
   Create a Multiphase Project for that BP
   Add a Sales Representative to it
   Add a phase to it
   Change Project Status to Order
   Select the phase and launch the Create Sales Order from Project Phase process.
   Verify no error is thrown and the sales order is successfully created
(0081134)
psanjuan (manager)
2015-10-20 13:32

Issue verified.

Test Plan above also verified. A sales order is properly created now with the information referred in the multi phase project.
(0081166)
hgbot (developer)
2015-10-21 10:16

Repository: erp/devel/pi
Changeset: 910a0f8b417c918c096ce081d22cbe571d2fa2d0
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Wed Oct 14 16:47:18 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/910a0f8b417c918c096ce081d22cbe571d2fa2d0 [^]

Fixed bug 31039: Cannot create sales order from project phase if the customer default invoice terms is Contract Billing

The v_InvoiceRule variable was defined as CHAR. In case the C_BPartner.InvoiceRule length is higher than 1 (as when defining Contract Billing), the process throws an exception.
The solution is to declare the variable as C_BPartner.InvoiceRule%TYPE, which automatically takes the definition from the C_BPartner table.

---
M src-db/database/model/functions/C_GENERATESOFROMPROJECTPHASE.xml
---
(0081167)
dmiguelez (developer)
2015-10-21 10:16

Code Review + Testing Ok
(0082137)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-10-05 11:10 ngarcia New Issue
2015-10-05 11:10 ngarcia Assigned To => Triage Finance
2015-10-05 11:10 ngarcia Modules => Core
2015-10-05 11:10 ngarcia Triggers an Emergency Pack => No
2015-10-05 11:10 ngarcia Issue Monitored: networkb
2015-10-14 16:21 vmromanos Assigned To Triage Finance => vmromanos
2015-10-14 16:21 vmromanos Status new => acknowledged
2015-10-14 16:43 vmromanos Status acknowledged => scheduled
2015-10-14 16:43 vmromanos Note Added: 0081020
2015-10-14 16:51 vmromanos Note Added: 0081021
2015-10-20 13:32 psanjuan Note Added: 0081134
2015-10-21 10:16 hgbot Checkin
2015-10-21 10:16 hgbot Note Added: 0081166
2015-10-21 10:16 hgbot Status scheduled => resolved
2015-10-21 10:16 hgbot Resolution open => fixed
2015-10-21 10:16 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/910a0f8b417c918c096ce081d22cbe571d2fa2d0 [^]
2015-10-21 10:16 dmiguelez Review Assigned To => dmiguelez
2015-10-21 10:16 dmiguelez Note Added: 0081167
2015-10-21 10:16 dmiguelez Status resolved => closed
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082137


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker