Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030961
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2015-09-29 14:172015-11-23 21:17
ReporterngarciaView Statuspublic 
Assigned Toaferraz 
PriorityurgentResolutionfixedFixed in Version3.0PR16Q1
StatusclosedFix in branchFixed in SCM revisione991e8220a8a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030961: Sales Order lines cannot be partially delivered if there is not enough stock due to the warehouse rule but there is more stock

DescriptionSales Order lines cannot be partially delivered if there is not enough stock due to the warehouse rule but there is more available stock in the on hand warehouses that do not fulfill the rule:

- If all the available stock complies with the rule, a partial shipment is made
- If there is some stock that does not comply with the rule, the partial shipment is not made
Steps To Reproduce   Create a warehouse rule which removes only some records of the m_stock_proposed table (for instance, the ones that do not belong to España Región Norte warehouse)
As group admin role:
   Check a product which has stock in Norte and Sur warehouses
   Create a sales order for F&B España, S.A. with that product but a higher quantity than the quantity available in the Norte warehouse
   Set that rule on its line
   Book it
   Go to Create Shipments from Orders and select the previously created order
   An error message is shown with the warehouse's names (This is another problem as the message that was intended to be shown was NotEnoughStockedDueWHRule)
   Leave only stock in the Norte warehouse
   Go to Create Shipments from Orders and select the previously created order
   Check the shipment is partially created and the following warning is shown:
      Warning
Order No. <> Shipment No. <>: Order partially delivered.
Order line: 10 for product <>: Not enough stock to complete the line, partially delivered.
Proposed SolutionVerify the checks made in the M_GET_STOCK_PARAM function after applying the Warehouse Rules
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0022231 closedgorkaion Qty on hand warehouses and rules 

-  Notes
(0081764)
hgbot (developer)
2015-11-12 17:33

Repository: erp/devel/pi
Changeset: e991e8220a8a5713a126cf95b7d85c9c4b275c81
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu Nov 12 17:32:58 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e991e8220a8a5713a126cf95b7d85c9c4b275c81 [^]

Fixes issue 30961: Warehouse rules will now make partial reservations

Warehouse rules will now make partial reservations in case it exists stock for the reservation but not enough to cover it completely.

---
M src-db/database/model/functions/M_GET_STOCK_PARAM.xml
---
(0081765)
aferraz (developer)
2015-11-12 17:35

Code review + Testing OK done by dmiguelez.
Functional API change published (PR16Q1.3): http://wiki.openbravo.com/wiki/API_changes [^]
(0082211)
hudsonbot (developer)
2015-11-23 21:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-09-29 14:17 ngarcia New Issue
2015-09-29 14:17 ngarcia Assigned To => Triage Finance
2015-09-29 14:17 ngarcia Modules => Core
2015-09-29 14:17 ngarcia Triggers an Emergency Pack => No
2015-09-29 14:19 ngarcia Description Updated View Revisions
2015-09-29 14:19 ngarcia Issue Monitored: networkb
2015-09-29 14:32 ngarcia Relationship added related to 0022231
2015-09-29 17:07 ngarcia Type feature request => defect
2015-09-29 17:07 ngarcia Summary It would be fine if sales order lines could be partially delivered although there is not enough stock due to the warehouse rule => Sales Order lines cannot be partially delivered if there is not enough stock due to the warehouse rule but there is more stock
2015-09-29 17:07 ngarcia Description Updated View Revisions
2015-09-29 17:07 ngarcia Steps to Reproduce Updated View Revisions
2015-09-29 17:12 ngarcia Steps to Reproduce Updated View Revisions
2015-09-29 17:12 ngarcia Proposed Solution updated
2015-10-19 10:02 AtulOpenbravo Assigned To Triage Finance => AtulOpenbravo
2015-10-28 11:17 vmromanos Status new => scheduled
2015-11-12 17:33 hgbot Checkin
2015-11-12 17:33 hgbot Note Added: 0081764
2015-11-12 17:33 hgbot Status scheduled => resolved
2015-11-12 17:33 hgbot Resolution open => fixed
2015-11-12 17:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e991e8220a8a5713a126cf95b7d85c9c4b275c81 [^]
2015-11-12 17:33 aferraz Assigned To AtulOpenbravo => aferraz
2015-11-12 17:35 aferraz Review Assigned To => dmiguelez
2015-11-12 17:35 aferraz Note Added: 0081765
2015-11-12 17:35 aferraz Status resolved => closed
2015-11-12 17:35 aferraz Fixed in Version => 3.0PR16Q1
2015-11-23 21:17 hudsonbot Checkin
2015-11-23 21:17 hudsonbot Note Added: 0082211


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker