Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030658
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Cash upmajoralways2015-08-24 21:422015-09-28 10:24
ReporterrbianchiniView Statuspublic 
Assigned Tomario_castello 
PrioritynormalResolutionfixedFixed in VersionRR15Q4
StatusclosedFix in branchFixed in SCM revisionc8e161556ec9
ProjectionnoneETAnoneTarget VersionRR15Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionRR15Q3SCM revision 
Review Assigned Tomarvintm
Regression levelProduction - Confirmed Stable
Regression date
Regression introduced in releaseRR15Q1.5
Regression introduced by commithttps://issues.openbravo.com/view.php?id=27019 [^]
Triggers an Emergency PackNo
Summary

0030658: Wrong user in cash up

DescriptionWhen you make a cash up in a version greater than 14Q3.6, the user/contact who made the cash up is wrong. This value is filled with the user who made the previous cash up.
Steps To Reproduce1 - Log in WebPOS as vallblanca
2 - sell something and make a cash up
3 - select back office in the menu
4 - check the cash up made and observes the user/contact field is valblanca
5 - log out WebPOS
6 - Log in WebPOS as openbravo
7 - sell something and make a cash up
8 - go to ERP
9 - Observes that the first cash up (made by vallblanca) has the field user filled with openbravo and the second cash up (made by openbravo) has the field user filled with valblanca
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on defect 0030743 closedRetail Automation: Add test in RR15Q4 
depends on backport 0030744RR15Q3.2 closedRetail Wrong user in cash up 
depends on backport 0030745RR15Q2.5 closedmarvintm Wrong user in cash up 
caused by design defect 0027019RR15Q1 closedszapata In Q2 version cash ups and reconciliations are not being created properly 

-  Notes
(0080358)
hgbot (developer)
2015-09-12 16:10

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: c8e161556ec984c8f1589a02474991490f45fe89
Author: Mario Castello <mario.castello <at> peoplewalking.com>
Date: Sat Sep 12 08:09:40 2015 -0600
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/c8e161556ec984c8f1589a02474991490f45fe89 [^]

Fixed issue 30658: Set the user in cash up process

---
M src/org/openbravo/retail/posterminal/CashCloseProcessor.java
---
(0080359)
hgbot (developer)
2015-09-12 16:14

Repository: tools/automation/pi-mobile
Changeset: fe2755ef347b241acf696371315c002772c5b5e4
Author: Mario Castello <mario.castello <at> peoplewalking.com>
Date: Sat Sep 12 08:13:48 2015 -0600
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/fe2755ef347b241acf696371315c002772c5b5e4 [^]

Related to issue 30658: Automation test to verify the user in cash up

---
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/cashup/I30658_VerifyUserCashpUp.java
---
(0080362)
hgbot (developer)
2015-09-13 22:54

Repository: tools/automation/pi-mobile
Changeset: 7bea89af6a0c67018051e04b6826bc2d3586f576
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Sun Sep 13 22:54:08 2015 +0200
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/7bea89af6a0c67018051e04b6826bc2d3586f576 [^]

Related to issue 30658: Wrong user in cash up
Disabled Openbravo user used in test as it causes test to fail. To solve/revisit.

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/cashup/I30658_VerifyUserCashpUp.java
---
(0080363)
hgbot (developer)
2015-09-13 22:58

Repository: tools/automation/pi-mobile
Changeset: 02e8dadfb7f4cb6d9e3c708da0b6c1fb3ad66288
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Sun Sep 13 22:58:36 2015 +0200
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/02e8dadfb7f4cb6d9e3c708da0b6c1fb3ad66288 [^]

Related to issue 30658: Wrong user in cash up
Use demouser login instead of Openbravo

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/cashup/I30658_VerifyUserCashpUp.java
---

- Issue History
Date Modified Username Field Change
2015-08-24 21:42 rbianchini New Issue
2015-08-24 21:42 rbianchini Assigned To => Retail
2015-08-24 21:42 rbianchini Regression level => Production - Confirmed Stable
2015-08-24 21:42 rbianchini Regression introduced in release => RR15Q1.5
2015-08-24 21:42 rbianchini Triggers an Emergency Pack => No
2015-09-02 16:31 Orekaria Relationship added depends on 0030743
2015-09-02 16:47 Orekaria Target Version => RR15Q4
2015-09-02 17:19 Orekaria Status new => scheduled
2015-09-11 23:21 Orekaria Assigned To Retail => mario_castello
2015-09-11 23:26 Orekaria Relationship added caused by 0027019
2015-09-11 23:26 Orekaria Regression introduced by commit => https://issues.openbravo.com/view.php?id=27019 [^]
2015-09-12 16:10 hgbot Checkin
2015-09-12 16:10 hgbot Note Added: 0080358
2015-09-12 16:10 hgbot Status scheduled => resolved
2015-09-12 16:10 hgbot Resolution open => fixed
2015-09-12 16:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/c8e161556ec984c8f1589a02474991490f45fe89 [^]
2015-09-12 16:14 hgbot Checkin
2015-09-12 16:14 hgbot Note Added: 0080359
2015-09-13 22:54 hgbot Checkin
2015-09-13 22:54 hgbot Note Added: 0080362
2015-09-13 22:58 hgbot Checkin
2015-09-13 22:58 hgbot Note Added: 0080363
2015-09-18 15:08 VictorVillar Issue Monitored: networkb
2015-09-18 15:10 VictorVillar Issue Monitored: VictorVillar
2015-09-28 10:24 marvintm Review Assigned To => marvintm
2015-09-28 10:24 marvintm Status resolved => closed
2015-09-28 10:24 marvintm Fixed in Version => RR15Q4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker