Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030602
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajorhave not tried2015-08-19 12:162015-09-14 17:10
ReportershuehnerView Statuspublic 
Assigned Tovmromanos 
PriorityurgentResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revision9f7d0329490b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030602: int-obx /view.php?id=474 fails as new module merge for 'Inventory Average Cost transactions' declare in core and not org.openbravo.v3

DescriptionRecently content of a module 'Inventory Average Cost' was added to pi.

It was done not adding module itself but declaring that this module was merged into some module of the distribution.

That merge was declare in the core (module_id=0) module.

However that is a change requiring normally to raise the major version which is not wanted or feasible at all for any module in pi.

Move that merge to org.openbrao.v3 (Openbravo v3 pack) as that module already had other merges and has special 'Allow changes in minor verison' flag set in the centralrepository allowing exception from that 'need to raise major version' rule.
Steps To Reproducehttps://ci.openbravo.com/job/int-obx/474/ [^]
Proposed SolutionMove the ad_module_merge entry for 'Inventory Average Cost' from core to org.openbravo.v3 module.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0079423)
hgbot (developer)
2015-08-19 14:39

Repository: erp/devel/pi
Changeset: 32822c040e86889344d0277d63136f94aa870193
Author: Stefan Hühner <stefan.huehner <at> openbravo.com>
Date: Wed Aug 19 12:18:15 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/32822c040e86889344d0277d63136f94aa870193 [^]

Fixed 30602. Moe module merge from core to org.openbravo.v3

That is required as declaring module merge normally requires to raise major
version and only the org.openbravo.v3 has an exception allowed for this rule.

---
M modules/org.openbravo.v3/src-db/database/sourcedata/AD_MODULE_MERGE.xml
R src-db/database/sourcedata/AD_MODULE_MERGE.xml
---
(0079432)
shuehner (administrator)
2015-08-20 11:43

Reopening as for now even merge in org.openbravo.v3 module not possible as is. As the 'Allow changes in minor version' flag does not allow/cover adding merges
(0079433)
hgbot (developer)
2015-08-20 11:53

Repository: erp/devel/pi
Changeset: 7a8050d0202c2d3dc2abb5c1c942e8d52b0adf4a
Author: Stefan Hühner <stefan.huehner <at> openbravo.com>
Date: Thu Aug 20 11:52:13 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/7a8050d0202c2d3dc2abb5c1c942e8d52b0adf4a [^]

Issue 30602: Undeclare merge for the moment until clear how it can be done.

'Allow changes in minor version' in CR does not cover merges at the moment.
Undeclare the merge for now until a proper solution can be found.

---
M modules/org.openbravo.v3/src-db/database/sourcedata/AD_MODULE_MERGE.xml
---
(0079562)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test
(0080334)
hgbot (developer)
2015-09-11 11:33

Repository: erp/devel/pi
Changeset: 9f7d0329490bf0610f1d22ad82374dcbaabe961a
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Fri Sep 11 10:58:53 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/9f7d0329490bf0610f1d22ad82374dcbaabe961a [^]

Fixed 30602: Inventory Average Cost module merge declared to org.openbravo.v3

Butler production has the capability to add new merges in minor versions for:
* core module
* modules marked as allow changes in minor versions

The merge has been declared for the org.openbrao.v3 (Openbravo v3 pack) module, because it already had other merges and has special 'Allow changes in minor verison' flag set in Butler.

---
M modules/org.openbravo.v3/src-db/database/sourcedata/AD_MODULE_MERGE.xml
---
(0080379)
AugustoMauch (developer)
2015-09-14 17:10

Code reviewed and verified in pi@9f7d0329490b

- Issue History
Date Modified Username Field Change
2015-08-19 12:16 shuehner New Issue
2015-08-19 12:16 shuehner Assigned To => shuehner
2015-08-19 12:16 shuehner Modules => Core
2015-08-19 12:16 shuehner Triggers an Emergency Pack => No
2015-08-19 14:39 hgbot Checkin
2015-08-19 14:39 hgbot Note Added: 0079423
2015-08-19 14:39 hgbot Status new => resolved
2015-08-19 14:39 hgbot Resolution open => fixed
2015-08-19 14:39 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/32822c040e86889344d0277d63136f94aa870193 [^]
2015-08-19 14:42 shuehner Review Assigned To => AugustoMauch
2015-08-20 11:43 shuehner Note Added: 0079432
2015-08-20 11:43 shuehner Status resolved => new
2015-08-20 11:43 shuehner Resolution fixed => open
2015-08-20 11:53 hgbot Checkin
2015-08-20 11:53 hgbot Note Added: 0079433
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079562
2015-09-11 09:23 vmromanos Status new => scheduled
2015-09-11 09:23 vmromanos Assigned To shuehner => vmromanos
2015-09-11 11:33 hgbot Checkin
2015-09-11 11:33 hgbot Note Added: 0080334
2015-09-11 11:33 hgbot Status scheduled => resolved
2015-09-11 11:33 hgbot Resolution open => fixed
2015-09-11 11:33 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/32822c040e86889344d0277d63136f94aa870193 [^] => http://code.openbravo.com/erp/devel/pi/rev/9f7d0329490bf0610f1d22ad82374dcbaabe961a [^]
2015-09-14 17:10 AugustoMauch Note Added: 0080379
2015-09-14 17:10 AugustoMauch Status resolved => closed
2015-09-14 17:10 AugustoMauch Fixed in Version => pi


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker