Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030600
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementcriticalalways2015-08-19 10:022015-08-20 23:16
ReporteraferrazView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision97d4a255c5da
ProjectionnoneETAnoneTarget Version3.0PR15Q4
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2015-08-07
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/4beee9b03fe7 [^]
Triggers an Emergency PackNo
Summary

0030600: Create Lines From process allows to choose any locator

DescriptionCreate Lines From process in Goods Receipt and Goods Shipment windows allows to choose any locator without taking into account the organization
Steps To ReproduceAs group admin role:

- Create a Goods Shipment for F&B España Region Norte
- Click on Create Lines From process
- Clicl on Warehouse position selector and clean the filters
- Realize you can select any storage bin
- The same happens in Goods Receipt window
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0030556 closedaferraz Goods shipment can be processed although there is not stock of a product and negative stock is not allowed at client level 
related to defect 00233683.0MP24 closedSandrahuguet Wrong Storage Bin filter in Create Inventory Count List (Physical inventory) 
caused by defect 0030463 closedAtulOpenbravo Move a Storage Bin process of Goods Movement window allows to choose any locator without taking into account the organization 
related to defect 0033373 closedSanjota Create Lines From allows to choose a storage bin that does not belong to the goods shipment/receipt organization 

-  Notes
(0079429)
aferraz (developer)
2015-08-20 10:32

Test Plan

As group admin role:

- Create a Goods Shipment for F&B España Region Norte
- Click on Create Lines From process
- Click on Warehouse position selector and clean the filters
- Realize you can select only storage bin from España Region Norte warehouse

- Change the organization to F&B España Region Sur
- Click on Create Lines From process
- Click on Warehouse position selector and clean the filters
- Realize you can select only storage bin from España Region Sur warehouse

- Change the organization to F&B España and España Region Norte warehouse
- Click on Create Lines From process
- Click on Warehouse position selector and clean the filters
- Realize you can select only storage bin from España Region Norte or Sur warehouses

- Realize the same happens if you open Locator selector from Lines tab

- Realize the same happens in Goods Receipt window

- Create a new Goods Movement for F&B España Region Norte
- Click on Move a Storage Bin process
- Click on Storage Bin from selector and clean the filters
- Realize you can select only storage bin from España Region Norte warehouse

- Create a new Goods Movement for F&B España Region Sur
- Click on Move a Storage Bin process
- Click on Storage Bin from selector and clean the filters
- Realize you can select only storage bin from España Region Sur warehouse

- Create a new Goods Movement for F&B España
- Click on Move a Storage Bin process
- Click on Storage Bin from selector and clean the filters
- Realize you can select only storage bin from España Region Norte or Sur warehouses

- Realize the same happens with Storage Bin to selector

- Realize the same happens if you open Locator selector from Lines tab

- Realize the same happens in any other window where exists a Locator selector
(0079435)
hgbot (developer)
2015-08-20 12:50

Repository: erp/devel/pi
Changeset: 97d4a255c5daa433f2ca9610fcfe5c340ecdbaba
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed Aug 19 15:23:17 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/97d4a255c5daa433f2ca9610fcfe5c340ecdbaba [^]

Fixes issue 30600: Backout commits from issue 30463

---
M src/org/openbravo/erpCommon/info/Locator.java
M src/org/openbravo/erpCommon/info/Locator_data.xsql
---
(0079436)
hgbot (developer)
2015-08-20 12:50

Repository: erp/devel/pi
Changeset: 21fec7ccc7ba2ae5c6c80c56826796911064812f
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed Aug 19 20:39:40 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/21fec7ccc7ba2ae5c6c80c56826796911064812f [^]

Related to issue 30600: Fix Locator selector in Goods Movement window

Organization parameter will be correctly setted in Goods Movement window

---
M src/org/openbravo/erpCommon/info/Locator.java
---
(0079437)
dmiguelez (developer)
2015-08-20 12:51

Code Review + Testing Ok
(0079563)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test
(0079565)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-08-19 10:02 aferraz New Issue
2015-08-19 10:02 aferraz Assigned To => aferraz
2015-08-19 10:02 aferraz Modules => Core
2015-08-19 10:02 aferraz Regression date => 2015-08-07
2015-08-19 10:02 aferraz Regression introduced in release => pi
2015-08-19 10:02 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/4beee9b03fe7 [^]
2015-08-19 10:02 aferraz Triggers an Emergency Pack => No
2015-08-19 10:03 aferraz Regression level => Pre packaging ( pi )
2015-08-19 10:04 aferraz Relationship added caused by 0030463
2015-08-19 10:09 aferraz Relationship added related to 0030556
2015-08-19 10:09 aferraz Status new => scheduled
2015-08-19 10:11 ngarcia Issue Monitored: ngarcia
2015-08-19 15:10 aferraz Relationship added related to 0023368
2015-08-20 10:32 aferraz Note Added: 0079429
2015-08-20 12:50 hgbot Checkin
2015-08-20 12:50 hgbot Note Added: 0079435
2015-08-20 12:50 hgbot Status scheduled => resolved
2015-08-20 12:50 hgbot Resolution open => fixed
2015-08-20 12:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/97d4a255c5daa433f2ca9610fcfe5c340ecdbaba [^]
2015-08-20 12:50 hgbot Checkin
2015-08-20 12:50 hgbot Note Added: 0079436
2015-08-20 12:51 dmiguelez Review Assigned To => dmiguelez
2015-08-20 12:51 dmiguelez Note Added: 0079437
2015-08-20 12:51 dmiguelez Status resolved => closed
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079563
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079565
2016-06-28 18:06 ngarcia Relationship added related to 0033373


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker