Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030530
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 01. General setupmajoralways2015-08-10 10:212015-08-20 23:16
ReportermaiteView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q4
StatusclosedFix in branchFixed in SCM revision774036976ffc
ProjectionnoneETAnoneTarget Version3.0PR15Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-11-14
Regression introduced in release3.0PR15Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/9eba998e1eb9 [^]
Triggers an Emergency PackNo
Summary

0030530: Performance problem in "InitializeBPCurrency" modulescript

DescriptionPerformance problem in "InitializeBPCurrency" modulescript
Steps To ReproduceRelated with issue https://issues.openbravo.com/view.php?id=28076 [^] , "UpdateBpCurrency" method was included. Performance of this method in not good in case huge amount of business partners needs to be updated

In my case, query returns 35382 business partners to update (I wait for 40 minutes and still running). Contact me in case copy of this environment is required.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00305843.0PR15Q3.1 closedaferraz Performance problem in "InitializeBPCurrency" modulescript 
depends on backport 00305853.0PR15Q2.4 closedaferraz Performance problem in "InitializeBPCurrency" modulescript 
caused by defect 0028076 closedAtulOpenbravo "InitializeBPCurrency" modulescript needs to be improved 
related to defect 00308543.0PR15Q4 closedvmromanos Still performance problem in "InitializeBPCurrency" modulescript 

-  Notes
(0079369)
hgbot (developer)
2015-08-14 18:43

Repository: erp/devel/pi
Changeset: 774036976ffcec1f92f3bd4ecd14068f6abca673
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Fri Aug 14 13:02:06 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/774036976ffcec1f92f3bd4ecd14068f6abca673 [^]

Fixes issue 30530: Performance problem in InitializeBPCurrency modulescript

Improve performance of UpdateBpCurrency method in InitializeBPCurrency modulescript.

---
M src-util/modulescript/build/classes/org/openbravo/modulescript/InitializeBPCurrencyData.class
M src-util/modulescript/build/javasqlc/src/org/openbravo/modulescript/InitializeBPCurrencyData.java
M src-util/modulescript/src/org/openbravo/modulescript/InitializeBPCurrency_data.xsql
---
(0079370)
aferraz (developer)
2015-08-14 18:50

Code review and Testing OK done by vmromanos
(0079554)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-08-10 10:21 maite New Issue
2015-08-10 10:21 maite Assigned To => Triage Finance
2015-08-10 10:21 maite Modules => Core
2015-08-10 10:21 maite Triggers an Emergency Pack => No
2015-08-10 10:21 maite Issue Monitored: networkb
2015-08-10 12:55 aferraz Assigned To Triage Finance => aferraz
2015-08-14 13:26 aferraz Regression level => Production - Confirmed Stable
2015-08-14 13:26 aferraz Regression date => 2014-11-14
2015-08-14 13:26 aferraz Regression introduced in release => 3.0PR15Q1
2015-08-14 13:26 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/9eba998e1eb9 [^]
2015-08-14 13:31 aferraz Status new => scheduled
2015-08-14 13:35 aferraz Relationship added caused by 0028076
2015-08-14 18:43 hgbot Checkin
2015-08-14 18:43 hgbot Note Added: 0079369
2015-08-14 18:43 hgbot Status scheduled => resolved
2015-08-14 18:43 hgbot Resolution open => fixed
2015-08-14 18:43 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/774036976ffcec1f92f3bd4ecd14068f6abca673 [^]
2015-08-14 18:50 aferraz Review Assigned To => vmromanos
2015-08-14 18:50 aferraz Note Added: 0079370
2015-08-14 18:50 aferraz Status resolved => closed
2015-08-14 18:50 aferraz Fixed in Version => 3.0PR15Q4
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079554
2015-09-17 09:43 maite Relationship added related to 0030854


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker