Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030507
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminoralways2015-08-06 12:252015-09-25 08:59
ReportermfuertesView Statuspublic 
Assigned Toinigosanchez 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q4
StatusclosedFix in branchFixed in SCM revision6b358e197d08
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-02-26
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/20eb3426d990 [^]
Triggers an Emergency PackNo
Summary

0030507: When clicking on a field on edit mode on the grid the value is not selected

DescriptionWhen editing a row on grid view if you click on a field the value is not selected.
On releases previous than PR15Q1.5, when clicking on a field the value contained on it was automatically refreshed.

Using the tab key to move from one field to other the value is properly selected.
Steps To Reproducehttps://drive.google.com/open?id=0BwUNU8Cy2RKYVUZzbW0zQVZlUWM [^]
TagsNo tags attached.
Attached Filesdiff file icon isc-combined-beautified.diff [^] (1,886 bytes) 2015-09-25 08:51 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00305123.0PR15Q3.1 closedinigosanchez When clicking on a field on edit mode on the grid the value is not selected 
depends on backport 00305133.0PR15Q2.4 closedinigosanchez When clicking on a field on edit mode on the grid the value is not selected 
caused by feature request 0025574 closeddbaz Upgrade SmartClient 10.0d 
related to defect 0031274 closedcaristu current combo value is not selected when opening drop down list with mouse in form view 
related to defect 0031365 acknowledgedplatform Delete _shouldSelectOnFocus() method from TextItem class 
blocks defect 0030846 closedplatform When clicking on a field on edit mode on the grid the value 0 is not selected 

-  Notes
(0079232)
alostale (developer)
2015-08-06 17:02

Most probably introduced in 3.0PR14Q2 with SC upgrade (needs confirmation). Note SC behaves in the same way currently OB does.
(0079313)
alostale (developer)
2015-08-11 13:22

Reported in SC forums: http://forums.smartclient.com/showthread.php?t=33300 [^]
(0079389)
inigosanchez (developer)
2015-08-17 12:53

It is a regression in Smartclient library. Awaiting for a reply in SmartClient forums.

Updated info in SC forums: http://forums.smartclient.com/showthread.php?t=33300 [^]
(0080598)
hgbot (developer)
2015-09-24 09:52

Repository: erp/mods/org.openbravo.userinterface.smartclient.dev
Changeset: b9755214276fc0cfa449b512883188e6dbdbb1d0
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Sep 24 09:45:00 2015 +0200
URL: http://code.openbravo.com/erp/mods/org.openbravo.userinterface.smartclient.dev/rev/b9755214276fc0cfa449b512883188e6dbdbb1d0 [^]

Related to bug 30507:On a field on grid edit mode the value is not selected

---
M web/org.openbravo.userinterface.smartclient/isomorphic/client/widgets/form/FormItem.js
M web/org.openbravo.userinterface.smartclient/isomorphic/client/widgets/form/TextItem.js
M web/org.openbravo.userinterface.smartclient/isomorphic/system/development/ISC_Forms.js
M web/org.openbravo.userinterface.smartclient/isomorphic/system/modules-debug/ISC_Forms.js
M web/org.openbravo.userinterface.smartclient/isomorphic/system/modules/ISC_Forms.js
---
(0080599)
hgbot (developer)
2015-09-24 09:54

Repository: erp/devel/pi
Changeset: 6b358e197d0814f25e76654c63192d902484a4c5
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Sep 24 09:51:56 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/6b358e197d0814f25e76654c63192d902484a4c5 [^]

Fixes bug 30507:Clicking on a field on grid edit mode the value is not selected

The problem was when editing a row on grid view if you click on a field the value
is not selected. It is a regression in Smartclient library.

To resolve this problem it has been included the code of Smartclient that fixes
Smartclient's regression. Besides another minor problem it has been detected in
Smartclient library. It has been resolved this problem too.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-date.js
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/reference/UIDefinition.java
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/isomorphic/ISC_Combined.js
---
(0080623)
inigosanchez (developer)
2015-09-24 17:18

Added test suite in TestLink [1]: Platform > [TST] Text Selection Test



[1] https://testlink.openbravo.com/testlink [^]
(0080627)
hudsonbot (developer)
2015-09-24 17:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/37e30a4ff711 [^]
Maturity status: Test
(0080632)
alostale (developer)
2015-09-25 08:59

* Code review:
 - Reviewed code in smartclient.dev (backported from latest SC dev code)
 - Reviewed ISC_Combined.js diff to check all chunks in smartclient.dev are correctly ported and uglified. To do it comparison after beautification has been performed (see attached isc-combined-beautified.diff)

* Tested
  - Grid edition for different references
    - Clicking on fields in the currently edited row selects field values (inlcuding text, FK selectors, dates, numeric values including 0, etc.)
    - Clicking on fields in another record select the value
    - Moving with tab key to another field selects the value
  - Form edition for different references
    - Moving with tab key to another field selects the value
    - Clicking on another field places the cursor in the position the click was done, but the value does not get selected

- Issue History
Date Modified Username Field Change
2015-08-06 12:25 mfuertes New Issue
2015-08-06 12:25 mfuertes Assigned To => platform
2015-08-06 12:25 mfuertes Modules => Core
2015-08-06 12:25 mfuertes Triggers an Emergency Pack => No
2015-08-06 14:09 egoitz Regression level => Production - Confirmed Stable
2015-08-06 14:09 egoitz Regression introduced in release => 3.0PR15Q1
2015-08-06 14:09 egoitz Type feature request => defect
2015-08-06 14:09 egoitz Summary Loose of selected focus when single click a field in grid editing mode. => When clicking on a field on edit mode on the grid the value is not selected
2015-08-06 14:09 egoitz Description Updated View Revisions
2015-08-06 14:09 egoitz Issue Monitored: egoitz
2015-08-06 14:10 egoitz Reproducibility have not tried => always
2015-08-06 17:00 alostale Assigned To platform => inigosanchez
2015-08-06 17:00 alostale Status new => acknowledged
2015-08-06 17:00 alostale Priority normal => immediate
2015-08-06 17:01 alostale Regression introduced in release 3.0PR15Q1 => 3.0PR14Q2
2015-08-06 17:02 alostale Note Added: 0079232
2015-08-06 17:02 alostale Relationship added caused by 0025574
2015-08-07 08:10 inigosanchez Status acknowledged => scheduled
2015-08-07 08:47 alostale Status scheduled => feedback
2015-08-07 08:48 alostale Status feedback => new
2015-08-07 08:49 alostale Status new => scheduled
2015-08-07 12:20 inigosanchez Regression date => 2014-02-26
2015-08-07 12:20 inigosanchez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/20eb3426d990 [^]
2015-08-11 13:22 alostale Note Added: 0079313
2015-08-17 12:53 inigosanchez Note Added: 0079389
2015-08-17 12:53 inigosanchez Status scheduled => feedback
2015-08-17 13:09 inigosanchez Status feedback => scheduled
2015-09-16 17:57 inigosanchez Relationship added blocks 0030846
2015-09-24 09:52 hgbot Checkin
2015-09-24 09:52 hgbot Note Added: 0080598
2015-09-24 09:53 inigosanchez Review Assigned To => alostale
2015-09-24 09:54 hgbot Checkin
2015-09-24 09:54 hgbot Note Added: 0080599
2015-09-24 09:54 hgbot Status scheduled => resolved
2015-09-24 09:54 hgbot Resolution open => fixed
2015-09-24 09:54 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/6b358e197d0814f25e76654c63192d902484a4c5 [^]
2015-09-24 17:18 inigosanchez Note Added: 0080623
2015-09-24 17:29 hudsonbot Checkin
2015-09-24 17:29 hudsonbot Note Added: 0080627
2015-09-25 08:51 alostale File Added: isc-combined-beautified.diff
2015-09-25 08:59 alostale Note Added: 0080632
2015-09-25 08:59 alostale Status resolved => closed
2015-09-25 08:59 alostale Fixed in Version => 3.0PR15Q4
2015-10-29 10:20 alostale Relationship added related to 0031274
2015-11-04 19:40 caristu Relationship added related to 0031365


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker