Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030458
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2015-07-30 10:022015-08-20 23:16
ReporterinigosanchezView Statuspublic 
Assigned Toinigosanchez 
PrioritylowResolutionfixedFixed in Version3.0PR15Q4
StatusclosedFix in branchFixed in SCM revisiond10e8d819216
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030458: Error information is hidden when a module scripts fails

DescriptionError information is hidden when a modulescript fails. When applying the modulescript and fails the method handleError() is thrown. This method hides information.
Steps To ReproduceSee example of error log [1]:


     [java] 142457 INFO - Executing moduleScript: org.openbravo.modulescript.HBFix
     [java] 142469 INFO - Executing moduleScript: org.openbravo.modulescript.InitializeAcctDimensionsInClient
     [java] 142474 ERROR - Error executing moduleScript org.openbravo.modulescript.InitializeAcctDimensionsInClient: null
     [java] 142480 ERROR - Error executing moduleScript: org.openbravo.modulescript.InitializeAcctDimensionsInClient
     [java] java.lang.reflect.InvocationTargetException
     [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
     [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
     [java] at java.lang.reflect.Method.invoke(Method.java:616)
     [java] at org.openbravo.modulescript.ModuleScriptHandler.callExecute(ModuleScriptHandler.java:78)
     [java] at org.openbravo.modulescript.ModuleScriptHandler.execute(ModuleScriptHandler.java:66)
     [java] at org.openbravo.ddlutils.task.AlterDatabaseDataAll.doExecute(AlterDatabaseDataAll.java:187)
     [java] at org.openbravo.ddlutils.task.BaseDatabaseTask.execute(BaseDatabaseTask.java:86)
     [java] at org.openbravo.ddlutils.task.AlterDatabaseJava.main(AlterDatabaseJava.java:44)


[1]. http://ci.openbravo.com/view/try/job/try-upgrade-pgsql/2574/artifact/log/20150729160433-apply.log [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0079121)
hgbot (developer)
2015-07-30 10:55

Repository: erp/devel/pi
Changeset: d10e8d819216cb2f3e0ed0326d5d12b76b0bbe08
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Jul 30 10:50:41 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d10e8d819216cb2f3e0ed0326d5d12b76b0bbe08 [^]

Fixed issue 30458: Error information is hidden when a modulescript fails

The problem was that error information is hidden when a modulescript fails. Now it has
been showed more information when a handleError() method is thrown.

---
M src-core/src/org/openbravo/modulescript/ModuleScript.java
---
(0079129)
alostale (developer)
2015-07-30 12:59

code reviewed

tested by executing same try than before, now with stack information:


     [java] 145785 ERROR - Error executing moduleScript org.openbravo.modulescript.InitializeAcctDimensionsInClient: null
     [java] java.lang.NullPointerException
     [java] at org.openbravo.database.ConnectionProviderImpl.getNewConnection(ConnectionProviderImpl.java:260)
     [java] at org.openbravo.database.ConnectionProviderImpl.getTransactionConnection(ConnectionProviderImpl.java:334)
     [java] at org.openbravo.database.CPStandAlone.getTransactionConnection(CPStandAlone.java:67)
     [java] at org.openbravo.modulescript.InitializeAcctDimensionsInClient.execute(InitializeAcctDimensionsInClient.java:35)
     [java] at org.openbravo.modulescript.ModuleScript.doExecute(ModuleScript.java:46)
     [java] at org.openbravo.modulescript.ModuleScript.preExecute(ModuleScript.java:61)
     [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
     [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
     [java] at java.lang.reflect.Method.invoke(Method.java:616)
     [java] at org.openbravo.modulescript.ModuleScriptHandler.callExecute(ModuleScriptHandler.java:78)
     [java] at org.openbravo.modulescript.ModuleScriptHandler.execute(ModuleScriptHandler.java:66)
     [java] at org.openbravo.ddlutils.task.AlterDatabaseDataAll.doExecute(AlterDatabaseDataAll.java:184)
     [java] at org.openbravo.ddlutils.task.BaseDatabaseTask.execute(BaseDatabaseTask.java:86)
     [java] at org.openbravo.ddlutils.task.AlterDatabaseJava.main(AlterDatabaseJava.java:44)
(0079511)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-07-30 10:02 inigosanchez New Issue
2015-07-30 10:02 inigosanchez Assigned To => platform
2015-07-30 10:02 inigosanchez Modules => Core
2015-07-30 10:02 inigosanchez Triggers an Emergency Pack => No
2015-07-30 10:43 inigosanchez Assigned To platform => inigosanchez
2015-07-30 10:43 inigosanchez Status new => scheduled
2015-07-30 10:50 inigosanchez Issue Monitored: alostale
2015-07-30 10:54 inigosanchez Review Assigned To => alostale
2015-07-30 10:55 hgbot Checkin
2015-07-30 10:55 hgbot Note Added: 0079121
2015-07-30 10:55 hgbot Status scheduled => resolved
2015-07-30 10:55 hgbot Resolution open => fixed
2015-07-30 10:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d10e8d819216cb2f3e0ed0326d5d12b76b0bbe08 [^]
2015-07-30 12:59 alostale Note Added: 0079129
2015-07-30 12:59 alostale Status resolved => closed
2015-07-30 12:59 alostale Fixed in Version => 3.0PR15Q4
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079511


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker