Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030435
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Retail Modules] Web POSmajoralways2015-07-27 14:432015-07-30 13:25
ReporterOrekariaView Statuspublic 
Assigned ToOrekaria 
PrioritynormalResolutionfixedFixed in VersionRR15Q2.3
StatusclosedFix in branchFixed in SCM revisionc6fab3b36216
ProjectionnoneETAnoneTarget VersionRR15Q2.3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030435: The 'syncAllModels ' process is reporting that the server synchronization has finished before the client has been updated

DescriptionThe synchronization is executing the success callbacks before the last stage of the synchronization, that is, updating the client tables, has been done.
Steps To ReproduceIn the 'ob-terminal-model.js' file, 'removeSyncedElemsCallback' method, verify that the models are being asynchronously flushed
TagsNo tags attached.
Attached Filespatch file icon 1319.patch [^] (2,225 bytes) 2015-07-27 14:44 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0030433RR15Q4 closedOrekaria The 'syncAllModels ' process is reporting that the server synchronization has finished before the client has been updated 

-  Notes
(0079118)
Orekaria (administrator)
2015-07-29 17:10

Please note that the attached patch is not the solution, but a prevention of the consequences
(0079126)
hgbot (developer)
2015-07-30 11:17

Repository: retail/backports/3.0RR15Q2.3/org.openbravo.mobile.core
Changeset: c6fab3b362164c0c557ae67442e95702f0f5f45d
Author: Rafa Alonso <ral <at> openbravo.com>
Date: Thu Jul 30 11:16:49 2015 +0200
URL: http://code.openbravo.com/retail/backports/3.0RR15Q2.3/org.openbravo.mobile.core/rev/c6fab3b362164c0c557ae67442e95702f0f5f45d [^]

Fixes issue 30435: Update only the 'isBeingProcessed' field when synchronized

---
M web/org.openbravo.mobile.core/source/model/ob-terminal-model.js
---
(0079130)
guilleaer (developer)
2015-07-30 13:25

Here I'm explain all the details that I've about this issue, which as explained above is not completely resolved but it is prevented by this fix.

The issue was detected because the cashup table, being more specific total retail transactions field suddenly is updated to a previous status. It creates a big problem because calculated total retail transactions are not OK.

According to the information that we have saw thanks to the logs included in customer, we know that when we recover the connectivity after a offline period this issue is more reproducible than in other scenarios.

This issue will be closed, because the problem is fixed, but some analysis should be done there to ensure that we are doing that we want during the synchronization.

- Issue History
Date Modified Username Field Change
2015-07-27 14:44 Orekaria Type defect => backport
2015-07-27 14:44 Orekaria Target Version => RR15Q2.3
2015-07-27 14:44 Orekaria File Added: 1319.patch
2015-07-27 14:51 Orekaria Summary The 'syncAllModels ' process is reporting that the server synchronization has finished before it has actually finished => The 'syncAllModels ' process is reporting that the server synchronization has finished before the client has been updated
2015-07-29 17:10 Orekaria Note Added: 0079118
2015-07-30 11:17 hgbot Checkin
2015-07-30 11:17 hgbot Note Added: 0079126
2015-07-30 11:17 hgbot Status scheduled => resolved
2015-07-30 11:17 hgbot Resolution open => fixed
2015-07-30 11:17 hgbot Fixed in SCM revision => http://code.openbravo.com/retail/backports/3.0RR15Q2.3/org.openbravo.mobile.core/rev/c6fab3b362164c0c557ae67442e95702f0f5f45d [^]
2015-07-30 13:25 guilleaer Review Assigned To => guilleaer
2015-07-30 13:25 guilleaer Note Added: 0079130
2015-07-30 13:25 guilleaer Status resolved => closed
2015-07-30 13:25 guilleaer Fixed in Version => RR15Q2.3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker