Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030425
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Multi order paymentmajoralways2015-07-25 13:022015-09-18 13:21
ReporterlorenzofidalgoView Statuspublic 
Assigned Tojorge-garcia 
PriorityimmediateResolutionfixedFixed in VersionRR15Q4
StatusclosedFix in branchFixed in SCM revisionc2f4e4836b52
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned Toguilleaer
Regression levelPackaging and release
Regression date
Regression introduced in releasemain
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030425: Partial payments in a layaway through "Pay Open Tickets" option does not save Received & Outstanding fields correctly

DescriptionTo pay a layaway partially through "Pay Open Tickets" option records wrongly data in backend.
In RR15Q2.2 this is working correcly.
Steps To Reproduce1-Login POS as vallblanca//openbravo.
2-Add 1x "Avalanche transceiver".
3-In dropdown menu, click "Layaway this receipt", click Total Amount button and click in "Layaway" button to layaway that receipt.
4-Click "Pay Open Tickets" option in dropdown menu, select the just created layaway and click "Done".
5-Click in the line of the product and when the "Amount to layaway" popup appears, enter 20 and apply. Then click Ok (tick) button and click Done button.
6-Go to POS backend and login with Openbravo//openbravo.
7-Using "The White Vally Group Admin" role go to "Sales Order" window and select the just created record.
8-Defect: In "Payment Plan" tab, check "Received" & "Outstanding" fields are wrong.
TagsNo tags attached.
Attached Filespng file icon WrongReceived+OutstandingAmounts.png [^] (34,575 bytes) 2015-07-25 13:02

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0030536RR15Q3 closedRetail [RR15Q3] Partial payments in a layaway through "Pay Open Tickets" option does not save Received & Outstanding fields correctly 
depends on backport 0030696RR15Q3.2 closedjorge-garcia [RR15Q3] Partial payments in a layaway through "Pay Open Tickets" option does not save Received & Outstanding fields correctly 

-  Notes
(0079281)
hgbot (developer)
2015-08-10 14:00

Repository: tools/automation/pi-mobile
Changeset: 8c0e3ae408596ef3da3633ec762664a0e6509c63
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Fri Aug 07 12:43:50 2015 +0200
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/8c0e3ae408596ef3da3633ec762664a0e6509c63 [^]

Verifies issue 30425: Added Test I30425_PartialPaymentLayaway

---
M src-test/org/openbravo/test/mobile/common/selenium/javascript/TestId.java
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/layaway/I30425_PartialPaymentLayaway.java
---
(0079293)
hgbot (developer)
2015-08-11 08:45

Repository: retail/backports/3.0RR15Q3/org.openbravo.retail.posterminal
Changeset: 3120318ef49ae1c68784ba804cc3672bb7c36b1e
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Tue Aug 11 08:38:57 2015 +0200
URL: http://code.openbravo.com/retail/backports/3.0RR15Q3/org.openbravo.retail.posterminal/rev/3120318ef49ae1c68784ba804cc3672bb7c36b1e [^]

Fixed issue 30536: Partial payments in layaway through "Pay Open Tickets" option

Backport for the issue 30425

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0079365)
hgbot (developer)
2015-08-14 17:25

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: f4354d4ba3340b58d1534c8859e9faf317a370a4
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Tue Aug 11 08:38:57 2015 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f4354d4ba3340b58d1534c8859e9faf317a370a4 [^]

Fixes issue 30425: Partial payments in layaway through "Pay Open Tickets" option

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0079796)
marvintm (developer)
2015-08-28 14:11

The fix for this issue is not correct. Instead of modifying the main execution path, it must be checked why the layaway specific flags are not set correctly.
(0080117)
hgbot (developer)
2015-09-04 13:29

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: f468a3fba7d67334cd3748c96026688e77d2d4fd
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Mon Aug 31 08:34:54 2015 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f468a3fba7d67334cd3748c96026688e77d2d4fd [^]

Backout issue 30425

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0080118)
hgbot (developer)
2015-09-04 13:29

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: a5224d35df572aeb927a33ebe99bac035d3d5c61
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Thu Sep 03 10:44:42 2015 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/a5224d35df572aeb927a33ebe99bac035d3d5c61 [^]

Fixes issue 30425: Partial payments in layaway through "Pay Open Tickets" option

The problem was that the partial payment of a layaway always creates a new
order, not taken into account that there is already a order created with the
same id and attributes.

The solution is to modify the newLayaway parameter to represent what it means in
the flow.

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0080149)
hgbot (developer)
2015-09-05 12:57

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: bdb5e63db53c648db73a20ddc8ebbf5203fd44e9
Author: Rafa Alonso <ral <at> openbravo.com>
Date: Sat Sep 05 12:06:47 2015 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/bdb5e63db53c648db73a20ddc8ebbf5203fd44e9 [^]

Backed out issue 30425, changeset: a5224d35df57. Integration failing.

affected processes can be reproduced with these tests:
- I25623_VerifiedReturnsAvoidMoreThanOrdered
- I29152_NoCashAvailableWhenVoidingALayaway
- I30075_NoPositiveLinesInReturnTickets
- Layaway_Cre1Par1Fin2
- LayawayVerifyPaymentsInformation

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0080150)
Orekaria (administrator)
2015-09-05 12:58

See the note of the back out
(0080152)
hgbot (developer)
2015-09-05 19:54

Repository: tools/automation/pi-mobile
Changeset: 8628deb81e2f749ce7a0c2eb78e5c4c87f3e424c
Author: Rafa Alonso <ral <at> openbravo.com>
Date: Sat Sep 05 16:39:45 2015 +0200
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/8628deb81e2f749ce7a0c2eb78e5c4c87f3e424c [^]

Related to issue 30425: The related test has been deactivated until the fix is ready

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/layaway/I30425_PartialPaymentLayaway.java
---
(0080250)
hgbot (developer)
2015-09-08 20:33

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: c2f4e4836b52fe4d033e69c67e1eabd4508c4a79
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Mon Sep 07 11:23:39 2015 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/c2f4e4836b52fe4d033e69c67e1eabd4508c4a79 [^]

Fixes issue 30425: Partial payments in layaway through "Pay Open Tickets" option

The problem was that the partial payment of a layaway always creates a new
order, not taken into account that there is already a order created with the
same id and attributes.

The solution is to create a new check to see if the layaway is partially paid.

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0080493)
guilleaer (developer)
2015-09-18 13:21

Tested and code review done

- Issue History
Date Modified Username Field Change
2015-07-25 13:02 lorenzofidalgo New Issue
2015-07-25 13:02 lorenzofidalgo Assigned To => Retail
2015-07-25 13:02 lorenzofidalgo File Added: WrongReceived+OutstandingAmounts.png
2015-07-25 13:02 lorenzofidalgo Regression level => Packaging and release
2015-07-25 13:02 lorenzofidalgo Regression introduced in release => RR15Q2.2
2015-07-25 13:02 lorenzofidalgo Triggers an Emergency Pack => No
2015-07-28 10:30 lorenzofidalgo Regression introduced in release RR15Q2.2 => main
2015-08-10 13:45 jorge-garcia Status new => scheduled
2015-08-10 14:00 hgbot Checkin
2015-08-10 14:00 hgbot Note Added: 0079281
2015-08-11 08:45 hgbot Checkin
2015-08-11 08:45 hgbot Note Added: 0079293
2015-08-14 17:25 hgbot Checkin
2015-08-14 17:25 hgbot Note Added: 0079365
2015-08-14 17:25 hgbot Status scheduled => resolved
2015-08-14 17:25 hgbot Resolution open => fixed
2015-08-14 17:25 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f4354d4ba3340b58d1534c8859e9faf317a370a4 [^]
2015-08-28 12:28 marvintm Assigned To Retail => jorge-garcia
2015-08-28 14:11 marvintm Note Added: 0079796
2015-08-28 14:11 marvintm Status resolved => new
2015-08-28 14:11 marvintm Resolution fixed => open
2015-08-28 14:11 marvintm Status new => scheduled
2015-09-04 13:29 hgbot Checkin
2015-09-04 13:29 hgbot Note Added: 0080117
2015-09-04 13:29 hgbot Checkin
2015-09-04 13:29 hgbot Note Added: 0080118
2015-09-04 13:29 hgbot Status scheduled => resolved
2015-09-04 13:29 hgbot Resolution open => fixed
2015-09-04 13:29 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f4354d4ba3340b58d1534c8859e9faf317a370a4 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/a5224d35df572aeb927a33ebe99bac035d3d5c61 [^]
2015-09-05 12:57 hgbot Checkin
2015-09-05 12:57 hgbot Note Added: 0080149
2015-09-05 12:58 Orekaria Note Added: 0080150
2015-09-05 12:58 Orekaria Status resolved => new
2015-09-05 12:58 Orekaria Resolution fixed => open
2015-09-05 19:54 hgbot Checkin
2015-09-05 19:54 hgbot Note Added: 0080152
2015-09-07 11:26 jorge-garcia Summary [RR15Q3] Partial payments in a layaway through "Pay Open Tickets" option does not save Received & Outstanding fields correctly => Partial payments in a layaway through "Pay Open Tickets" option does not save Received & Outstanding fields correctly
2015-09-08 20:33 hgbot Checkin
2015-09-08 20:33 hgbot Note Added: 0080250
2015-09-08 20:33 hgbot Status new => resolved
2015-09-08 20:33 hgbot Resolution open => fixed
2015-09-08 20:33 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/a5224d35df572aeb927a33ebe99bac035d3d5c61 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/c2f4e4836b52fe4d033e69c67e1eabd4508c4a79 [^]
2015-09-18 12:23 guilleaer Review Assigned To => guilleaer
2015-09-18 13:21 guilleaer Note Added: 0080493
2015-09-18 13:21 guilleaer Status resolved => closed
2015-09-18 13:21 guilleaer Fixed in Version => RR15Q4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker