Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030331
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Retail Modules] Web POSmajorhave not tried2015-07-08 09:152015-07-28 15:25
ReporterguilleaerView Statuspublic 
Assigned Toguilleaer 
PrioritynormalResolutionfixedFixed in VersionRR15Q2.3
StatusclosedFix in branchFixed in SCM revision5cee3fb1550f
ProjectionnoneETAnoneTarget VersionRR15Q2.3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToOrekaria
Regression level
Regression date
Regression introduced in releaseRR15Q1
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/542f6f37e91e4a41a9c8346d15819e299847e463 [^]
Triggers an Emergency PackNo
Summary

0030331: Error Importing orders caused by the organization of the userContact of the order

DescriptionSometimes some orders are not processed because the organization of the user which is set in the order as userContact is not in the natural tree.
Steps To ReproduceUsing a BP create a contect (user) in a organization which is not in the natural tree.

Then in web pos, create an order for that bp and process it.
The order will appear in "Errors" window.
Proposed SolutionThis value only should be set if the organization of the user is in the natural tree.
TagsNo tags attached.
Attached Filesdiff file icon diffIssue30329_15Q22.diff [^] (1,715 bytes) 2015-07-08 09:49 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0030329RR15Q4 closedguilleaer Error Importing orders caused by the organization of the userContact of the order 

-  Notes
(0078740)
guilleaer (developer)
2015-07-08 09:50

attached fix for 15q2.2
(0078842)
hgbot (developer)
2015-07-16 09:57

Repository: retail/backports/3.0RR15Q2.3/org.openbravo.retail.posterminal
Changeset: 5cee3fb1550f8808f279b676e4ea84b9f4fdc95a
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Thu Jul 16 09:56:59 2015 +0200
URL: http://code.openbravo.com/retail/backports/3.0RR15Q2.3/org.openbravo.retail.posterminal/rev/5cee3fb1550f8808f279b676e4ea84b9f4fdc95a [^]

Fixed issue 30331. Fixed the way the user contact is being found for a given business partner.

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---

- Issue History
Date Modified Username Field Change
2015-07-08 09:49 guilleaer Type defect => backport
2015-07-08 09:49 guilleaer Target Version RR15Q4 => RR15Q2.3
2015-07-08 09:49 guilleaer File Added: diffIssue30329_15Q22.diff
2015-07-08 09:50 guilleaer Note Added: 0078740
2015-07-16 09:57 hgbot Checkin
2015-07-16 09:57 hgbot Note Added: 0078842
2015-07-16 09:57 hgbot Status scheduled => resolved
2015-07-16 09:57 hgbot Resolution open => fixed
2015-07-16 09:57 hgbot Fixed in SCM revision => http://code.openbravo.com/retail/backports/3.0RR15Q2.3/org.openbravo.retail.posterminal/rev/5cee3fb1550f8808f279b676e4ea84b9f4fdc95a [^]
2015-07-28 15:25 Orekaria Review Assigned To => Orekaria
2015-07-28 15:25 Orekaria Status resolved => closed
2015-07-28 15:25 Orekaria Fixed in Version => RR15Q2.3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker