Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030302
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 09. Financial managementmajoralways2015-06-29 12:542015-07-06 12:05
ReportermaiteView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisione40aef398b22
ProjectionnoneETAnoneTarget Version3.0PR15Q2.3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesAdvanced Payables and Receivables Mngmt
Regression levelProduction - QA Approved
Regression date2015-01-13
Regression introduced in release3.0PR15Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/368eb470c2955fb9525c9e529591c2699122ef21 [^]
Triggers an Emergency PackNo
Summary

0030302: "Not Balance" error received when posting a transaction (although suspense balancing is not needed)

Description"Not Balance" error received when posting a transaction (although suspense balancing is not needed)
Steps To Reproduce1. Access General Ledger Configuration window and General Accounts tab and leave "Suspense Balancing" field empty and uncheck "Suspense Balancing use" for EspaƱa and International ledgers
2. Access "Cuenta de Banco" financial account and search Transaction with Line no 4800. Unpost transaction
3. Post transaction again and "Not Balanced" error will be raised

If you come back to General Ledger Configuration and mark "Suspense Balancing Use" and then try to post Transaction again it will be correctly posted (not using suspense balancing account)
Proposed Solution1. Revert changeset https://code.openbravo.com/erp/devel/pi/rev/368eb470c2955fb9525c9e529591c2699122ef21 [^]

2. Replace this piece of code in DocFINFinAccTransaction.getBalance()

    // if payment IN/OUT is in Multi-Currency then get Multi-Currency amount field because
    // FIN_Payment line amount is in that currency.
    if (payment != null) {
      if (!payment.getAccount().getCurrency().getId()
          .equalsIgnoreCase(payment.getCurrency().getId())) {
        retValue = payment.getAmount();
      }
    }

by

    // if payment IN/OUT is in Multi-Currency then get Multi-Currency amount field because
    // FIN_Payment line amount is in that currency.
    if (payment != null) {
      if (!payment.getAccount().getCurrency().getId()
          .equalsIgnoreCase(payment.getCurrency().getId())) {
        retValue = payment.isReceipt() ? payment.getAmount() : payment.getAmount().negate();
      }
    }
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00302733.0PR15Q4 closedAtulOpenbravo "Not Balance" error received when posting a transaction (although suspense balancing is not needed) 

-  Notes
(0078667)
hgbot (developer)
2015-07-06 12:04

Repository: erp/backports/3.0PR15Q2.3
Changeset: e40aef398b22ccdee36e1d523022904e1a1ebdee
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Thu Jul 02 22:07:27 2015 +0530
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2.3/rev/e40aef398b22ccdee36e1d523022904e1a1ebdee [^]

Fixes Issue 30302:"Not Balance" error received when posting a transaction
(although suspense balancing is not needed)

Fix takes into account the payment's sign (payment in/out).

---
M src/org/openbravo/erpCommon/ad_forms/DocFINFinAccTransaction.java
---
(0078670)
vmromanos (developer)
2015-07-06 12:05

Code review + testing OK

- Issue History
Date Modified Username Field Change
2015-07-02 12:41 vmromanos Type defect => backport
2015-07-02 12:41 vmromanos Target Version 3.0PR15Q4 => 3.0PR15Q2.3
2015-07-02 19:26 dmitry_mezentsev Tag Attached: Approved
2015-07-06 12:04 hgbot Checkin
2015-07-06 12:04 hgbot Note Added: 0078667
2015-07-06 12:04 hgbot Status scheduled => resolved
2015-07-06 12:04 hgbot Resolution open => fixed
2015-07-06 12:04 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q2.3/rev/e40aef398b22ccdee36e1d523022904e1a1ebdee [^]
2015-07-06 12:05 vmromanos Review Assigned To => vmromanos
2015-07-06 12:05 vmromanos Note Added: 0078670
2015-07-06 12:05 vmromanos Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker