Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030272
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Retail Modules] Web POSmajorhave not tried2015-06-29 12:442015-07-30 15:24
ReportermarvintmView Statuspublic 
Assigned Tojorge-garcia 
PrioritynormalResolutionout of dateFixed in VersionRR15Q2.3
StatusclosedFix in branchFixed in SCM revisiona522db26b2f1
ProjectionnoneETAnoneTarget VersionRR15Q2.3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToOrekaria
Regression levelProduction - Confirmed Stable
Regression date
Regression introduced in releaseRR14Q3
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030272: Preferences are not reloaded when loging in the Web POS

DescriptionWhen the user logs in the Web POS, the terminal object (which includes some configuration information, like the values for the preferences) should be reloaded. However, this doesn't happen in case the incremental masterdata refresh is not activated.

This forces the user to clear the cache if he wants to see any configuration change, such as changes in the preferences definition.
Steps To Reproduce- Log in the Web POS
- Change some preference value in the backend (such as approvals, or any other configuration)
- Log in again in the Web POS. Verify that the new value is not used.
- Clear the cache. Log in again in the Web POS. Verify that the new value is used.
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0030271RR16Q1 closedjorge-garcia Preferences are not reloaded when loging in the Web POS 

-  Notes
(0079005)
hgbot (developer)
2015-07-21 11:54

Repository: retail/backports/3.0RR15Q2.3/org.openbravo.mobile.core
Changeset: a522db26b2f1344a17d96aca30736b65d5379675
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Tue Jul 21 11:52:21 2015 +0200
URL: http://code.openbravo.com/retail/backports/3.0RR15Q2.3/org.openbravo.mobile.core/rev/a522db26b2f1344a17d96aca30736b65d5379675 [^]

Fixed issue 30272: Preferences are not reloaded when login in the Web POS

The problem was that the terminal information is not loaded from backend if
it's set the fully refresh of the terminal.

The solution is to check if there is a fully refresh, and if so, force the
refreshment of the terminal's information from the backend.

Backport for 3.0RR15Q2.3

---
M web/org.openbravo.mobile.core/source/model/ob-terminal-model.js
---
(0079085)
guilleaer (developer)
2015-07-27 17:29

Tested and Verified
(0079127)
hgbot (developer)
2015-07-30 11:27

Repository: retail/backports/3.0RR15Q2.3/org.openbravo.mobile.core
Changeset: 8ebb803a0545313e24ed822fc4a0f4fb0a52a9a1
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Thu Jul 30 11:24:39 2015 +0200
URL: http://code.openbravo.com/retail/backports/3.0RR15Q2.3/org.openbravo.mobile.core/rev/8ebb803a0545313e24ed822fc4a0f4fb0a52a9a1 [^]

Related to issue 30272: Preferences are not reloaded when login in the Web POS

A change is necessary to stabilization of the retail tests.

---
M web/org.openbravo.mobile.core/source/model/ob-terminal-model.js
---
(0079132)
Orekaria (administrator)
2015-07-30 14:55

When this test is executed several times in a row, the integration reports an issue related to the OB.Format object not being loaded
(0079133)
hgbot (developer)
2015-07-30 15:22

Repository: retail/backports/3.0RR15Q2.3/org.openbravo.mobile.core
Changeset: e204c806d03516c240539d678398a9189d753cbb
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Thu Jul 30 15:21:31 2015 +0200
URL: http://code.openbravo.com/retail/backports/3.0RR15Q2.3/org.openbravo.mobile.core/rev/e204c806d03516c240539d678398a9189d753cbb [^]

Backout issue 30272

Need to investigate futher for stabilization in tests.

---
M web/org.openbravo.mobile.core/source/model/ob-terminal-model.js
---
(0079134)
Orekaria (administrator)
2015-07-30 15:24

This issue will not be backported to Q2.3

- Issue History
Date Modified Username Field Change
2015-06-29 12:44 marvintm Type defect => backport
2015-06-29 12:44 marvintm Target Version RR15Q3 => RR15Q2.3
2015-06-29 14:02 dmitry_mezentsev Tag Attached: Approved
2015-07-15 11:18 marvintm Description Updated View Revisions
2015-07-21 11:54 hgbot Checkin
2015-07-21 11:54 hgbot Note Added: 0079005
2015-07-21 11:54 hgbot Status scheduled => resolved
2015-07-21 11:54 hgbot Resolution open => fixed
2015-07-21 11:54 hgbot Fixed in SCM revision => http://code.openbravo.com/retail/backports/3.0RR15Q2.3/org.openbravo.mobile.core/rev/a522db26b2f1344a17d96aca30736b65d5379675 [^]
2015-07-21 11:55 jorge-garcia Assigned To Retail => jorge-garcia
2015-07-27 17:29 guilleaer Review Assigned To => guilleaer
2015-07-27 17:29 guilleaer Note Added: 0079085
2015-07-27 17:29 guilleaer Status resolved => closed
2015-07-27 17:29 guilleaer Fixed in Version => RR15Q2.3
2015-07-29 12:27 jorge-garcia Status closed => new
2015-07-29 12:27 jorge-garcia Resolution fixed => open
2015-07-29 12:27 jorge-garcia Fixed in Version RR15Q2.3 =>
2015-07-30 11:25 jorge-garcia Status new => scheduled
2015-07-30 11:27 hgbot Checkin
2015-07-30 11:27 hgbot Note Added: 0079127
2015-07-30 11:29 Orekaria Status scheduled => resolved
2015-07-30 11:29 Orekaria Fixed in Version => RR15Q2.3
2015-07-30 11:29 Orekaria Resolution open => fixed
2015-07-30 11:29 Orekaria Review Assigned To guilleaer => Orekaria
2015-07-30 11:29 Orekaria Status resolved => closed
2015-07-30 14:55 Orekaria Note Added: 0079132
2015-07-30 14:55 Orekaria Status closed => new
2015-07-30 14:55 Orekaria Resolution fixed => open
2015-07-30 14:55 Orekaria Fixed in Version RR15Q2.3 =>
2015-07-30 15:22 hgbot Checkin
2015-07-30 15:22 hgbot Note Added: 0079133
2015-07-30 15:24 Orekaria Note Added: 0079134
2015-07-30 15:24 Orekaria Status new => closed
2015-07-30 15:24 Orekaria Resolution open => out of date
2015-07-30 15:24 Orekaria Fixed in Version => RR15Q2.3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker