Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030267
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Retail Modules] Web POSminoralways2015-06-26 14:382015-07-27 14:14
ReportermalsasuaView Statuspublic 
Assigned Tojorge-garcia 
PriorityimmediateResolutionfixedFixed in VersionRR15Q2.3
StatusclosedFix in branchFixed in SCM revision00453ebc1a4e
ProjectionnoneETAnoneTarget VersionRR15Q2.3
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression levelProduction - Confirmed Stable
Regression date2014-11-06
Regression introduced in releaseRR15Q1
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/9b8a8c54fe38 [^]
Triggers an Emergency PackNo
Summary

0030267: receipts search in WEB POS does not work with the char -

Descriptionwhen the document no of receipts contains the char - and in the string to search is introduced the char -, no receips are displayed
Steps To Reproduce. in backoffice, configure the posterminal with the prefix 1121-1/
. go to webpos
. create and paid a recetipt: documentno 1121-1/100000 is created
. go to search receipt:
search 1121-1
no receipts are displayed
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0030261 closedjorge-garcia receipts search in WEB POS does not work with the char - 

-  Notes
(0078937)
hgbot (developer)
2015-07-17 14:48

Repository: retail/backports/3.0RR15Q2.3/org.openbravo.retail.posterminal
Changeset: 00453ebc1a4e84764b0a95c7624fbe64f6cac7a9
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Fri Jul 17 14:47:51 2015 +0200
URL: http://code.openbravo.com/retail/backports/3.0RR15Q2.3/org.openbravo.retail.posterminal/rev/00453ebc1a4e84764b0a95c7624fbe64f6cac7a9 [^]

Fixed issue 30267. Receipts search in WEB POS does not work with the char -

The problem was that the search process removes the char '-' and the filter from
the sql doesn't work as expected. This is a security measure to avoid sql
injection.

The solution is to add named parameters and change the filter value in the sql
string.

Now the filter works fine.

---
M src/org/openbravo/retail/posterminal/PaidReceiptsHeader.java
---
(0078938)
hgbot (developer)
2015-07-17 14:49

Repository: retail/backports/3.0RR15Q2.3/org.openbravo.mobile.core
Changeset: 930378560152da7901b399fee25a1f30b3ef5083
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Fri Jul 17 14:49:17 2015 +0200
URL: http://code.openbravo.com/retail/backports/3.0RR15Q2.3/org.openbravo.mobile.core/rev/930378560152da7901b399fee25a1f30b3ef5083 [^]

Related to issue 30267. Needed changes in the ProcessHQLQuery

Some changes are necessary in the ProcessHQLQuery file.

It's needed to add the possibility to add named parameters.

---
M src/org/openbravo/mobile/core/process/ProcessHQLQuery.java
---
(0078940)
hgbot (developer)
2015-07-17 14:55

Repository: retail/backports/3.0RR15Q2.3/org.openbravo.retail.posterminal
Changeset: ecbbe2ac59b98a094810c98a735580932449909e
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Fri Jul 17 14:55:29 2015 +0200
URL: http://code.openbravo.com/retail/backports/3.0RR15Q2.3/org.openbravo.retail.posterminal/rev/ecbbe2ac59b98a094810c98a735580932449909e [^]

Related to issue 30267. Needed changes in the ProcessHQLQuery

sanitizeString process must be deleted

---
M src/org/openbravo/retail/posterminal/PaidReceiptsHeader.java
---
(0079082)
guilleaer (developer)
2015-07-27 14:14

tested and verified

- Issue History
Date Modified Username Field Change
2015-06-29 11:43 malsasua Type defect => backport
2015-06-29 11:43 malsasua Target Version => RR15Q2.3
2015-06-29 13:59 dmitry_mezentsev Tag Attached: Approved
2015-07-03 09:35 jorge-garcia Assigned To Retail => jorge-garcia
2015-07-17 14:48 hgbot Checkin
2015-07-17 14:48 hgbot Note Added: 0078937
2015-07-17 14:48 hgbot Status scheduled => resolved
2015-07-17 14:48 hgbot Resolution open => fixed
2015-07-17 14:48 hgbot Fixed in SCM revision => http://code.openbravo.com/retail/backports/3.0RR15Q2.3/org.openbravo.retail.posterminal/rev/00453ebc1a4e84764b0a95c7624fbe64f6cac7a9 [^]
2015-07-17 14:49 hgbot Checkin
2015-07-17 14:49 hgbot Note Added: 0078938
2015-07-17 14:55 hgbot Checkin
2015-07-17 14:55 hgbot Note Added: 0078940
2015-07-27 14:14 guilleaer Review Assigned To => guilleaer
2015-07-27 14:14 guilleaer Note Added: 0079082
2015-07-27 14:14 guilleaer Status resolved => closed
2015-07-27 14:14 guilleaer Fixed in Version => RR15Q2.3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker