Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030230
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 09. Financial managementcriticalalways2015-06-18 17:262015-07-08 11:26
ReporterVictorVillarView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision680dab707b0d
ProjectionnoneETAnoneTarget Version3.0PR15Q2.3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2015-04-07
Regression introduced in release3.0PR15Q1.3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/58b1503188be73811b4885798fae1d31bd337076 [^]
Triggers an Emergency PackYes
Summary

0030230: Wrong payment status under some circumstancies

DescriptionWrong payment status under some circumstancies.

If you are using Automatic Deposit: Yes - Execution Type: Automatic and Execution Process: Simple Execution Process in your payment method and you complete a Payment In (the same in Payment Out) the status is Payment Received and it is wrong, it should be Deposited not cleared
Steps To ReproduceConfigure the Payment method: Wire Transfer (see the screenshot attached):
Automatic Deposit: Yes - Execution Type: Automatic and Execution Process: Simple Execution Process

Go to Payment In window:
 Organization: US
 create a new one for Healthy Food Supermarkets
 Amount: 20
Click on Add details button.
   Add a GL Item and received amount: 20
Click on Done

Realise that the payment status is Payment Received and it is wrong, it should be Deposited not cleared.

The same is happening with Payments Outs.


Note: It is working fine with the following configuration:
 * Automatic deposit: Yes - Execution Type: Manual
 * Automatic deposit: Yes - Execution Type: Automatic - Execution process: Simple execution process - Deferred: yes


TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00302063.0PR15Q3 closedaferraz Wrong payment status under some circumstancies 

-  Notes
(0078468)
hgbot (developer)
2015-06-24 10:12

Repository: erp/backports/3.0PR15Q2.3
Changeset: 680dab707b0d875afbed0eac50209456fb957f98
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Tue Jun 23 12:52:47 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2.3/rev/680dab707b0d875afbed0eac50209456fb957f98 [^]

Fixes issue 30230: Wrong payment status under some circumstancies

comingFrom internal parameter in FIN_PaymentProcess.java was always setted to "TRANSACTION" instead of using received comingFrom value, when Automatic Deposit/Withdrawn was activated and execution type was Automatic and not Deferred.
Because of that, transaction was not created when creating a payment from Payment In or Payment Out with this configuration.

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_PaymentProcess.java
---
(0078471)
vmromanos (developer)
2015-06-24 10:14

Code review + testing OK

- Issue History
Date Modified Username Field Change
2015-06-23 12:57 aferraz Type defect => backport
2015-06-23 12:57 aferraz Target Version 3.0PR15Q3 => 3.0PR15Q2.3
2015-06-23 15:49 dmitry_mezentsev Tag Attached: Approved
2015-06-24 10:12 hgbot Checkin
2015-06-24 10:12 hgbot Note Added: 0078468
2015-06-24 10:12 hgbot Status scheduled => resolved
2015-06-24 10:12 hgbot Resolution open => fixed
2015-06-24 10:12 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q2.3/rev/680dab707b0d875afbed0eac50209456fb957f98 [^]
2015-06-24 10:14 vmromanos Review Assigned To => vmromanos
2015-06-24 10:14 vmromanos Note Added: 0078471
2015-06-24 10:14 vmromanos Status resolved => closed
2015-07-08 11:26 vmromanos Regression introduced in release main => 3.0PR15Q1.3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker