Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030143
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2015-06-09 18:082015-06-30 20:44
ReporterngarciaView Statuspublic 
Assigned Tovmromanos 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision7e2d0fb062fa
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesAdvanced Payables and Receivables Mngmt
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030143: It is not possible to deposit more than one payment at the same time after 3.0PR14Q4

DescriptionIt is not possible to deposit more than one payment at the same time after 3.0PR14Q4
Steps To ReproduceAs group admin role:
   Create a payment method and do not check the Automatic Deposit
   Add it to a Financial Account
   Create two Payment In with that Payment Method and process them without depositing them
   Go to Financial Account and create a new transaction
   Check you can only select one payment
   Prior to 3.0PR14Q4 the Add Transaction process was available, which allowed you to choose more than one payment and created one transaction for each payment
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00302063.0PR15Q3 closedaferraz Wrong payment status under some circumstancies 
related to feature request 0030372 closedvmromanos Add accounting date to Add Multiple Payments 

-  Notes
(0078384)
vmromanos (developer)
2015-06-19 08:51

Proposed solution: Create a P&E process where the user can select several payments at the same time. Create a transaction per payment selected in the payment's financial account
(0078385)
vmromanos (developer)
2015-06-19 09:19

Moved from design defect to defect
(0078501)
vmromanos (developer)
2015-06-25 11:55
edited on: 2015-06-25 11:56

Test plan I:
Go to Financial Account | Transaction
  Create a new record
  Open the Payment selector and write down all the payments that are displayed
  Revert the changes to the record
  Press the new "Add Multiple Payments" button
  Verify the payments displayed in the P&E are exactly the same as in the payment selector



Test plan II:
Go to Payment In window.
Create a new record
  BP: Alimentos
  Payment method: Cheque
Press add details:
  Add a new GL Item with any received amount
Process the payment (do not deposit!)

Go to Payment Out window
Create a new record
  BP: Bebidas
  Payment Method: Cheque
Press add details:
  Add a new GL Item with any paid out amount
Process the payment (do not withdrawal!)

Go to Financial Account
Select Cuenta de Banco
Press the new "Add Multiple Payments" button
Verify the 2 payments created before are shown
Verify transaction date is set to today by default
Select all the payments and press done
Verify a successful message is shown with the number of transactions created
Verify the transactions are created and processed

(0078533)
psanjuan (manager)
2015-06-26 13:13
edited on: 2015-06-26 13:21

Verified.

Test plan above I and II verified.

Besides that it has also been verified that:

- Transaction date works OK, the transaction date entered is the one moved to the transactions created.
- All filters work ok
- Once a payment(s) are selected, all those ones are created as transactions already processed that can be reactivated and deleted, therefore are once again shown in the new window "Add Multiple Payments"
- Payment Made selected are created as BP Withdrawal transactions
- Payment Received selected are created as BP Deposit transactions
- Payments with status "Awaiting Execution" or "Remitted" are not shown
- Payments created in a different currency (i.e. USD) than Financial Account currency (i.e EUR) are also correctly shown, the correct amount in both currencies is shown ok and it is also move to the financial account transaction (Withdrawal/Deposit Amount and Foreign Amount)

(0078540)
hgbot (developer)
2015-06-26 15:12

Repository: erp/devel/pi
Changeset: 7e2d0fb062fac67f5a81264a2d076845f1b85385
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Thu Jun 25 10:20:46 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/7e2d0fb062fac67f5a81264a2d076845f1b85385 [^]

Fixed bug 30143: Add Multiple Payments in Financial Account

Due to the Add Transaction refactor, the ability to create transactions from several payments in a batch was missed.
This development adds a new button in Financial Account window (Add Multiple Payments) where the user must enter a transaction date and select one or more payments. The system will create a transaction per selected payment and it will process all of them. If any exception is raised at any point in time, no transactions will be created.

The payments shown in the P&E are exactly the same as in the payment selector at Transaction tab.
The great advantage of this process is that you can select multiple payments at the same time, and that the transactions are automatically processed, so it is very agile from the user point of view.

---
M modules/org.openbravo.advpaymentmngt/src-db/database/model/modifiedTables/FIN_FINANCIAL_ACCOUNT.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_ELEMENT.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_FIELD.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_MESSAGE.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_REFERENCE.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_TAB.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_WINDOW.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/OBUIAPP_PARAMETER.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/OBUIAPP_PROCESS.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/OBUIAPP_REF_WINDOW.xml
A modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/actionHandler/AddMultiplePaymentsHandler.java
---
(0078579)
hudsonbot (developer)
2015-06-30 00:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8d846f99ad0b [^]
Maturity status: Test
(0078586)
hgbot (developer)
2015-06-30 10:29

Repository: erp/devel/pi
Changeset: 3c0ec0ba6d2da4531200e9f2e396200be077f043
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Tue Jun 30 10:27:33 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3c0ec0ba6d2da4531200e9f2e396200be077f043 [^]

Related to issue 30143. Filters Add Payments Pop up by Financial Account
If a different Financial Account is selected it is taken into account
when creating the Transacion.

---
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_FIELD.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_TAB.xml
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/actionHandler/AddMultiplePaymentsHandler.java
---
(0078587)
dmiguelez (developer)
2015-06-30 10:30

Code Review + Testing Ok
(0078594)
hgbot (developer)
2015-06-30 14:20

Repository: erp/devel/pi
Changeset: 0562e0074222e6c68d5882133daffe40d8e940ec
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Tue Jun 30 14:19:30 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/0562e0074222e6c68d5882133daffe40d8e940ec [^]

Related to issue 30143: Synchronize Terminology

---
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_FIELD.xml
---
(0078601)
hudsonbot (developer)
2015-06-30 20:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a0fd6a76a3d5 [^]
Maturity status: Test
(0078603)
hudsonbot (developer)
2015-06-30 20:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a0fd6a76a3d5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-06-09 18:08 ngarcia New Issue
2015-06-09 18:08 ngarcia Assigned To => Triage Finance
2015-06-09 18:08 ngarcia Modules => Advanced Payables and Receivables Mngmt
2015-06-09 18:08 ngarcia Triggers an Emergency Pack => No
2015-06-09 18:10 ngarcia Issue Monitored: networkb
2015-06-19 08:51 vmromanos Note Added: 0078384
2015-06-19 09:19 vmromanos Note Added: 0078385
2015-06-19 09:19 vmromanos Type design defect => defect
2015-06-23 13:04 aferraz Assigned To Triage Finance => aferraz
2015-06-23 13:10 aferraz Relationship added related to 0030206
2015-06-24 11:26 vmromanos Status new => scheduled
2015-06-24 11:26 vmromanos Assigned To aferraz => vmromanos
2015-06-25 10:29 vmromanos Target Version => 3.0PR15Q3
2015-06-25 11:55 vmromanos Note Added: 0078501
2015-06-25 11:56 vmromanos Note Edited: 0078501 View Revisions
2015-06-26 13:13 psanjuan Note Added: 0078533
2015-06-26 13:15 psanjuan Note Edited: 0078533 View Revisions
2015-06-26 13:17 psanjuan Note Edited: 0078533 View Revisions
2015-06-26 13:21 psanjuan Note Edited: 0078533 View Revisions
2015-06-26 15:12 hgbot Checkin
2015-06-26 15:12 hgbot Note Added: 0078540
2015-06-26 15:12 hgbot Status scheduled => resolved
2015-06-26 15:12 hgbot Resolution open => fixed
2015-06-26 15:12 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/7e2d0fb062fac67f5a81264a2d076845f1b85385 [^]
2015-06-29 09:54 egoitz Issue Monitored: egoitz
2015-06-30 00:54 hudsonbot Checkin
2015-06-30 00:54 hudsonbot Note Added: 0078579
2015-06-30 10:29 hgbot Checkin
2015-06-30 10:29 hgbot Note Added: 0078586
2015-06-30 10:30 dmiguelez Review Assigned To => dmiguelez
2015-06-30 10:30 dmiguelez Note Added: 0078587
2015-06-30 10:30 dmiguelez Status resolved => closed
2015-06-30 14:20 hgbot Checkin
2015-06-30 14:20 hgbot Note Added: 0078594
2015-06-30 20:44 hudsonbot Checkin
2015-06-30 20:44 hudsonbot Note Added: 0078601
2015-06-30 20:44 hudsonbot Checkin
2015-06-30 20:44 hudsonbot Note Added: 0078603
2015-07-15 17:41 vmromanos Relationship added related to 0030372


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker