Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030111
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Retail Modules] Web POSminoralways2015-06-05 10:362015-07-27 17:31
ReportermalsasuaView Statuspublic 
Assigned ToRetail 
PriorityimmediateResolutionfixedFixed in VersionRR15Q2.3
StatusclosedFix in branchFixed in SCM revisione1ad3bf1fdae
ProjectionnoneETAnoneTarget VersionRR15Q2.3
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionpiSCM revision 
Review Assigned Toguilleaer
Regression levelProduction - QA Approved
Regression date2015-03-10
Regression introduced in releaseRR15Q2
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/7564ee29fa2f328e32f2ae33aa458dee4e89d7d5 [^]
Triggers an Emergency PackNo
Summary

0030111: keyboard discount button is disabled with preference set to N and automatic roles

DescriptionWhen the user is login with automatic role, and the preference "Web POS action Apply discount" is set to N, the keyboard discount button is disabled, and it should be enabled
Steps To Reproduce. login in webops with user vallblanca
. add new line in receipt
. select the line

keyboard discount button is disabled
Proposed Solutionthe line
https://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/file/tip/web/org.openbravo.mobile.core/source/component/ob-keyboard.js#l141 [^]

The problem is not in the changeset that created the regression, the problem is that the permission is wrong defined:
the second param in haspermission function, should be false.
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0030109 scheduledRetail keyboard discount button is disabled with preference set to N and automatic roles 

-  Notes
(0078845)
hgbot (developer)
2015-07-16 10:42

Repository: retail/backports/3.0RR15Q2.3/org.openbravo.mobile.core
Changeset: e1ad3bf1fdaec316c2e7234d958e1b75cf3f8d36
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Thu Jul 16 10:42:05 2015 +0200
URL: http://code.openbravo.com/retail/backports/3.0RR15Q2.3/org.openbravo.mobile.core/rev/e1ad3bf1fdaec316c2e7234d958e1b75cf3f8d36 [^]

Fixed issue 30111. Permission will be checked correctly for automatic roles.

---
M web/org.openbravo.mobile.core/source/component/ob-keyboard.js
---
(0079086)
guilleaer (developer)
2015-07-27 17:31

Tested & Verified

- Issue History
Date Modified Username Field Change
2015-06-05 10:37 malsasua Type defect => backport
2015-06-05 10:37 malsasua Target Version => RR15Q2.2
2015-06-10 13:19 dmitry_mezentsev Tag Attached: Approved
2015-06-17 16:31 marvintm Target Version RR15Q2.2 => RR15Q2.3
2015-07-16 10:42 hgbot Checkin
2015-07-16 10:42 hgbot Note Added: 0078845
2015-07-16 10:42 hgbot Status scheduled => resolved
2015-07-16 10:42 hgbot Resolution open => fixed
2015-07-16 10:42 hgbot Fixed in SCM revision => http://code.openbravo.com/retail/backports/3.0RR15Q2.3/org.openbravo.mobile.core/rev/e1ad3bf1fdaec316c2e7234d958e1b75cf3f8d36 [^]
2015-07-27 17:31 guilleaer Review Assigned To => guilleaer
2015-07-27 17:31 guilleaer Note Added: 0079086
2015-07-27 17:31 guilleaer Status resolved => closed
2015-07-27 17:31 guilleaer Fixed in Version => RR15Q2.3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker