Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030092
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2015-06-04 13:252015-06-15 09:26
ReportermalsasuaView Statuspublic 
Assigned ToNaroaIriarte 
PrioritynormalResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revision34641a1a0c78
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toalostale
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030092: WS template bo.xslt is not working fine

Descriptionthe links created by the WS template bo.xslt, are not working
Steps To Reproduceclick in URL:
https://livebuilds.openbravo.com/erp_main_pgsql/ws/dal/ADUser?template=bo.xslt [^]

click in some link, for example:
supervisor: Openbravo ( 100 ) (xml)

error is returned:
<ob:error xmlns:ob="http://www.openbravo.com"><message>No [^] WebService found using the name ADUser</message></ob:error>

The link is
https://livebuilds.openbravo.com/erp_main_pgsql/ws/ADUser/100?template=bo.xslt [^]
and it should be
https://livebuilds.openbravo.com/erp_main_pgsql/ws/dal/ADUser/100?template=bo.xslt [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0078184)
hgbot (developer)
2015-06-10 15:52

Repository: erp/devel/pi
Changeset: 34641a1a0c7807ba2559c69776e64fa9e3bf5723
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Wed Jun 10 15:51:06 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/34641a1a0c7807ba2559c69776e64fa9e3bf5723 [^]

Fixed issue 30092: the bo.xslt template is working wrong.

The problem was that it was not possible to get the correct url by clicking
in the links. For example, if you went to the url:

https://livebuilds.openbravo.com/erp_main_pgsql/ws/dal/ADUser?template=bo.xslt [^]

And you click in some link, the obtained url was:

https://livebuilds.openbravo.com/erp_main_pgsql/ws/ADUser/100?template=bo.xslt [^]

instead of:

https://livebuilds.openbravo.com/erp_main_pgsql/ws/dal/ADUser/100?template=bo.xslt [^]

The problem was in the bo.xslt template, in the href variable. It was being set wrong in some cases,
it removed one extra level from the url. This is OK when the url has the id after the entity name, like:

https://livebuilds.openbravo.com/erp_main_pgsql/ws/dal/ADUser/100?template=bo.xslt [^]

But in the case of not having the id after the entity name in the url, it is wrong to substract a level
from the url.

In this case, that does not have the id after the entity name, didn't work well:

https://livebuilds.openbravo.com/erp_main_pgsql/ws/dal/ADUser?template=bo.xslt [^]

The substraction of the level retuned a bad url, the "/dal" is missing:

https://livebuilds.openbravo.com/erp_main_pgsql/ws/ADUser/100?template=bo.xslt [^]

To fix this the bo.xslt has been changed, now it takes into account if the url contains the id after
the entity name. If it does, a level is substracted. If not, no.

The WebServiceUtil.applyTemplate method has been changed too. Now the parameter hasId is set here and is
passed to the bo.xslt. This boolean parameter is true if the url has the id after the entity name,
and false if not.

---
M src/org/openbravo/service/rest/bo.xslt
M src/org/openbravo/service/web/WebServiceUtil.java
---
(0078200)
hudsonbot (developer)
2015-06-11 00:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/29888743cfde [^]
Maturity status: Test
(0078276)
alostale (developer)
2015-06-15 09:26

code reviewed

tested with the 2 link types

- Issue History
Date Modified Username Field Change
2015-06-04 13:25 malsasua New Issue
2015-06-04 13:25 malsasua Assigned To => platform
2015-06-04 13:25 malsasua Web browser => Google Chrome
2015-06-04 13:25 malsasua Modules => Core
2015-06-04 13:25 malsasua Triggers an Emergency Pack => No
2015-06-04 13:28 malsasua Web browser Google Chrome => Google Chrome
2015-06-04 18:19 malsasua Web browser Google Chrome => Google Chrome
2015-06-04 18:19 malsasua Severity major => minor
2015-06-05 08:22 alostale Status new => scheduled
2015-06-05 08:22 alostale Assigned To platform => NaroaIriarte
2015-06-10 14:03 NaroaIriarte Issue Monitored: alostale
2015-06-10 14:03 NaroaIriarte Review Assigned To => alostale
2015-06-10 14:03 NaroaIriarte Web browser Google Chrome => Google Chrome
2015-06-10 15:52 hgbot Checkin
2015-06-10 15:52 hgbot Note Added: 0078184
2015-06-10 15:52 hgbot Status scheduled => resolved
2015-06-10 15:52 hgbot Resolution open => fixed
2015-06-10 15:52 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/34641a1a0c7807ba2559c69776e64fa9e3bf5723 [^]
2015-06-11 00:49 hudsonbot Checkin
2015-06-11 00:49 hudsonbot Note Added: 0078200
2015-06-15 09:26 alostale Note Added: 0078276
2015-06-15 09:26 alostale Status resolved => closed
2015-06-15 09:26 alostale Fixed in Version => 3.0PR15Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker