Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030070
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementminoralways2015-06-02 11:532015-06-03 18:55
ReporteraferrazView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision72a46a4bb692
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelCoding ( Testing )
Regression date2015-05-29
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/093fb9ca1c6d340260547fedf9fbc79ef60e5976 [^]
Triggers an Emergency PackNo
Summary

0030070: NPE in Payment In/Out Lines when navigating from Order/Invoice Payment Schedule and it is null

DescriptionNull Pointer Exception in Payment In Lines tab or Payment Out Lines tab, when navigating from Order Payment Schedule field or Invoice Payment Schedule field and it is null.
Steps To Reproduce- Go to Payment In window and create a header.
- Click on Add Details and add a line related to a GLItem (and not to a order nor to an invoice)
- Move to Lines tab. Click on Order Payment Schedule field to navigate to Sales Order Payment Plan tab.
- Realize a Null Pointer Exception is raised.
- Move to Lines tab. Click on Invoice Payment Schedule field to navigate to Sales Invoice Payment Plan tab.
- Realize a Null Pointer Exception is raised.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by design defect 0025355 closedfsoto82 Long time to show the lines on the payment in/out windows 

-  Notes
(0077999)
hgbot (developer)
2015-06-02 18:15

Repository: erp/devel/pi
Changeset: 72a46a4bb692a86e40761dc2b30b0f2518e586ac
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Tue Jun 02 11:59:51 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/72a46a4bb692a86e40761dc2b30b0f2518e586ac [^]

Fixes issue 30070: NPE when navigating from Payment In/Out Lines tab

ReferencedLink was checking reference record when navigating from Order Payment Schedule or Invoice Payment Schedule fields from Payment In Lines or Payment Out Lines tab; in order to know where the record had to navigate to.
When the value of this field was empty, a Null Pointer Exception was raised. Now, in this case, a "Record empty" exception will be raised.
Also, those fields will be now not displayed if their value is empty.
Duplicated Order Payment Schedule and Invoice Payment Schedule fields have been removed also in those tabs, what was causing an error in int-full-oracle-compile-all job.

---
M src-db/database/sourcedata/AD_FIELD.xml
M src/org/openbravo/erpCommon/utility/ReferencedLink.java
---
(0078000)
hgbot (developer)
2015-06-02 18:15

Repository: erp/devel/pi
Changeset: cf75c68bd2e0fe65361b3cfbd4c9e8894a8cd312
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Tue Jun 02 18:13:05 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/cf75c68bd2e0fe65361b3cfbd4c9e8894a8cd312 [^]

Related to issue 30070: code review improvements

Improved exception message with a bit of context.
Set Document No. related fields as centrally maintained = N and renamed to Invoice No. and Order No.

---
M src-db/database/sourcedata/AD_FIELD.xml
M src/org/openbravo/erpCommon/utility/ReferencedLink.java
---
(0078001)
vmromanos (developer)
2015-06-02 18:16

Code review + testing OK
(0078041)
hudsonbot (developer)
2015-06-03 18:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/084e25f8f2cd [^]
Maturity status: Test
(0078042)
hudsonbot (developer)
2015-06-03 18:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/084e25f8f2cd [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-06-02 11:53 aferraz New Issue
2015-06-02 11:53 aferraz Assigned To => aferraz
2015-06-02 11:53 aferraz Modules => Core
2015-06-02 11:53 aferraz Regression level => Coding ( Testing )
2015-06-02 11:53 aferraz Regression date => 2015-05-29
2015-06-02 11:53 aferraz Regression introduced in release => pi
2015-06-02 11:53 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/093fb9ca1c6d340260547fedf9fbc79ef60e5976 [^]
2015-06-02 11:53 aferraz Triggers an Emergency Pack => No
2015-06-02 12:01 aferraz Relationship added caused by 0025355
2015-06-02 14:40 aferraz Status new => scheduled
2015-06-02 18:15 hgbot Checkin
2015-06-02 18:15 hgbot Note Added: 0077999
2015-06-02 18:15 hgbot Status scheduled => resolved
2015-06-02 18:15 hgbot Resolution open => fixed
2015-06-02 18:15 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/72a46a4bb692a86e40761dc2b30b0f2518e586ac [^]
2015-06-02 18:15 hgbot Checkin
2015-06-02 18:15 hgbot Note Added: 0078000
2015-06-02 18:16 vmromanos Review Assigned To => vmromanos
2015-06-02 18:16 vmromanos Note Added: 0078001
2015-06-02 18:16 vmromanos Status resolved => closed
2015-06-03 18:55 hudsonbot Checkin
2015-06-03 18:55 hudsonbot Note Added: 0078041
2015-06-03 18:55 hudsonbot Checkin
2015-06-03 18:55 hudsonbot Note Added: 0078042


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker