Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030047
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2015-05-29 14:092015-06-05 01:33
ReportermaiteView Statuspublic 
Assigned Tojorge-garcia 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision843ebb54cf07
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030047: "US Finance" role should be able to select by account in General Ledger Report

DescriptionIn an organization structure similar to F&B, a role with access to "US" organization should be able to filter by specific accounts in General Ledger Report, although account tree is defined at F&B Organization
Steps To Reproduce1. Log in using "US Finance" role
2. Access General Ledger Report, open Account selector and realize that you are not able to see any account

However you are able to run report for all accounts and review accounting information
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0077947)
jorge-garcia (developer)
2015-06-01 15:46

Test Plan:

 AS "F&B US Finance" role:
   Access General Ledger Report, open Account selector and realize that you see accounts to select
(0078066)
hgbot (developer)
2015-06-04 13:59

Repository: erp/devel/pi
Changeset: 843ebb54cf075c2b805a662b884e5756db7cd5f3
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Mon Jun 01 13:20:50 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/843ebb54cf075c2b805a662b884e5756db7cd5f3 [^]

Fixed issue 30047: Finance role should be able to select a account in G/L Report

In an organization structure similar to F&B, a role with access to "US"
organization should be able to filter by specific accounts in General Ledger
Report, although account tree is defined at F&B Organization.

The problem was that the F&B US Finance role cannot select none of the accounts
defined for F&B International group.

The solution is to grant access to the accounts defined for F&B International
group. It has no sense that the user cannot select those accounts, but the user
can see the report with all it's accounts.

---
M src/org/openbravo/erpCommon/info/AccountElementValue.java
---
(0078067)
hgbot (developer)
2015-06-04 13:59

Repository: erp/devel/pi
Changeset: 9befee29287f306d6a7e0457683ebb83af0cf56d
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Thu Jun 04 13:59:03 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/9befee29287f306d6a7e0457683ebb83af0cf56d [^]

Related to issue 30047: updated copyright

---
M src/org/openbravo/erpCommon/info/AccountElementValue.java
---
(0078069)
vmromanos (developer)
2015-06-04 14:00

Code review + testing OK
(0078104)
hudsonbot (developer)
2015-06-05 01:33

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/aa05c3f56c97 [^]
Maturity status: Test
(0078105)
hudsonbot (developer)
2015-06-05 01:33

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/aa05c3f56c97 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-05-29 14:09 maite New Issue
2015-05-29 14:09 maite Assigned To => Triage Finance
2015-05-29 14:09 maite Modules => Core
2015-05-29 14:09 maite Triggers an Emergency Pack => No
2015-05-29 14:10 maite Issue Monitored: networkb
2015-06-01 10:28 jorge-garcia Assigned To Triage Finance => jorge-garcia
2015-06-01 10:28 jorge-garcia Status new => acknowledged
2015-06-01 15:46 jorge-garcia Note Added: 0077947
2015-06-04 13:08 vmromanos Status acknowledged => scheduled
2015-06-04 13:59 hgbot Checkin
2015-06-04 13:59 hgbot Note Added: 0078066
2015-06-04 13:59 hgbot Status scheduled => resolved
2015-06-04 13:59 hgbot Resolution open => fixed
2015-06-04 13:59 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/843ebb54cf075c2b805a662b884e5756db7cd5f3 [^]
2015-06-04 13:59 hgbot Checkin
2015-06-04 13:59 hgbot Note Added: 0078067
2015-06-04 14:00 vmromanos Review Assigned To => vmromanos
2015-06-04 14:00 vmromanos Note Added: 0078069
2015-06-04 14:00 vmromanos Status resolved => closed
2015-06-05 01:33 hudsonbot Checkin
2015-06-05 01:33 hudsonbot Note Added: 0078104
2015-06-05 01:33 hudsonbot Checkin
2015-06-05 01:33 hudsonbot Note Added: 0078105


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker