Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029992
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2015-05-25 10:452015-06-02 03:42
ReporterngarciaView Statuspublic 
Assigned Tovmromanos 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisiona9518a8e931b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2015-05-06
Regression introduced in releasemain
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/5772533f5768eba602eabec0bcc87e86c513f25d [^]
Triggers an Emergency PackNo
Summary

0029992: Cannot add stocked products with no stock in physical inventory lines

DescriptionCannot add stocked products with no stock in physical inventory lines
Steps To ReproduceAs group admin role:
   Create a Physical Inventory header
   Try to add a product set as Stocked = 'Y' in the Product window that does not have stock. Check you cannot add it although you clear the filter
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0028850 closedvmromanos It should not be possible to add non stocked products to a physical inventory 

-  Notes
(0077704)
vmromanos (developer)
2015-05-25 12:34

Test plan I:
Go to Product window.
Create a new record:
  Name: SSS
  Stocked: Y

Go to Physical Inventory.
Create a new header. Save it.
Go to lines.
Create a new record.
Open the product selector. Verify the SSS product doesn't appear by default because it doesn't have stock at this moment.
Clear the selector filter. Verify the SSS product is shown now.


Test plan II:
Go to Product window.
Find SSS product previously created.
Set Stocked = N
Save it.

Go to Physical Inventory.
Create a new header. Save it.
Go to lines.
Create a new record.
Open the product selector. Verify the SSS product doesn't appear by default.
Clear the selector filter. Verify the SSS product is NOT shown because is set as Stocked = N
(0077938)
hgbot (developer)
2015-06-01 13:10

Repository: erp/devel/pi
Changeset: a9518a8e931b9b0cfa1ed0e38de3126433becf8b
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Mon Jun 01 13:08:42 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a9518a8e931b9b0cfa1ed0e38de3126433becf8b [^]

Fixes Issue 29992. Fixes HQL Where Clause in OBUISEL_Selector definition.
It now filters by Products that are Stocked based on the Product definition
rather than the Stocked flag in the Storage Detail.

---
M src-db/database/sourcedata/AD_REFERENCE.xml
M src-db/database/sourcedata/OBUISEL_SELECTOR.xml
M src-db/database/sourcedata/OBUISEL_SELECTOR_FIELD.xml
---
(0077940)
dmiguelez (developer)
2015-06-01 13:11

Code Review + Testing Ok
(0077966)
hudsonbot (developer)
2015-06-02 03:42

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/14de467bd788 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-05-25 10:45 ngarcia New Issue
2015-05-25 10:45 ngarcia Assigned To => Triage Finance
2015-05-25 10:45 ngarcia Modules => Core
2015-05-25 10:45 ngarcia Regression date => 2015-05-06
2015-05-25 10:45 ngarcia Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/5772533f5768eba602eabec0bcc87e86c513f25d [^]
2015-05-25 10:45 ngarcia Triggers an Emergency Pack => No
2015-05-25 10:45 ngarcia Relationship added caused by 0028850
2015-05-25 10:46 ngarcia Issue Monitored: networkb
2015-05-25 11:28 vmromanos Regression level => Pre packaging ( pi )
2015-05-25 11:28 vmromanos Regression introduced in release => pi
2015-05-25 11:29 vmromanos Regression introduced in release pi => main
2015-05-25 11:29 vmromanos Status new => scheduled
2015-05-25 11:29 vmromanos Assigned To Triage Finance => vmromanos
2015-05-25 11:30 vmromanos Priority urgent => immediate
2015-05-25 12:34 vmromanos Note Added: 0077704
2015-06-01 13:10 hgbot Checkin
2015-06-01 13:10 hgbot Note Added: 0077938
2015-06-01 13:10 hgbot Status scheduled => resolved
2015-06-01 13:10 hgbot Resolution open => fixed
2015-06-01 13:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a9518a8e931b9b0cfa1ed0e38de3126433becf8b [^]
2015-06-01 13:11 dmiguelez Review Assigned To => dmiguelez
2015-06-01 13:11 dmiguelez Note Added: 0077940
2015-06-01 13:11 dmiguelez Status resolved => closed
2015-06-02 03:42 hudsonbot Checkin
2015-06-02 03:42 hudsonbot Note Added: 0077966


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker